summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDaniel Black <dragonheart@gentoo.org>2007-07-16 09:35:24 +0000
committerDaniel Black <dragonheart@gentoo.org>2007-07-16 09:35:24 +0000
commit73ee0c88d051509c1bb54615ffc7b585c1b6fa8d (patch)
treef22efee7423f222796ec4487a9456c478e0eae07 /sys-libs/libstatgrab/libstatgrab-0.15.ebuild
parentadded 2.2.6 rc1 (diff)
downloadgentoo-2-73ee0c88d051509c1bb54615ffc7b585c1b6fa8d.tar.gz
gentoo-2-73ee0c88d051509c1bb54615ffc7b585c1b6fa8d.tar.bz2
gentoo-2-73ee0c88d051509c1bb54615ffc7b585c1b6fa8d.zip
version bump
(Portage version: 2.1.2.9)
Diffstat (limited to 'sys-libs/libstatgrab/libstatgrab-0.15.ebuild')
-rw-r--r--sys-libs/libstatgrab/libstatgrab-0.15.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/sys-libs/libstatgrab/libstatgrab-0.15.ebuild b/sys-libs/libstatgrab/libstatgrab-0.15.ebuild
new file mode 100644
index 000000000000..fc7e17ef51e8
--- /dev/null
+++ b/sys-libs/libstatgrab/libstatgrab-0.15.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/libstatgrab/libstatgrab-0.15.ebuild,v 1.1 2007/07/16 09:35:24 dragonheart Exp $
+
+DESCRIPTION="Provides cross platform access to statistics about the system on which it's run."
+HOMEPAGE="http://www.i-scream.org/libstatgrab/"
+SRC_URI="http://www.mirrorservice.org/sites/ftp.i-scream.org/pub/i-scream/libstatgrab/${P}.tar.gz"
+
+LICENSE="|| ( GPL-2 LGPL-2.1 )"
+SLOT=0
+KEYWORDS="~amd64 ~ia64 ~ppc ~x86"
+IUSE=""
+RDEPEND=">=sys-libs/ncurses-5.4-r1
+ virtual/libc"
+
+DEPEND="${RDEPEND}
+ sys-apps/gawk
+ sys-apps/grep
+ sys-devel/gcc
+ dev-util/pkgconfig"
+
+src_compile() {
+ econf --disable-setgid-binaries --disable-setuid-binaries \
+ --disable-deprecated --with-ncurses || die "econf failed"
+ emake || die "emake failed"
+}
+
+src_install() {
+ emake DESTDIR=${D} install || die "einstall failed"
+ dodoc ChangeLog PLATFORMS NEWS AUTHORS README
+}