summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeffrey Gardner <je_fro@gentoo.org>2009-02-05 04:12:56 +0000
committerJeffrey Gardner <je_fro@gentoo.org>2009-02-05 04:12:56 +0000
commit870ebe11368b1a742d7bbccc273fedf6c88e4970 (patch)
tree2e960a7012ffd1f1906e9f5d1f308e7ac664bf23 /sys-libs/libstdc++-v3
parent(non maintainer commit) Don't use bundled intltool, causes problems for some ... (diff)
downloadgentoo-2-870ebe11368b1a742d7bbccc273fedf6c88e4970.tar.gz
gentoo-2-870ebe11368b1a742d7bbccc273fedf6c88e4970.tar.bz2
gentoo-2-870ebe11368b1a742d7bbccc273fedf6c88e4970.zip
Patch to compile with gcc-4.3.3, thanks to Magnus Granberg, closes bug #232102. Fixed repoman warnings galore.
(Portage version: 2.1.6.7/cvs/Linux x86_64)
Diffstat (limited to 'sys-libs/libstdc++-v3')
-rw-r--r--sys-libs/libstdc++-v3/ChangeLog7
-rw-r--r--sys-libs/libstdc++-v3/files/libstdc++-v3-open_missing_mode.patch12
-rw-r--r--sys-libs/libstdc++-v3/libstdc++-v3-3.3.3-r1.ebuild42
-rw-r--r--sys-libs/libstdc++-v3/libstdc++-v3-3.3.4.ebuild42
-rw-r--r--sys-libs/libstdc++-v3/libstdc++-v3-3.3.6.ebuild45
5 files changed, 84 insertions, 64 deletions
diff --git a/sys-libs/libstdc++-v3/ChangeLog b/sys-libs/libstdc++-v3/ChangeLog
index e905a61951bb..9e1cc4d1154c 100644
--- a/sys-libs/libstdc++-v3/ChangeLog
+++ b/sys-libs/libstdc++-v3/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sys-libs/libstdc++-v3
# Copyright 2000-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/libstdc++-v3/ChangeLog,v 1.55 2009/02/01 22:51:10 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/libstdc++-v3/ChangeLog,v 1.56 2009/02/05 04:12:56 je_fro Exp $
+
+ 05 Feb 2009; Jeff Gardner <je_fro@gentoo.org>
+ +files/libstdc++-v3-open_missing_mode.patch, libstdc++-v3-3.3.6.ebuild:
+ Patch to compile with gcc-4.3.3, thanks to Magnus Granberg, closes bug
+ #232102. Fixed repoman warnings galore.
01 Feb 2009; Michael Sterrett <mr_bones_@gentoo.org>
libstdc++-v3-3.3.3-r1.ebuild, libstdc++-v3-3.3.4.ebuild,
diff --git a/sys-libs/libstdc++-v3/files/libstdc++-v3-open_missing_mode.patch b/sys-libs/libstdc++-v3/files/libstdc++-v3-open_missing_mode.patch
new file mode 100644
index 000000000000..610fae2bb39b
--- /dev/null
+++ b/sys-libs/libstdc++-v3/files/libstdc++-v3-open_missing_mode.patch
@@ -0,0 +1,12 @@
+diff -Nru /var/tmp/portage/sys-libs/libstdc++-v3-3.3.6/work/gcc-3.3.6/gcc/collect2.c /root/hardened/gcc-3.3.6/gcc/collect2.c
+--- /gcc-3.3.6/gcc/collect2.c 2003-12-08 20:02:39.000000000 +0100
++++ /gcc-3.3.6/gcc/collect2.c 2008-06-19 01:04:21.000000000 +0200
+@@ -1572,7 +1572,7 @@
+ if (redir)
+ {
+ /* Open response file. */
+- redir_handle = open (redir, O_WRONLY | O_TRUNC | O_CREAT);
++ redir_handle = open (redir, O_WRONLY | O_TRUNC | O_CREAT, S_IRUSR | S_IWUSR);
+
+ /* Duplicate the stdout and stderr file handles
+ so they can be restored later. */
diff --git a/sys-libs/libstdc++-v3/libstdc++-v3-3.3.3-r1.ebuild b/sys-libs/libstdc++-v3/libstdc++-v3-3.3.3-r1.ebuild
index 4877a1708bdd..341eb96a7b79 100644
--- a/sys-libs/libstdc++-v3/libstdc++-v3-3.3.3-r1.ebuild
+++ b/sys-libs/libstdc++-v3/libstdc++-v3-3.3.3-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/libstdc++-v3/libstdc++-v3-3.3.3-r1.ebuild,v 1.43 2009/02/01 22:51:10 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/libstdc++-v3/libstdc++-v3-3.3.3-r1.ebuild,v 1.44 2009/02/05 04:12:56 je_fro Exp $
inherit eutils flag-o-matic libtool gnuconfig versionator
@@ -151,16 +151,16 @@ PDEPEND="sys-devel/gcc-config"
src_unpack() {
unpack ${A}
- cd ${S}
+ cd "${S}"
# Fixup libtool to correctly generate .la files with portage
elibtoolize --portage --shallow
- use amd64 && epatch ${FILESDIR}/libstdc++_amd64_multilib_hack.patch
+ use amd64 && epatch "${FILESDIR}"/libstdc++_amd64_multilib_hack.patch
# Misdesign in libstdc++ (Redhat)
- cp -a ${S}/libstdc++-v3/config/cpu/i{4,3}86/atomicity.h
+ cp -a "${S}"/libstdc++-v3/config/cpu/i{4,3}86/atomicity.h
- cd ${S}; ./contrib/gcc_update --touch &> /dev/null
+ cd "${S}"; ./contrib/gcc_update --touch &> /dev/null
gnuconfig_update
}
@@ -182,12 +182,12 @@ src_compile() {
einfo "CXXFLAGS=\"${CXXFLAGS}\""
# Build in a separate build tree
- mkdir -p ${WORKDIR}/build
- cd ${WORKDIR}/build
+ mkdir -p "${WORKDIR}"/build
+ cd "${WORKDIR}"/build
einfo "Configuring libstdc++..."
addwrite "/dev/zero"
- ${S}/configure --prefix=${LOC} \
+ "${S}"/configure --prefix=${LOC} \
--bindir=${BINPATH} \
--includedir=${LIBPATH}/include \
--datadir=${DATAPATH} \
@@ -208,7 +208,7 @@ src_compile() {
--with-local-prefix=${LOC}/local \
${myconf} || die
- touch ${S}/gcc/c-gperf.h
+ touch "${S}"/gcc/c-gperf.h
einfo "Compiling libstdc++..."
S="${WORKDIR}/build" \
@@ -222,7 +222,7 @@ src_install() {
# Do allow symlinks in ${LOC}/lib/gcc-lib/${CHOST}/${PV}/include as
# this can break the build.
- for x in ${WORKDIR}/build/gcc/include/*
+ for x in "${WORKDIR}"/build/gcc/include/*
do
if [ -L ${x} ]
then
@@ -232,7 +232,7 @@ src_install() {
done
# Remove generated headers, as they can cause things to break
# (ncurses, openssl, etc).
- for x in `find ${WORKDIR}/build/gcc/include/ -name '*.h'`
+ for x in `find "${WORKDIR}"/build/gcc/include/ -name '*.h'`
do
if grep -q 'It has been auto-edited by fixincludes from' ${x}
then
@@ -242,8 +242,8 @@ src_install() {
einfo "Installing libstdc++..."
# Do the 'make install' from the build directory
- cd ${WORKDIR}/build
- S="${WORKDIR}/build" \
+ cd "${WORKDIR}"/build
+ S="${WORKDIR}"/build \
make prefix=${LOC} \
bindir=${BINPATH} \
includedir=${LIBPATH}/include \
@@ -257,24 +257,24 @@ src_install() {
# we'll move this into a directory we can put at the end of ld.so.conf
# other than the normal versioned directory, so that it doesnt conflict
# with gcc 3.3.3
- mkdir -p ${D}/${LOC}/lib/libstdc++-v3/
- mv ${D}/${LIBPATH}/lib* ${D}/${LOC}/lib/libstdc++-v3/
+ mkdir -p "${D}"/${LOC}/lib/libstdc++-v3/
+ mv "${D}"/${LIBPATH}/lib* "${D}"/${LOC}/lib/libstdc++-v3/
# we dont want the headers...
- rm -rf ${D}/${LOC}/lib/gcc*
+ rm -rf "${D}"/${LOC}/lib/gcc*
# or locales...
- rm -rf ${D}/${LOC}/share
+ rm -rf "${D}"/${LOC}/share
# or anything other than the .so files, really.
- find ${D} | grep -e c++.la$ -e c++.a$ | xargs rm -f
+ find "${D}" | grep -e c++.la$ -e c++.a$ | xargs rm -f
# we dont even want the un-versioned .so symlink, as it confuses some
# apps and also causes others to link against the old libstdc++...
- rm ${D}/${LOC}/lib/libstdc++-v3/libstdc++.so
+ rm "${D}"/${LOC}/lib/libstdc++-v3/libstdc++.so
# and it's much easier to just move around the result than it is to
# configure libstdc++-v3 to use CONF_LIDIR
if [ "$(get_libdir)" != "lib" ] ; then
- mv ${D}/${LOC}/lib ${D}/${LOC}/$(get_libdir)
+ mv "${D}"/${LOC}/lib "${D}"/${LOC}/$(get_libdir)
fi
- mkdir -p ${D}/etc/env.d/
+ mkdir -p "${D}"/etc/env.d/
echo "LDPATH=\"${LOC}/lib/libstdc++-v3/\"" >> ${D}/etc/env.d/99libstdc++
}
diff --git a/sys-libs/libstdc++-v3/libstdc++-v3-3.3.4.ebuild b/sys-libs/libstdc++-v3/libstdc++-v3-3.3.4.ebuild
index 7f33032bf6c8..87869f72ddea 100644
--- a/sys-libs/libstdc++-v3/libstdc++-v3-3.3.4.ebuild
+++ b/sys-libs/libstdc++-v3/libstdc++-v3-3.3.4.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/libstdc++-v3/libstdc++-v3-3.3.4.ebuild,v 1.26 2009/02/01 22:51:10 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/libstdc++-v3/libstdc++-v3-3.3.4.ebuild,v 1.27 2009/02/05 04:12:56 je_fro Exp $
inherit eutils flag-o-matic libtool gnuconfig versionator
@@ -157,21 +157,21 @@ PDEPEND="sys-devel/gcc-config"
src_unpack() {
unpack ${A}
- cd ${S}
+ cd "${S}"
# Fixup libtool to correctly generate .la files with portage
elibtoolize --portage --shallow
if (has_multilib_profile || use multilib) ; then
sed -i \
-e 's:\(MULTILIB_OSDIRNAMES = \).*:\1../lib64 ../lib32:' \
- ${S}/gcc/config/i386/t-linux64 \
+ "${S}"/gcc/config/i386/t-linux64 \
|| die "sed failed!"
fi
# Misdesign in libstdc++ (Redhat)
- cp -a ${S}/libstdc++-v3/config/cpu/i{4,3}86/atomicity.h
+ cp -a "${S}"/libstdc++-v3/config/cpu/i{4,3}86/atomicity.h
- cd ${S}; ./contrib/gcc_update --touch &> /dev/null
+ cd "${S}"; ./contrib/gcc_update --touch &> /dev/null
gnuconfig_update
}
@@ -193,12 +193,12 @@ src_compile() {
einfo "CXXFLAGS=\"${CXXFLAGS}\""
# Build in a separate build tree
- mkdir -p ${WORKDIR}/build
- cd ${WORKDIR}/build
+ mkdir -p "${WORKDIR}"/build
+ cd "${WORKDIR}"/build
einfo "Configuring libstdc++..."
addwrite "/dev/zero"
- ${S}/configure --prefix=${LOC} \
+ "${S}"/configure --prefix=${LOC} \
--bindir=${BINPATH} \
--includedir=${LIBPATH}/include \
--datadir=${DATAPATH} \
@@ -219,7 +219,7 @@ src_compile() {
--with-local-prefix=${LOC}/local \
${myconf} || die
- touch ${S}/gcc/c-gperf.h
+ touch "${S}"/gcc/c-gperf.h
einfo "Compiling libstdc++..."
S="${WORKDIR}/build" \
@@ -233,7 +233,7 @@ src_install() {
# Do allow symlinks in ${LOC}/lib/gcc-lib/${CHOST}/${PV}/include as
# this can break the build.
- for x in ${WORKDIR}/build/gcc/include/*
+ for x in "${WORKDIR}"/build/gcc/include/*
do
if [ -L ${x} ]
then
@@ -243,7 +243,7 @@ src_install() {
done
# Remove generated headers, as they can cause things to break
# (ncurses, openssl, etc).
- for x in `find ${WORKDIR}/build/gcc/include/ -name '*.h'`
+ for x in `find "${WORKDIR}"/build/gcc/include/ -name '*.h'`
do
if grep -q 'It has been auto-edited by fixincludes from' ${x}
then
@@ -253,7 +253,7 @@ src_install() {
einfo "Installing libstdc++..."
# Do the 'make install' from the build directory
- cd ${WORKDIR}/build
+ cd "${WORKDIR}"/build
S="${WORKDIR}/build" \
make prefix=${LOC} \
bindir=${BINPATH} \
@@ -268,24 +268,24 @@ src_install() {
# we'll move this into a directory we can put at the end of ld.so.conf
# other than the normal versioned directory, so that it doesnt conflict
# with gcc 3.3.3
- mkdir -p ${D}/${LOC}/lib/libstdc++-v3/
- mv ${D}/${LIBPATH}/lib* ${D}/${LOC}/lib/libstdc++-v3/
+ mkdir -p "${D}"/${LOC}/lib/libstdc++-v3/
+ mv "${D}"/${LIBPATH}/lib* "${D}"/${LOC}/lib/libstdc++-v3/
# we dont want the headers...
- rm -rf ${D}/${LOC}/lib/gcc*
+ rm -rf "${D}"/${LOC}/lib/gcc*
# or locales...
- rm -rf ${D}/${LOC}/share
+ rm -rf "${D}"/${LOC}/share
# or anything other than the .so files, really.
- find ${D} | grep -e c++.la$ -e c++.a$ | xargs rm -f
+ find "${D}" | grep -e c++.la$ -e c++.a$ | xargs rm -f
# we dont even want the un-versioned .so symlink, as it confuses some
# apps and also causes others to link against the old libstdc++...
- rm ${D}/${LOC}/lib/libstdc++-v3/libstdc++.so
+ rm "${D}"/${LOC}/lib/libstdc++-v3/libstdc++.so
# and it's much easier to just move around the result than it is to
# configure libstdc++-v3 to use CONF_LIDIR
if [ "$(get_libdir)" != "lib" ] ; then
- mv ${D}/${LOC}/lib ${D}/${LOC}/$(get_libdir)
+ mv "${D}"/${LOC}/lib "${D}"/${LOC}/$(get_libdir)
fi
- mkdir -p ${D}/etc/env.d/
- echo "LDPATH=\"${LOC}/$(get_libdir)/libstdc++-v3/\"" >> ${D}/etc/env.d/99libstdc++
+ mkdir -p "${D}"/etc/env.d/
+ echo "LDPATH=\"${LOC}/$(get_libdir)/libstdc++-v3/\"" >> "${D}"/etc/env.d/99libstdc++
}
diff --git a/sys-libs/libstdc++-v3/libstdc++-v3-3.3.6.ebuild b/sys-libs/libstdc++-v3/libstdc++-v3-3.3.6.ebuild
index 20ae4c40ae02..4087f68bb076 100644
--- a/sys-libs/libstdc++-v3/libstdc++-v3-3.3.6.ebuild
+++ b/sys-libs/libstdc++-v3/libstdc++-v3-3.3.6.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/libstdc++-v3/libstdc++-v3-3.3.6.ebuild,v 1.19 2009/02/01 22:51:10 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/libstdc++-v3/libstdc++-v3-3.3.6.ebuild,v 1.20 2009/02/05 04:12:56 je_fro Exp $
inherit eutils flag-o-matic libtool gnuconfig versionator
@@ -157,21 +157,24 @@ PDEPEND="sys-devel/gcc-config"
src_unpack() {
unpack ${A}
- cd ${S}
+ cd "${S}"
+
+ epatch "${FILESDIR}"/libstdc++-v3-open_missing_mode.patch || die "epatch failed"
+
# Fixup libtool to correctly generate .la files with portage
elibtoolize --portage --shallow
if (has_multilib_profile || use multilib) ; then
sed -i \
-e 's:\(MULTILIB_OSDIRNAMES = \).*:\1../lib64 ../lib32:' \
- ${S}/gcc/config/i386/t-linux64 \
+ "${S}"/gcc/config/i386/t-linux64 \
|| die "sed failed!"
fi
# Misdesign in libstdc++ (Redhat)
- cp -pPR ${S}/libstdc++-v3/config/cpu/i{4,3}86/atomicity.h
+ cp -pPR "${S}"/libstdc++-v3/config/cpu/i{4,3}86/atomicity.h
- cd ${S}; ./contrib/gcc_update --touch &> /dev/null
+ cd "${S}"; ./contrib/gcc_update --touch &> /dev/null
gnuconfig_update
}
@@ -193,12 +196,12 @@ src_compile() {
einfo "CXXFLAGS=\"${CXXFLAGS}\""
# Build in a separate build tree
- mkdir -p ${WORKDIR}/build
- cd ${WORKDIR}/build
+ mkdir -p "${WORKDIR}"/build
+ cd "${WORKDIR}"/build
einfo "Configuring libstdc++..."
addwrite "/dev/zero"
- ${S}/configure --prefix=${LOC} \
+ "${S}"/configure --prefix=${LOC} \
--bindir=${BINPATH} \
--includedir=${LIBPATH}/include \
--datadir=${DATAPATH} \
@@ -219,7 +222,7 @@ src_compile() {
--with-local-prefix=${LOC}/local \
${myconf} || die
- touch ${S}/gcc/c-gperf.h
+ touch "${S}"/gcc/c-gperf.h
einfo "Compiling libstdc++..."
S="${WORKDIR}/build" \
@@ -233,7 +236,7 @@ src_install() {
# Do allow symlinks in ${LOC}/lib/gcc-lib/${CHOST}/${PV}/include as
# this can break the build.
- for x in ${WORKDIR}/build/gcc/include/*
+ for x in "${WORKDIR}"/build/gcc/include/*
do
if [ -L ${x} ]
then
@@ -243,7 +246,7 @@ src_install() {
done
# Remove generated headers, as they can cause things to break
# (ncurses, openssl, etc).
- for x in `find ${WORKDIR}/build/gcc/include/ -name '*.h'`
+ for x in `find "${WORKDIR}"/build/gcc/include/ -name '*.h'`
do
if grep -q 'It has been auto-edited by fixincludes from' ${x}
then
@@ -253,7 +256,7 @@ src_install() {
einfo "Installing libstdc++..."
# Do the 'make install' from the build directory
- cd ${WORKDIR}/build
+ cd "${WORKDIR}"/build
S="${WORKDIR}/build" \
make prefix=${LOC} \
bindir=${BINPATH} \
@@ -268,24 +271,24 @@ src_install() {
# we'll move this into a directory we can put at the end of ld.so.conf
# other than the normal versioned directory, so that it doesnt conflict
# with gcc 3.3.3
- mkdir -p ${D}/${LOC}/lib/libstdc++-v3/
- mv ${D}/${LIBPATH}/lib* ${D}/${LOC}/lib/libstdc++-v3/
+ mkdir -p "${D}"/${LOC}/lib/libstdc++-v3/
+ mv "${D}"/${LIBPATH}/lib* "${D}"/${LOC}/lib/libstdc++-v3/
# we dont want the headers...
- rm -rf ${D}/${LOC}/lib/gcc*
+ rm -rf "${D}"/${LOC}/lib/gcc*
# or locales...
- rm -rf ${D}/${LOC}/share
+ rm -rf "${D}"/${LOC}/share
# or anything other than the .so files, really.
- find ${D} | grep -e c++.la$ -e c++.a$ | xargs rm -f
+ find "${D}" | grep -e c++.la$ -e c++.a$ | xargs rm -f
# we dont even want the un-versioned .so symlink, as it confuses some
# apps and also causes others to link against the old libstdc++...
- rm ${D}/${LOC}/lib/libstdc++-v3/libstdc++.so
+ rm "${D}"/${LOC}/lib/libstdc++-v3/libstdc++.so
# and it's much easier to just move around the result than it is to
# configure libstdc++-v3 to use CONF_LIDIR
if [ "$(get_libdir)" != "lib" ] ; then
- mv ${D}/${LOC}/lib ${D}/${LOC}/$(get_libdir)
+ mv "${D}"/${LOC}/lib "${D}"/${LOC}/$(get_libdir)
fi
- mkdir -p ${D}/etc/env.d/
- echo "LDPATH=\"${LOC}/$(get_libdir)/libstdc++-v3/\"" >> ${D}/etc/env.d/99libstdc++
+ mkdir -p "${D}"/etc/env.d/
+ echo "LDPATH=\"${LOC}/$(get_libdir)/libstdc++-v3/\"" >> "${D}"/etc/env.d/99libstdc++
}