summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaurice van der Pot <griffon26@gentoo.org>2006-06-08 11:39:06 +0000
committerMaurice van der Pot <griffon26@gentoo.org>2006-06-08 11:39:06 +0000
commit04ffaa70f749df6b266647dfff47d4242ddf5681 (patch)
tree1e1e0b3f48abb38162ca7ddac67f0dfdf2470c37 /sys-libs/lwp/lwp-2.2.ebuild
parentVersion bump. (diff)
downloadgentoo-2-04ffaa70f749df6b266647dfff47d4242ddf5681.tar.gz
gentoo-2-04ffaa70f749df6b266647dfff47d4242ddf5681.tar.bz2
gentoo-2-04ffaa70f749df6b266647dfff47d4242ddf5681.zip
Added version 2.2 of lwp (threading lib for coda)
(Portage version: 2.1_rc4)
Diffstat (limited to 'sys-libs/lwp/lwp-2.2.ebuild')
-rw-r--r--sys-libs/lwp/lwp-2.2.ebuild34
1 files changed, 34 insertions, 0 deletions
diff --git a/sys-libs/lwp/lwp-2.2.ebuild b/sys-libs/lwp/lwp-2.2.ebuild
new file mode 100644
index 000000000000..5fa8aa7890b2
--- /dev/null
+++ b/sys-libs/lwp/lwp-2.2.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/lwp/lwp-2.2.ebuild,v 1.1 2006/06/08 11:39:06 griffon26 Exp $
+
+inherit eutils
+
+DESCRIPTION="Light weight process library (used by Coda). This is NOT libwww-perl."
+HOMEPAGE="http://www.coda.cs.cmu.edu/"
+SRC_URI="http://www.coda.cs.cmu.edu/pub/lwp/src/${P}.tar.gz"
+
+SLOT="1"
+LICENSE="LGPL-2.1"
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~mips ~ppc ~sparc ~x86"
+IUSE=""
+
+DEPEND="sys-apps/grep
+ sys-apps/sed
+ sys-devel/libtool
+ sys-devel/gcc"
+
+RDEPEND=""
+
+src_unpack() {
+ unpack ${A} ; cd ${S}
+
+ # Was introduced for bug #34542, not sure if still needed
+ use amd64 && epatch ${FILESDIR}/lwp-2.0-amd64.patch
+}
+
+src_install() {
+ einstall || die
+
+ dodoc AUTHORS NEWS PORTING README
+}