summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGeorge Shapovalov <george@gentoo.org>2010-05-09 12:07:47 +0000
committerGeorge Shapovalov <george@gentoo.org>2010-05-09 12:07:47 +0000
commitbfa64907af6ce14faba30b2936d3816da5459fce (patch)
treea8a5836777be27ce7b1fdeca1192ece3394d4071 /sys-libs/lwp/lwp-2.6.ebuild
parentVersion bump (diff)
downloadgentoo-2-bfa64907af6ce14faba30b2936d3816da5459fce.tar.gz
gentoo-2-bfa64907af6ce14faba30b2936d3816da5459fce.tar.bz2
gentoo-2-bfa64907af6ce14faba30b2936d3816da5459fce.zip
bumping in preparation for new coda version
(Portage version: 2.1.8.3/cvs/Linux x86_64)
Diffstat (limited to 'sys-libs/lwp/lwp-2.6.ebuild')
-rw-r--r--sys-libs/lwp/lwp-2.6.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/sys-libs/lwp/lwp-2.6.ebuild b/sys-libs/lwp/lwp-2.6.ebuild
new file mode 100644
index 000000000000..9b4ee61634cf
--- /dev/null
+++ b/sys-libs/lwp/lwp-2.6.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/lwp/lwp-2.6.ebuild,v 1.1 2010/05/09 12:07:47 george Exp $
+
+inherit eutils
+
+DESCRIPTION="Light weight process library (used by Coda). This is NOT libwww-perl."
+HOMEPAGE="http://www.coda.cs.cmu.edu/"
+SRC_URI="http://www.coda.cs.cmu.edu/pub/lwp/src/${P}.tar.gz"
+
+SLOT="1"
+LICENSE="LGPL-2.1"
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86"
+IUSE=""
+
+DEPEND="sys-apps/grep
+ sys-apps/sed
+ sys-devel/libtool
+ sys-devel/gcc"
+RDEPEND=""
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ # Was introduced for bug #34542, not sure if still needed
+ use amd64 && epatch "${FILESDIR}"/lwp-2.0-amd64.patch
+}
+
+src_install() {
+ einstall || die "einstall failed."
+ dodoc AUTHORS NEWS PORTING README
+}