summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLuca Barbato <lu_zero@gentoo.org>2008-11-14 12:06:05 +0000
committerLuca Barbato <lu_zero@gentoo.org>2008-11-14 12:06:05 +0000
commitfa6d631f343cafe571e8525c26df01afc2c629a0 (patch)
tree1c6aee6fedebc53b7af009e6a37aae3d15d47d7c /sys-libs/mars/mars-1.0.1.ebuild
parentMIT_Plus license required by mars (diff)
downloadgentoo-2-fa6d631f343cafe571e8525c26df01afc2c629a0.tar.gz
gentoo-2-fa6d631f343cafe571e8525c26df01afc2c629a0.tar.bz2
gentoo-2-fa6d631f343cafe571e8525c26df01afc2c629a0.zip
New version
(Portage version: 2.2_rc13/cvs/Linux 2.6.24-rc5-g31034440 ppc64)
Diffstat (limited to 'sys-libs/mars/mars-1.0.1.ebuild')
-rw-r--r--sys-libs/mars/mars-1.0.1.ebuild42
1 files changed, 42 insertions, 0 deletions
diff --git a/sys-libs/mars/mars-1.0.1.ebuild b/sys-libs/mars/mars-1.0.1.ebuild
new file mode 100644
index 000000000000..97b88d181606
--- /dev/null
+++ b/sys-libs/mars/mars-1.0.1.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/mars/mars-1.0.1.ebuild,v 1.1 2008/11/14 12:06:05 lu_zero Exp $
+
+inherit autotools
+
+MY_P=${P/mars/mars-src}
+
+DESCRIPTION="Multicore Application Runtime System"
+HOMEPAGE="ftp://ftp.infradead.org/pub/Sony-PS3/mars/"
+SRC_URI="ftp://ftp.infradead.org/pub/Sony-PS3/mars/1.0.1/${MY_P}.tar.gz"
+
+LICENSE="MIT_Plus MIT"
+SLOT="0"
+KEYWORDS="~ppc64"
+IUSE=""
+
+DEPEND="sys-libs/libspe2"
+RDEPEND="${DEPEND}"
+
+S="${WORKDIR}/${MY_P}/core"
+
+src_unpack () {
+ unpack ${A}
+ cd "${S}"
+ # repeat after me: "dummy tuples are bogus"
+ sed -i -e "s:/spu:/spu-elf:" \
+ -e "s:--host=spu:--host=spu-elf:" configure.ac
+ eautoreconf
+}
+
+src_compile () {
+ unset CFLAGS
+ unset CXXFLAGS
+ unset CFLAGS_ppc64
+ econf --with-mars-platform=cell || die
+ emake || die
+}
+
+src_install () {
+ emake -j1 DESTDIR="${D}" install
+}