summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2015-02-27 08:01:12 +0000
committerMike Frysinger <vapier@gentoo.org>2015-02-27 08:01:12 +0000
commite628908e469aad2bc8b0437c4f8500223609f1ee (patch)
tree445b2e980791f03f4f16c5110358423d5197b9bb /sys-libs/newlib/newlib-1.19.0.ebuild
parentVersion Bump (diff)
downloadgentoo-2-e628908e469aad2bc8b0437c4f8500223609f1ee.tar.gz
gentoo-2-e628908e469aad2bc8b0437c4f8500223609f1ee.tar.bz2
gentoo-2-e628908e469aad2bc8b0437c4f8500223609f1ee.zip
Use more readable CTARGET setup logic.
(Portage version: 2.2.17/cvs/Linux x86_64, signed Manifest commit with key D2E96200)
Diffstat (limited to 'sys-libs/newlib/newlib-1.19.0.ebuild')
-rw-r--r--sys-libs/newlib/newlib-1.19.0.ebuild8
1 files changed, 4 insertions, 4 deletions
diff --git a/sys-libs/newlib/newlib-1.19.0.ebuild b/sys-libs/newlib/newlib-1.19.0.ebuild
index 0afb51d75046..1fcedb4c7781 100644
--- a/sys-libs/newlib/newlib-1.19.0.ebuild
+++ b/sys-libs/newlib/newlib-1.19.0.ebuild
@@ -1,14 +1,14 @@
-# Copyright 1999-2013 Gentoo Foundation
+# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/newlib/newlib-1.19.0.ebuild,v 1.3 2013/02/09 04:40:10 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/newlib/newlib-1.19.0.ebuild,v 1.4 2015/02/27 08:01:12 vapier Exp $
inherit eutils flag-o-matic toolchain-funcs
export CBUILD=${CBUILD:-${CHOST}}
export CTARGET=${CTARGET:-${CHOST}}
if [[ ${CTARGET} == ${CHOST} ]] ; then
- if [[ ${CATEGORY/cross-} != ${CATEGORY} ]] ; then
- export CTARGET=${CATEGORY/cross-}
+ if [[ ${CATEGORY} == cross-* ]] ; then
+ export CTARGET=${CATEGORY#cross-}
fi
fi