summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTravis Tilley <lv@gentoo.org>2004-08-15 06:33:08 +0000
committerTravis Tilley <lv@gentoo.org>2004-08-15 06:33:08 +0000
commit4eef209cd29af56a53f625f51e61ed9a39c8115a (patch)
tree50b442f7228bce066c754f13129212e2bc516504 /sys-libs/readline
parentmake ARCH happy #56763 (Manifest recommit) (diff)
downloadgentoo-2-4eef209cd29af56a53f625f51e61ed9a39c8115a.tar.gz
gentoo-2-4eef209cd29af56a53f625f51e61ed9a39c8115a.tar.bz2
gentoo-2-4eef209cd29af56a53f625f51e61ed9a39c8115a.zip
added CONF_LIBDIR support and changed make install to einstall to avoid a sandbox violation that occurs when CONF_LIBDIR is set
Diffstat (limited to 'sys-libs/readline')
-rw-r--r--sys-libs/readline/ChangeLog7
-rw-r--r--sys-libs/readline/readline-4.3-r5.ebuild33
-rw-r--r--sys-libs/readline/readline-4.3-r6.ebuild33
-rw-r--r--sys-libs/readline/readline-5.0.ebuild16
4 files changed, 58 insertions, 31 deletions
diff --git a/sys-libs/readline/ChangeLog b/sys-libs/readline/ChangeLog
index 928c0f28d6c8..bba61fcd9f71 100644
--- a/sys-libs/readline/ChangeLog
+++ b/sys-libs/readline/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sys-libs/readline
# Copyright 2002-2004 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/readline/ChangeLog,v 1.32 2004/07/29 02:11:42 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/readline/ChangeLog,v 1.33 2004/08/15 06:33:08 lv Exp $
+
+ 14 Aug 2004; Travis Tilley <lv@gentoo.org> readline-4.3-r5.ebuild,
+ readline-4.3-r6.ebuild, readline-5.0.ebuild:
+ added CONF_LIBDIR support and changed make install to einstall to avoid a
+ sandbox violation that occurs when CONF_LIBDIR is set
*readline-5.0 (28 Jul 2004)
diff --git a/sys-libs/readline/readline-4.3-r5.ebuild b/sys-libs/readline/readline-4.3-r5.ebuild
index cddeaf2920ec..df8d33fdebd3 100644
--- a/sys-libs/readline/readline-4.3-r5.ebuild
+++ b/sys-libs/readline/readline-4.3-r5.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/readline/readline-4.3-r5.ebuild,v 1.13 2004/07/29 02:11:42 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/readline/readline-4.3-r5.ebuild,v 1.14 2004/08/15 06:33:08 lv Exp $
inherit eutils gnuconfig
@@ -35,6 +35,14 @@ src_unpack() {
gnuconfig_update
}
+pkg_setup() {
+ # this adds support for installing to lib64/lib32. since only portage
+ # 2.0.51 will have this functionality supported in dolib and friends,
+ # and since it isnt expected that many profiles will define it, we need
+ # to make this variable default to lib.
+ [ -z "${CONF_LIBDIR}" ] && export CONF_LIBDIR="lib"
+}
+
src_compile() {
econf --with-curses || die
@@ -45,27 +53,25 @@ src_compile() {
src_install() {
- make prefix=${D}/usr mandir=${D}/usr/share/man \
- infodir=${D}/usr/share/info install || die
+ einstall || die
cd ${S}/shlib
- make prefix=${D}/usr mandir=${D}/usr/share/man \
- infodir=${D}/usr/share/info install || die
+ einstall || die
cd ${S}
- dodir /lib
- mv ${D}/usr/lib/*.so* ${D}/lib
- rm -f ${D}/lib/*.old
+ dodir /${CONF_LIBDIR}
+ mv ${D}/usr/${CONF_LIBDIR}/*.so* ${D}/${CONF_LIBDIR}
+ rm -f ${D}/${CONF_LIBDIR}/*.old
# bug #4411
gen_usr_ldscript libreadline.so
gen_usr_ldscript libhistory.so
# end bug #4411
- dosym libhistory.so.${PV/a/} /lib/libhistory.so
- dosym libreadline.so.${PV/a/} /lib/libreadline.so
+ dosym libhistory.so.${PV/a/} /${CONF_LIBDIR}/libhistory.so
+ dosym libreadline.so.${PV/a/} /${CONF_LIBDIR}/libreadline.so
# Needed because make install uses ${D} for the link
- dosym libhistory.so.${PV/a/} /lib/libhistory.so.4
- dosym libreadline.so.${PV/a/} /lib/libreadline.so.4
- chmod 755 ${D}/lib/*.${PV/a/}
+ dosym libhistory.so.${PV/a/} /${CONF_LIBDIR}/libhistory.so.4
+ dosym libreadline.so.${PV/a/} /${CONF_LIBDIR}/libreadline.so.4
+ chmod 755 ${D}/${CONF_LIBDIR}/*.${PV/a/}
dodoc CHANGELOG CHANGES README USAGE
docinto ps
@@ -74,6 +80,7 @@ src_install() {
# Backwards compatibility #29865
if [ -e ${ROOT}/lib/libreadline.so.4.1 ] ; then
+ [ "${CONF_LIBDIR}" != "lib" ] && dodir /lib
cp -a ${ROOT}/lib/libreadline.so.4.1 ${D}/lib/
touch ${D}/lib/libreadline.so.4.1
fi
diff --git a/sys-libs/readline/readline-4.3-r6.ebuild b/sys-libs/readline/readline-4.3-r6.ebuild
index c4b6b806ad63..0fa26df2e936 100644
--- a/sys-libs/readline/readline-4.3-r6.ebuild
+++ b/sys-libs/readline/readline-4.3-r6.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/readline/readline-4.3-r6.ebuild,v 1.3 2004/07/29 02:11:42 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/readline/readline-4.3-r6.ebuild,v 1.4 2004/08/15 06:33:08 lv Exp $
inherit eutils gnuconfig
@@ -36,6 +36,14 @@ src_unpack() {
gnuconfig_update
}
+pkg_setup() {
+ # this adds support for installing to lib64/lib32. since only portage
+ # 2.0.51 will have this functionality supported in dolib and friends,
+ # and since it isnt expected that many profiles will define it, we need
+ # to make this variable default to lib.
+ [ -z "${CONF_LIBDIR}" ] && export CONF_LIBDIR="lib"
+}
+
src_compile() {
econf --with-curses || die
@@ -46,28 +54,26 @@ src_compile() {
src_install() {
- make prefix=${D}/usr mandir=${D}/usr/share/man \
- infodir=${D}/usr/share/info install || die
+ einstall || die
cd ${S}/shlib
- make prefix=${D}/usr mandir=${D}/usr/share/man \
- infodir=${D}/usr/share/info install || die
+ einstall || die
cd ${S}
if ! use macos; then
- dodir /lib
- mv ${D}/usr/lib/*.so* ${D}/lib
- rm -f ${D}/lib/*.old
+ dodir /${CONF_LIBDIR}
+ mv ${D}/usr/${CONF_LIBDIR}/*.so* ${D}/${CONF_LIBDIR}
+ rm -f ${D}/${CONF_LIBDIR}/*.old
# bug #4411
gen_usr_ldscript libreadline.so
gen_usr_ldscript libhistory.so
# end bug #4411
- dosym libhistory.so.${PV/a/} /lib/libhistory.so
- dosym libreadline.so.${PV/a/} /lib/libreadline.so
+ dosym libhistory.so.${PV/a/} /${CONF_LIBDIR}/libhistory.so
+ dosym libreadline.so.${PV/a/} /${CONF_LIBDIR}/libreadline.so
# Needed because make install uses ${D} for the link
- dosym libhistory.so.${PV/a/} /lib/libhistory.so.4
- dosym libreadline.so.${PV/a/} /lib/libreadline.so.4
- chmod 755 ${D}/lib/*.${PV/a/}
+ dosym libhistory.so.${PV/a/} /${CONF_LIBDIR}/libhistory.so.4
+ dosym libreadline.so.${PV/a/} /${CONF_LIBDIR}/libreadline.so.4
+ chmod 755 ${D}/${CONF_LIBDIR}/*.${PV/a/}
fi
dodoc CHANGELOG CHANGES README USAGE
@@ -77,6 +83,7 @@ src_install() {
# Backwards compatibility #29865
if [ -e ${ROOT}/lib/libreadline.so.4.1 ] ; then
+ [ "${CONF_LIBDIR}" != "lib" ] && dodir /lib
cp -a ${ROOT}/lib/libreadline.so.4.1 ${D}/lib/
touch ${D}/lib/libreadline.so.4.1
fi
diff --git a/sys-libs/readline/readline-5.0.ebuild b/sys-libs/readline/readline-5.0.ebuild
index cbe4939bf6fb..28c8d190e58e 100644
--- a/sys-libs/readline/readline-5.0.ebuild
+++ b/sys-libs/readline/readline-5.0.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/readline/readline-5.0.ebuild,v 1.1 2004/07/29 02:11:42 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/readline/readline-5.0.ebuild,v 1.2 2004/08/15 06:33:08 lv Exp $
inherit eutils gnuconfig
@@ -36,15 +36,23 @@ src_unpack() {
gnuconfig_update
}
+pkg_setup() {
+ # this adds support for installing to lib64/lib32. since only portage
+ # 2.0.51 will have this functionality supported in dolib and friends,
+ # and since it isnt expected that many profiles will define it, we need
+ # to make this variable default to lib.
+ [ -z "${CONF_LIBDIR}" ] && export CONF_LIBDIR="lib"
+}
+
src_compile() {
econf --with-curses || die
emake || die
}
src_install() {
- make install DESTDIR=${D} || die
- dodir /lib
- mv ${D}/usr/lib/*.so* ${D}/lib
+ einstall || die
+ dodir /${CONF_LIBDIR}
+ mv ${D}/usr/${CONF_LIBDIR}/*.so* ${D}/${CONF_LIBDIR}
# Bug #4411
gen_usr_ldscript libreadline.so