summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSergei Trofimovich <slyfox@gentoo.org>2013-11-19 12:41:59 +0000
committerSergei Trofimovich <slyfox@gentoo.org>2013-11-19 12:41:59 +0000
commitb363360851e4556dfc9c572bd65a97afdb9fe1c1 (patch)
treece3ffcacfad0df327505cc4b94b3f609032d5751 /sys-libs/slang
parentadded missing DEPEND: dev-perl/Task-Weaken wrt bug #488232 (diff)
downloadgentoo-2-b363360851e4556dfc9c572bd65a97afdb9fe1c1.tar.gz
gentoo-2-b363360851e4556dfc9c572bd65a97afdb9fe1c1.tar.bz2
gentoo-2-b363360851e4556dfc9c572bd65a97afdb9fe1c1.zip
Fix implicit memset() declaration in png module.
(Portage version: 2.2.7_p18/cvs/Linux x86_64, signed Manifest commit with key 611FF3AA)
Diffstat (limited to 'sys-libs/slang')
-rw-r--r--sys-libs/slang/ChangeLog8
-rw-r--r--sys-libs/slang/files/slang-2.2.4-memset.patch32
-rw-r--r--sys-libs/slang/slang-2.2.4.ebuild5
3 files changed, 41 insertions, 4 deletions
diff --git a/sys-libs/slang/ChangeLog b/sys-libs/slang/ChangeLog
index ff22569f0663..208b07fc8524 100644
--- a/sys-libs/slang/ChangeLog
+++ b/sys-libs/slang/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for sys-libs/slang
-# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/slang/ChangeLog,v 1.133 2012/10/08 00:45:28 naota Exp $
+# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/slang/ChangeLog,v 1.134 2013/11/19 12:41:59 slyfox Exp $
+
+ 19 Nov 2013; Sergei Trofimovich <slyfox@gentoo.org>
+ +files/slang-2.2.4-memset.patch, slang-2.2.4.ebuild:
+ Fix implicit memset() declaration in png module.
08 Oct 2012; <naota@gentoo.org> slang-2.2.4.ebuild:
Install also pkg-config file. #433732
diff --git a/sys-libs/slang/files/slang-2.2.4-memset.patch b/sys-libs/slang/files/slang-2.2.4-memset.patch
new file mode 100644
index 000000000000..0be90fdc3091
--- /dev/null
+++ b/sys-libs/slang/files/slang-2.2.4-memset.patch
@@ -0,0 +1,32 @@
+From e06be392e42c23dd9bd7205445f3c5232ddb9ed7 Mon Sep 17 00:00:00 2001
+From: Sergei Trofimovich <slyfox@gentoo.org>
+Date: Tue, 19 Nov 2013 15:17:52 +0300
+Subject: [PATCH] modules/png-module.c: add declaration of 'memset'
+MIME-Version: 1.0
+Content-Type: text/plain; charset=UTF-8
+Content-Transfer-Encoding: 8bit
+
+ * QA Notice: Package triggers severe warnings which indicate that it
+ * may exhibit random runtime failures.
+ * /tmp/portage/sys-libs/slang-2.2.4/work/slang-2.2.4/modules/png-module.c:122:2: warning: incompatible implicit declaration of built-in function ‘memset’ [enabled by default]
+
+Signed-off-by: Sergei Trofimovich <slyfox@gentoo.org>
+---
+ modules/png-module.c | 1 +
+ 3 files changed, 403 insertions(+), 259 deletions(-)
+
+diff --git a/modules/png-module.c b/modules/png-module.c
+index 92ede3d..fed9392 100644
+--- a/modules/png-module.c
++++ b/modules/png-module.c
+@@ -23,6 +23,7 @@ USA.
+ #include "config.h"
+
+ #include <stdio.h>
++#include <string.h> /* memset() */
+ #include <errno.h>
+ #include <slang.h>
+
+--
+1.8.4
+
diff --git a/sys-libs/slang/slang-2.2.4.ebuild b/sys-libs/slang/slang-2.2.4.ebuild
index a924a3f1ad6e..5458253ebb23 100644
--- a/sys-libs/slang/slang-2.2.4.ebuild
+++ b/sys-libs/slang/slang-2.2.4.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2012 Gentoo Foundation
+# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/slang/slang-2.2.4.ebuild,v 1.13 2012/10/08 00:45:28 naota Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/slang/slang-2.2.4.ebuild,v 1.14 2013/11/19 12:41:59 slyfox Exp $
EAPI=4
inherit eutils
@@ -27,6 +27,7 @@ MAKEOPTS="${MAKEOPTS} -j1"
src_prepare() {
epatch "${FILESDIR}"/${PN}-2.2.3-slsh-libs.patch
+ epatch "${FILESDIR}"/${PN}-2.2.4-memset.patch
# avoid linking to -ltermcap race with some systems
sed -i -e '/^TERMCAP=/s:=.*:=:' configure || die