summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorVictor Ostorga <vostorga@gentoo.org>2011-04-01 15:04:52 +0000
committerVictor Ostorga <vostorga@gentoo.org>2011-04-01 15:04:52 +0000
commit7a132270349d65f5ee113f7009a6bacee9a24487 (patch)
tree016e9936aef79dd8b807dd4fcb25c26dda26d040 /sys-libs/tdb/tdb-1.2.1.ebuild
parentsys-kernel/dracut: Version bump to 010. No, it's not a joke. (diff)
downloadgentoo-2-7a132270349d65f5ee113f7009a6bacee9a24487.tar.gz
gentoo-2-7a132270349d65f5ee113f7009a6bacee9a24487.tar.bz2
gentoo-2-7a132270349d65f5ee113f7009a6bacee9a24487.zip
Restricting working python version to 2.x bug #360033 . Adding double blocker to previous tdb version #314611
(Portage version: 2.1.9.42/cvs/Linux i686)
Diffstat (limited to 'sys-libs/tdb/tdb-1.2.1.ebuild')
-rw-r--r--sys-libs/tdb/tdb-1.2.1.ebuild16
1 files changed, 12 insertions, 4 deletions
diff --git a/sys-libs/tdb/tdb-1.2.1.ebuild b/sys-libs/tdb/tdb-1.2.1.ebuild
index bd84627abb42..e8b81cdb9a0d 100644
--- a/sys-libs/tdb/tdb-1.2.1.ebuild
+++ b/sys-libs/tdb/tdb-1.2.1.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2010 Gentoo Foundation
+# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/tdb/tdb-1.2.1.ebuild,v 1.8 2010/08/12 01:14:43 josejx Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/tdb/tdb-1.2.1.ebuild,v 1.9 2011/04/01 15:04:52 vostorga Exp $
EAPI="2"
-
+PYTHON_DEPEND="python? 2:2.6"
inherit autotools python
DESCRIPTION="Samba tdb"
@@ -14,13 +14,21 @@ SLOT="0"
KEYWORDS="alpha amd64 arm hppa ia64 ppc ppc64 s390 sh sparc x86"
IUSE="python static-libs tools tdbtest"
-RDEPEND=""
+RDEPEND="!!<sys-libs/tdb-1.2.1"
DEPEND="python? ( dev-lang/python )
!<net-fs/samba-libs-3.4
!<net-fs/samba-3.3
app-text/docbook-xsl-stylesheets
dev-libs/libxslt"
+pkg_setup() {
+ if use python; then
+ # Make sure the build system will use the right python bug #360033
+ python_set_active_version 2
+ python_pkg_setup
+ fi
+}
+
src_prepare() {
eautoconf -Ilibreplace
sed -i \