summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLars Wendler <polynomial-c@gentoo.org>2014-03-23 20:00:38 +0000
committerLars Wendler <polynomial-c@gentoo.org>2014-03-23 20:00:38 +0000
commitd0b069f8ca1550d48039d891f4aaf59b2796d53b (patch)
tree69aa7bc06132c0cd8576322bc5aea63a538aad1e /sys-libs/tdb/tdb-1.2.13.ebuild
parentVersion bump. (diff)
downloadgentoo-2-d0b069f8ca1550d48039d891f4aaf59b2796d53b.tar.gz
gentoo-2-d0b069f8ca1550d48039d891f4aaf59b2796d53b.tar.bz2
gentoo-2-d0b069f8ca1550d48039d891f4aaf59b2796d53b.zip
Version bump
(Portage version: 2.2.9-r1/cvs/Linux x86_64, signed Manifest commit with key 0x981CA6FC)
Diffstat (limited to 'sys-libs/tdb/tdb-1.2.13.ebuild')
-rw-r--r--sys-libs/tdb/tdb-1.2.13.ebuild40
1 files changed, 40 insertions, 0 deletions
diff --git a/sys-libs/tdb/tdb-1.2.13.ebuild b/sys-libs/tdb/tdb-1.2.13.ebuild
new file mode 100644
index 000000000000..4b8a7e5b17b5
--- /dev/null
+++ b/sys-libs/tdb/tdb-1.2.13.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/tdb/tdb-1.2.13.ebuild,v 1.1 2014/03/23 20:00:38 polynomial-c Exp $
+
+EAPI=5
+
+PYTHON_COMPAT=( python{2_6,2_7} )
+
+inherit waf-utils python-single-r1
+
+DESCRIPTION="A simple database API"
+HOMEPAGE="http://tdb.samba.org/"
+SRC_URI="http://samba.org/ftp/tdb/${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~arm-linux ~x86-linux"
+IUSE="python"
+
+REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )"
+
+RDEPEND="python? ( ${PYTHON_DEPS} )"
+DEPEND="
+ ${RDEPEND}
+ app-text/docbook-xml-dtd:4.2"
+
+WAF_BINARY="${S}/buildtools/bin/waf"
+
+src_configure() {
+ local extra_opts=""
+ use python || extra_opts+=" --disable-python"
+ waf-utils_src_configure \
+ ${extra_opts}
+}
+
+src_test() {
+ # the default src_test runs 'make test' and 'make check', letting
+ # the tests fail occasionally (reason: unknown)
+ emake check
+}