summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLars Wendler <polynomial-c@gentoo.org>2014-12-02 08:20:46 +0000
committerLars Wendler <polynomial-c@gentoo.org>2014-12-02 08:20:46 +0000
commitb8ccff67f7bd4d84e3be4fb0a7d178774b2006c8 (patch)
treea8a561fa56d3c42300b769b531a5714f1f9d63e9 /sys-libs/tdb
parentadd pypy3 support (diff)
downloadgentoo-2-b8ccff67f7bd4d84e3be4fb0a7d178774b2006c8.tar.gz
gentoo-2-b8ccff67f7bd4d84e3be4fb0a7d178774b2006c8.tar.bz2
gentoo-2-b8ccff67f7bd4d84e3be4fb0a7d178774b2006c8.zip
Version bump. Removed old
(Portage version: 2.2.14/cvs/Linux x86_64, signed Manifest commit with key 0x981CA6FC)
Diffstat (limited to 'sys-libs/tdb')
-rw-r--r--sys-libs/tdb/ChangeLog8
-rw-r--r--sys-libs/tdb/tdb-1.2.10.ebuild42
-rw-r--r--sys-libs/tdb/tdb-1.2.11.ebuild42
-rw-r--r--sys-libs/tdb/tdb-1.2.13.ebuild40
-rw-r--r--sys-libs/tdb/tdb-1.3.2.ebuild59
5 files changed, 66 insertions, 125 deletions
diff --git a/sys-libs/tdb/ChangeLog b/sys-libs/tdb/ChangeLog
index f01826d61aa3..6da045d5ccc5 100644
--- a/sys-libs/tdb/ChangeLog
+++ b/sys-libs/tdb/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sys-libs/tdb
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/tdb/ChangeLog,v 1.77 2014/11/11 22:28:47 floppym Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/tdb/ChangeLog,v 1.78 2014/12/02 08:20:46 polynomial-c Exp $
+
+*tdb-1.3.2 (02 Dec 2014)
+
+ 02 Dec 2014; Lars Wendler <polynomial-c@gentoo.org> -tdb-1.2.10.ebuild,
+ -tdb-1.2.11.ebuild, -tdb-1.2.13.ebuild, +tdb-1.3.2.ebuild:
+ Version bump. Removed old.
11 Nov 2014; Mike Gilbert <floppym@gentoo.org> tdb-1.3.0-r1.ebuild,
tdb-1.3.1.ebuild:
diff --git a/sys-libs/tdb/tdb-1.2.10.ebuild b/sys-libs/tdb/tdb-1.2.10.ebuild
deleted file mode 100644
index ef996a48db13..000000000000
--- a/sys-libs/tdb/tdb-1.2.10.ebuild
+++ /dev/null
@@ -1,42 +0,0 @@
-# Copyright 1999-2013 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/tdb/tdb-1.2.10.ebuild,v 1.8 2013/08/07 12:29:07 polynomial-c Exp $
-
-EAPI=3
-PYTHON_DEPEND="python? 2"
-RESTRICT_PYTHON_ABIS="3.* *-jython 2.7-pypy-*"
-
-inherit waf-utils python
-
-DESCRIPTION="A simple database API"
-HOMEPAGE="http://tdb.samba.org/"
-SRC_URI="http://samba.org/ftp/tdb/${P}.tar.gz"
-
-LICENSE="GPL-3"
-SLOT="0"
-KEYWORDS="hppa ppc ppc64"
-IUSE="python"
-
-RDEPEND=""
-DEPEND="|| ( dev-lang/python:2.7 dev-lang/python:2.6 )
- app-text/docbook-xml-dtd:4.2"
-
-WAF_BINARY="${S}/buildtools/bin/waf"
-
-pkg_setup() {
- python_set_active_version 2
- python_pkg_setup
-}
-
-src_configure() {
- local extra_opts=""
- use python || extra_opts+=" --disable-python"
- waf-utils_src_configure \
- ${extra_opts}
-}
-
-src_test() {
- # the default src_test runs 'make test' and 'make check', letting
- # the tests fail occasionally (reason: unknown)
- emake check || die "emake check failed"
-}
diff --git a/sys-libs/tdb/tdb-1.2.11.ebuild b/sys-libs/tdb/tdb-1.2.11.ebuild
deleted file mode 100644
index f43a5e1da7f3..000000000000
--- a/sys-libs/tdb/tdb-1.2.11.ebuild
+++ /dev/null
@@ -1,42 +0,0 @@
-# Copyright 1999-2013 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/tdb/tdb-1.2.11.ebuild,v 1.8 2013/09/06 16:04:59 ago Exp $
-
-EAPI=3
-PYTHON_DEPEND="python? 2"
-RESTRICT_PYTHON_ABIS="3.* *-jython 2.7-pypy-*"
-
-inherit waf-utils python
-
-DESCRIPTION="A simple database API"
-HOMEPAGE="http://tdb.samba.org/"
-SRC_URI="http://samba.org/ftp/tdb/${P}.tar.gz"
-
-LICENSE="GPL-3"
-SLOT="0"
-KEYWORDS="alpha amd64 arm ~hppa ia64 ~mips ~ppc ~ppc64 ~s390 ~sh sparc x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~arm-linux ~x86-linux"
-IUSE="python"
-
-RDEPEND=""
-DEPEND="|| ( dev-lang/python:2.7 dev-lang/python:2.6 )
- app-text/docbook-xml-dtd:4.2"
-
-WAF_BINARY="${S}/buildtools/bin/waf"
-
-pkg_setup() {
- python_set_active_version 2
- python_pkg_setup
-}
-
-src_configure() {
- local extra_opts=""
- use python || extra_opts+=" --disable-python"
- waf-utils_src_configure \
- ${extra_opts}
-}
-
-src_test() {
- # the default src_test runs 'make test' and 'make check', letting
- # the tests fail occasionally (reason: unknown)
- emake check || die "emake check failed"
-}
diff --git a/sys-libs/tdb/tdb-1.2.13.ebuild b/sys-libs/tdb/tdb-1.2.13.ebuild
deleted file mode 100644
index 4b8a7e5b17b5..000000000000
--- a/sys-libs/tdb/tdb-1.2.13.ebuild
+++ /dev/null
@@ -1,40 +0,0 @@
-# Copyright 1999-2014 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/tdb/tdb-1.2.13.ebuild,v 1.1 2014/03/23 20:00:38 polynomial-c Exp $
-
-EAPI=5
-
-PYTHON_COMPAT=( python{2_6,2_7} )
-
-inherit waf-utils python-single-r1
-
-DESCRIPTION="A simple database API"
-HOMEPAGE="http://tdb.samba.org/"
-SRC_URI="http://samba.org/ftp/tdb/${P}.tar.gz"
-
-LICENSE="GPL-3"
-SLOT="0"
-KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~arm-linux ~x86-linux"
-IUSE="python"
-
-REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )"
-
-RDEPEND="python? ( ${PYTHON_DEPS} )"
-DEPEND="
- ${RDEPEND}
- app-text/docbook-xml-dtd:4.2"
-
-WAF_BINARY="${S}/buildtools/bin/waf"
-
-src_configure() {
- local extra_opts=""
- use python || extra_opts+=" --disable-python"
- waf-utils_src_configure \
- ${extra_opts}
-}
-
-src_test() {
- # the default src_test runs 'make test' and 'make check', letting
- # the tests fail occasionally (reason: unknown)
- emake check
-}
diff --git a/sys-libs/tdb/tdb-1.3.2.ebuild b/sys-libs/tdb/tdb-1.3.2.ebuild
new file mode 100644
index 000000000000..2d0848387537
--- /dev/null
+++ b/sys-libs/tdb/tdb-1.3.2.ebuild
@@ -0,0 +1,59 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/tdb/tdb-1.3.2.ebuild,v 1.1 2014/12/02 08:20:46 polynomial-c Exp $
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 )
+
+inherit waf-utils multilib-minimal python-single-r1 eutils
+
+DESCRIPTION="A simple database API"
+HOMEPAGE="http://tdb.samba.org/"
+SRC_URI="http://samba.org/ftp/tdb/${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~arm-linux ~x86-linux"
+IUSE="python"
+
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+RDEPEND="python? ( ${PYTHON_DEPS} )"
+DEPEND="
+ ${RDEPEND}
+ ${PYTHON_DEPS}
+ app-text/docbook-xml-dtd:4.2"
+
+WAF_BINARY="${S}/buildtools/bin/waf"
+
+src_prepare() {
+ python_fix_shebang .
+ multilib_copy_sources
+}
+
+multilib_src_configure() {
+ local extra_opts=()
+ if ! multilib_is_native_abi || ! use python; then
+ extra_opts+=( --disable-python )
+ fi
+
+ waf-utils_src_configure \
+ "${extra_opts[@]}"
+}
+
+multilib_src_compile() {
+ # need to avoid parallel building, this looks like the sanest way with waf-utils/multiprocessing eclasses
+ unset MAKEOPTS
+ waf-utils_src_compile
+}
+
+multilib_src_test() {
+ # the default src_test runs 'make test' and 'make check', letting
+ # the tests fail occasionally (reason: unknown)
+ emake check
+}
+
+multilib_src_install() {
+ waf-utils_src_install
+}