summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlin Năstac <mrness@gentoo.org>2009-09-12 03:59:20 +0000
committerAlin Năstac <mrness@gentoo.org>2009-09-12 03:59:20 +0000
commit0c7d8d112b9985b3c86e647adc592a7f9833f05e (patch)
treea9f9ffb012f563910b796f13b736938f3ab26b3f /sys-libs
parentCleaning out unused patch (diff)
downloadgentoo-2-0c7d8d112b9985b3c86e647adc592a7f9833f05e.tar.gz
gentoo-2-0c7d8d112b9985b3c86e647adc592a7f9833f05e.tar.bz2
gentoo-2-0c7d8d112b9985b3c86e647adc592a7f9833f05e.zip
Initial version.
(Portage version: 2.1.6.13/cvs/Linux x86_64)
Diffstat (limited to 'sys-libs')
-rw-r--r--sys-libs/libcap-ng/ChangeLog10
-rw-r--r--sys-libs/libcap-ng/files/libcap-ng-gentoo.patch33
-rw-r--r--sys-libs/libcap-ng/libcap-ng-0.6.1.ebuild38
-rw-r--r--sys-libs/libcap-ng/metadata.xml14
4 files changed, 95 insertions, 0 deletions
diff --git a/sys-libs/libcap-ng/ChangeLog b/sys-libs/libcap-ng/ChangeLog
new file mode 100644
index 000000000000..971d083d0861
--- /dev/null
+++ b/sys-libs/libcap-ng/ChangeLog
@@ -0,0 +1,10 @@
+# ChangeLog for sys-libs/libcap-ng
+# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/libcap-ng/ChangeLog,v 1.1 2009/09/12 03:59:19 mrness Exp $
+
+*libcap-ng-0.6.1 (12 Sep 2009)
+
+ 12 Sep 2009; Alin Năstac <mrness@gentoo.org>
+ +files/libcap-ng-gentoo.patch, +metadata.xml, +libcap-ng-0.6.1.ebuild:
+ Initial version.
+
diff --git a/sys-libs/libcap-ng/files/libcap-ng-gentoo.patch b/sys-libs/libcap-ng/files/libcap-ng-gentoo.patch
new file mode 100644
index 000000000000..301c3d72b84b
--- /dev/null
+++ b/sys-libs/libcap-ng/files/libcap-ng-gentoo.patch
@@ -0,0 +1,33 @@
+diff -Nru libcap-ng-0.6.1.orig/configure.ac libcap-ng-0.6.1/configure.ac
+--- libcap-ng-0.6.1.orig/configure.ac 2009-09-12 05:39:48.000000000 +0200
++++ libcap-ng-0.6.1/configure.ac 2009-09-12 05:40:11.000000000 +0200
+@@ -100,12 +100,25 @@
+
+ AC_SUBST(DEBUG)
+
+-AC_CHECK_PROG(swig_found, swig, yes, no)
+-if test x"${swig_found}" = x"no" ; then
+- AC_MSG_WARN("Swig not found, python bindings will not be made")
++AC_ARG_ENABLE(python,
++[ --disable-python disable python bindings],
++[
++if test "x${enableval}" = xyes; then
++ PYTHONBINDINGS="yes"
++else
++ PYTHONBINDINGS="no"
++fi
++],PYTHONBINDINGS="yes")
++if test x"${PYTHONBINDINGS}" = xyes; then
++ AC_CHECK_PROG(swig_found, swig, yes, no)
++ if test x"${swig_found}" = x"no" ; then
++ AC_MSG_WARN("Swig not found, python bindings will not be made")
++ fi
++ AM_PATH_PYTHON
++else
++ swig_found="no"
+ fi
+ AM_CONDITIONAL(HAVE_SWIG, test x"${swig_found}" = x"yes")
+-AM_PATH_PYTHON
+
+ AC_OUTPUT(Makefile src/Makefile src/test/Makefile bindings/Makefile
+ bindings/python/Makefile bindings/python/test/Makefile
diff --git a/sys-libs/libcap-ng/libcap-ng-0.6.1.ebuild b/sys-libs/libcap-ng/libcap-ng-0.6.1.ebuild
new file mode 100644
index 000000000000..cd17e066e32e
--- /dev/null
+++ b/sys-libs/libcap-ng/libcap-ng-0.6.1.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/libcap-ng/libcap-ng-0.6.1.ebuild,v 1.1 2009/09/12 03:59:19 mrness Exp $
+
+EAPI="2"
+
+inherit eutils autotools
+
+DESCRIPTION="POSIX 1003.1e capabilities"
+HOMEPAGE="http://people.redhat.com/sgrubb/libcap-ng/"
+SRC_URI="http://people.redhat.com/sgrubb/libcap-ng/${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="python"
+
+COMMON_DEPEND="sys-apps/attr"
+RDEPEND="${COMMON_DEPEND}
+ python? ( dev-lang/python )"
+DEPEND="${COMMON_DEPEND}
+ sys-kernel/linux-headers
+ python? ( dev-lang/swig dev-lang/python )"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${PN}-gentoo.patch
+ eautoreconf
+}
+
+src_configure() {
+ econf $(use_enable python) || die "econf failed"
+}
+
+src_install() {
+ emake install DESTDIR="${D}" || die "emake install failed"
+
+ dodoc ChangeLog README
+}
diff --git a/sys-libs/libcap-ng/metadata.xml b/sys-libs/libcap-ng/metadata.xml
new file mode 100644
index 000000000000..413ad15cfaa1
--- /dev/null
+++ b/sys-libs/libcap-ng/metadata.xml
@@ -0,0 +1,14 @@
+<?xml version = '1.0' encoding = 'UTF-8'?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>base-system</herd>
+ <maintainer>
+ <email>mrness@gentoo.org</email>
+ <name>Alin Nastac</name>
+ </maintainer>
+ <longdescription>The libcap-ng library is intended to make programming with
+ POSIX capabilities much easier than the traditional libcap library. It
+ includes utilities that can analyse all currently running applications and
+ print out any capabilities and whether or not it has an open ended bounding
+ set.</longdescription>
+</pkgmetadata>