summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorVictor Ostorga <vostorga@gentoo.org>2011-03-15 20:46:10 +0000
committerVictor Ostorga <vostorga@gentoo.org>2011-03-15 20:46:10 +0000
commit17dc561ce55d98b06b9ce2f1fa521b622ebd41c5 (patch)
treef4c6214ee2ef25cb6fff7e01fc0a2d0a467b6e7c /sys-libs
parentRemove old version. (diff)
downloadgentoo-2-17dc561ce55d98b06b9ce2f1fa521b622ebd41c5.tar.gz
gentoo-2-17dc561ce55d98b06b9ce2f1fa521b622ebd41c5.tar.bz2
gentoo-2-17dc561ce55d98b06b9ce2f1fa521b622ebd41c5.zip
Fixing collision with /usr/lib/libtalloc.so.2 bug #351608 setting python 2.6 as runtime python bug #354587 #357269
(Portage version: 2.1.9.25/cvs/Linux i686)
Diffstat (limited to 'sys-libs')
-rw-r--r--sys-libs/talloc/ChangeLog6
-rw-r--r--sys-libs/talloc/talloc-2.0.5.ebuild17
2 files changed, 16 insertions, 7 deletions
diff --git a/sys-libs/talloc/ChangeLog b/sys-libs/talloc/ChangeLog
index 47a3c19e6400..5cc9c377650f 100644
--- a/sys-libs/talloc/ChangeLog
+++ b/sys-libs/talloc/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for sys-libs/talloc
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/talloc/ChangeLog,v 1.21 2011/03/01 23:03:58 abcd Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/talloc/ChangeLog,v 1.22 2011/03/15 20:46:10 vostorga Exp $
+
+ 15 Mar 2011; Víctor Ostorga <vostorga@gentoo.org> talloc-2.0.5.ebuild:
+ Fixing collision with /usr/lib/libtalloc.so.2 bug #351608 setting python
+ 2.6 as runtime python bug #354587 #357269
01 Mar 2011; Jonathan Callen <abcd@gentoo.org> talloc-2.0.5.ebuild:
Add ~amd64-linux/~x86-linux keywords
diff --git a/sys-libs/talloc/talloc-2.0.5.ebuild b/sys-libs/talloc/talloc-2.0.5.ebuild
index 2e26eb3367aa..15c2ed8df950 100644
--- a/sys-libs/talloc/talloc-2.0.5.ebuild
+++ b/sys-libs/talloc/talloc-2.0.5.ebuild
@@ -1,10 +1,10 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/talloc/talloc-2.0.5.ebuild,v 1.2 2011/03/01 23:03:58 abcd Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/talloc/talloc-2.0.5.ebuild,v 1.3 2011/03/15 20:46:10 vostorga Exp $
EAPI=3
-
-inherit waf-utils
+PYTHON_DEPEND="2::2.6"
+inherit waf-utils python
DESCRIPTION="Samba talloc library"
HOMEPAGE="http://talloc.samba.org/"
@@ -15,12 +15,17 @@ SLOT="0"
KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-linux ~x86-linux"
IUSE="compat python"
-RDEPEND=""
-DEPEND="${RDEPEND}
- dev-libs/libxslt"
+RDEPEND="!!<sys-libs/talloc-2.0.5"
+DEPEND="dev-libs/libxslt"
WAF_BINARY="${S}/buildtools/bin/waf"
+pkg_setup() {
+ # Make sure the build system will use the right python
+ python_set_active_version 2
+ python_pkg_setup
+}
+
src_configure() {
local extra_opts=""