summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTravis Tilley <lv@gentoo.org>2004-08-16 18:57:20 +0000
committerTravis Tilley <lv@gentoo.org>2004-08-16 18:57:20 +0000
commit1f690f517f8cebd2c94e0787ea66bc61d987899c (patch)
tree2eb019a7d3c8df410dbe5ecfbb5842782f0b1312 /sys-libs
parentinstall docs correctly (Manifest recommit) (diff)
downloadgentoo-2-1f690f517f8cebd2c94e0787ea66bc61d987899c.tar.gz
gentoo-2-1f690f517f8cebd2c94e0787ea66bc61d987899c.tar.bz2
gentoo-2-1f690f517f8cebd2c94e0787ea66bc61d987899c.zip
added ld.so brk patch, which should fix the upstream bug detailed at http://sources.redhat.com/bugzilla/show_bug.cgi?id=227
Diffstat (limited to 'sys-libs')
-rw-r--r--sys-libs/glibc/ChangeLog7
-rw-r--r--sys-libs/glibc/files/2.3.4/glibc-2.3.4-ld.so-brk-fix.patch60
-rw-r--r--sys-libs/glibc/glibc-2.3.4.20040808.ebuild4
3 files changed, 69 insertions, 2 deletions
diff --git a/sys-libs/glibc/ChangeLog b/sys-libs/glibc/ChangeLog
index 11e7454710a1..7562601def0c 100644
--- a/sys-libs/glibc/ChangeLog
+++ b/sys-libs/glibc/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sys-libs/glibc
# Copyright 2002-2004 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/glibc/ChangeLog,v 1.239 2004/08/16 04:57:57 lv Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/glibc/ChangeLog,v 1.240 2004/08/16 18:57:20 lv Exp $
+
+ 16 Aug 2004; Travis Tilley <lv@gentoo.org>
+ +files/2.3.4/glibc-2.3.4-ld.so-brk-fix.patch, glibc-2.3.4.20040808.ebuild:
+ added ld.so brk patch, which should fix the upstream bug detailed at
+ http://sources.redhat.com/bugzilla/show_bug.cgi?id=227
15 Aug 2004; Travis Tilley <lv@gentoo.org> -glibc-2.3.3_pre20040207.ebuild:
removed ebuild now that alpha and ia64 dont use it
diff --git a/sys-libs/glibc/files/2.3.4/glibc-2.3.4-ld.so-brk-fix.patch b/sys-libs/glibc/files/2.3.4/glibc-2.3.4-ld.so-brk-fix.patch
new file mode 100644
index 000000000000..d1d9a924be8b
--- /dev/null
+++ b/sys-libs/glibc/files/2.3.4/glibc-2.3.4-ld.so-brk-fix.patch
@@ -0,0 +1,60 @@
+diff -Nru glibc-2.3.3.old/sysdeps/unix/sysv/linux/dl-sysdep.c glibc-2.3.3/sysdeps/unix/sysv/linux/dl-sysdep.c
+--- glibc-2.3.3.old/sysdeps/unix/sysv/linux/dl-sysdep.c 2004-08-16 10:47:10.361264216 -0400
++++ glibc-2.3.3/sysdeps/unix/sysv/linux/dl-sysdep.c 2004-08-16 10:47:55.068467688 -0400
+@@ -1,5 +1,5 @@
+ /* Dynamic linker system dependencies for Linux.
+- Copyright (C) 1995, 1997, 2001 Free Software Foundation, Inc.
++ Copyright (C) 1995, 1997, 2001, 2004 Free Software Foundation, Inc.
+ This file is part of the GNU C Library.
+
+ The GNU C Library is free software; you can redistribute it and/or
+@@ -21,6 +21,8 @@
+ the generic dynamic linker system interface code. */
+
+ #include <unistd.h>
++#include <ldsodefs.h>
++#include "kernel-features.h"
+
+ #define DL_SYSDEP_INIT frob_brk ()
+
+@@ -28,6 +30,27 @@
+ frob_brk (void)
+ {
+ __brk (0); /* Initialize the break. */
++
++#if ! __ASSUME_BRK_PAGE_ROUNDED
++ /* If the dynamic linker was executed as a program, then the break may
++ start immediately after our data segment. However, dl-minimal.c has
++ already stolen the remainder of the page for internal allocations.
++ If we don't adjust the break location recorded by the kernel, the
++ normal program startup will inquire, find the value at our &_end,
++ and start allocating its own data there, clobbering dynamic linker
++ data structures allocated there during startup.
++
++ Later Linux kernels have changed this behavior so that the initial
++ break value is rounded up to the page boundary before we start. */
++
++ extern void *__curbrk attribute_hidden;
++ extern void _end attribute_hidden;
++ void *const endpage = (void *) 0 + (((__curbrk - (void *) 0)
++ + GLRO(dl_pagesize) - 1)
++ & -GLRO(dl_pagesize));
++ if (__builtin_expect (__curbrk >= &_end && __curbrk < endpage, 0))
++ __brk (endpage);
++#endif
+ }
+
+ #include <sysdeps/generic/dl-sysdep.c>
+diff -Nru glibc-2.3.3.old/sysdeps/unix/sysv/linux/kernel-features.h glibc-2.3.3/sysdeps/unix/sysv/linux/kernel-features.h
+--- glibc-2.3.3.old/sysdeps/unix/sysv/linux/kernel-features.h 2004-08-16 10:47:09.458401472 -0400
++++ glibc-2.3.3/sysdeps/unix/sysv/linux/kernel-features.h 2004-08-16 10:48:02.345361432 -0400
+@@ -400,3 +400,9 @@
+ #if __LINUX_KERNEL_VERSION >= 132612
+ # define __ASSUME_GETDENTS32_D_TYPE 1
+ #endif
++
++/* Starting with version 2.5.3, the initial location returned by `brk'
++ after exec is always rounded up to the next page. */
++#if __LINUX_KERNEL_VERSION >= 132355
++# define __ASSUME_BRK_PAGE_ROUNDED 1
++#endif
diff --git a/sys-libs/glibc/glibc-2.3.4.20040808.ebuild b/sys-libs/glibc/glibc-2.3.4.20040808.ebuild
index 40fe61c2f4b3..833977fa8ee8 100644
--- a/sys-libs/glibc/glibc-2.3.4.20040808.ebuild
+++ b/sys-libs/glibc/glibc-2.3.4.20040808.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/glibc/glibc-2.3.4.20040808.ebuild,v 1.9 2004/08/12 18:11:57 lv Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/glibc/glibc-2.3.4.20040808.ebuild,v 1.10 2004/08/16 18:57:20 lv Exp $
inherit eutils flag-o-matic gcc
@@ -513,6 +513,8 @@ src_unpack() {
# Remaining patches
cd ${S}
+ # fix for http://sources.redhat.com/bugzilla/show_bug.cgi?id=227
+ epatch ${FILESDIR}/2.3.4/glibc-2.3.4-ld.so-brk-fix.patch
# Fix permissions on some of the scripts
chmod u+x ${S}/scripts/*.sh