summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2009-02-07 09:10:23 +0000
committerMike Frysinger <vapier@gentoo.org>2009-02-07 09:10:23 +0000
commit2a4c26bdb63fc380556050684e4fb5fcd04c8a40 (patch)
tree3c468817cff9aec75dec1458e4eab137783af26a /sys-libs
parentCleanup src_compile and src_install. (diff)
downloadgentoo-2-2a4c26bdb63fc380556050684e4fb5fcd04c8a40.tar.gz
gentoo-2-2a4c26bdb63fc380556050684e4fb5fcd04c8a40.tar.bz2
gentoo-2-2a4c26bdb63fc380556050684e4fb5fcd04c8a40.zip
Use is-flagq rather than is-flag.
(Portage version: 2.2_rc23/cvs/Linux x86_64)
Diffstat (limited to 'sys-libs')
-rw-r--r--sys-libs/db/ChangeLog8
-rw-r--r--sys-libs/db/db-4.5.20_p2-r1.ebuild6
-rw-r--r--sys-libs/db/db-4.5.20_p2.ebuild6
-rw-r--r--sys-libs/db/db-4.6.21_p1.ebuild4
-rw-r--r--sys-libs/db/db-4.6.21_p3-r1.ebuild4
-rw-r--r--sys-libs/db/db-4.6.21_p3.ebuild4
-rw-r--r--sys-libs/db/db-4.7.25.ebuild4
-rw-r--r--sys-libs/db/db-4.7.25_p1-r1.ebuild4
-rw-r--r--sys-libs/db/db-4.7.25_p1.ebuild4
9 files changed, 25 insertions, 19 deletions
diff --git a/sys-libs/db/ChangeLog b/sys-libs/db/ChangeLog
index 8cc910e9fc0b..067c70b80e44 100644
--- a/sys-libs/db/ChangeLog
+++ b/sys-libs/db/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sys-libs/db
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/db/ChangeLog,v 1.273 2009/02/07 09:04:45 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/db/ChangeLog,v 1.274 2009/02/07 09:10:23 vapier Exp $
+
+ 07 Feb 2009; Mike Frysinger <vapier@gentoo.org> db-4.5.20_p2.ebuild,
+ db-4.5.20_p2-r1.ebuild, db-4.6.21_p1.ebuild, db-4.6.21_p3.ebuild,
+ db-4.6.21_p3-r1.ebuild, db-4.7.25.ebuild, db-4.7.25_p1.ebuild,
+ db-4.7.25_p1-r1.ebuild:
+ Use is-flagq rather than is-flag.
07 Feb 2009; Mike Frysinger <vapier@gentoo.org> db-4.7.25_p1-r1.ebuild:
Cleanup src_compile and src_install.
diff --git a/sys-libs/db/db-4.5.20_p2-r1.ebuild b/sys-libs/db/db-4.5.20_p2-r1.ebuild
index 727657f9095d..33e9f623677f 100644
--- a/sys-libs/db/db-4.5.20_p2-r1.ebuild
+++ b/sys-libs/db/db-4.5.20_p2-r1.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2008 Gentoo Foundation
+# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/db/db-4.5.20_p2-r1.ebuild,v 1.9 2008/10/26 12:27:40 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/db/db-4.5.20_p2-r1.ebuild,v 1.10 2009/02/07 09:10:23 vapier Exp $
inherit eutils db flag-o-matic java-pkg-opt-2 autotools libtool
@@ -93,7 +93,7 @@ src_compile() {
# compilation with -O0 fails on amd64, see bug #171231
if use amd64; then
replace-flags -O0 -O2
- is-flag -O[s123] || append-flags -O2
+ is-flagq -O[s123] || append-flags -O2
fi
local myconf=""
diff --git a/sys-libs/db/db-4.5.20_p2.ebuild b/sys-libs/db/db-4.5.20_p2.ebuild
index 5f7ff0e5b1af..b5569117283a 100644
--- a/sys-libs/db/db-4.5.20_p2.ebuild
+++ b/sys-libs/db/db-4.5.20_p2.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2008 Gentoo Foundation
+# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/db/db-4.5.20_p2.ebuild,v 1.25 2008/08/16 05:23:01 robbat2 Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/db/db-4.5.20_p2.ebuild,v 1.26 2009/02/07 09:10:23 vapier Exp $
inherit eutils db flag-o-matic java-pkg-opt-2
@@ -57,7 +57,7 @@ src_compile() {
# compilation with -O0 fails on amd64, see bug #171231
if use amd64; then
replace-flags -O0 -O2
- is-flag -O[s123] || append-flags -O2
+ is-flagq -O[s123] || append-flags -O2
fi
local myconf=""
diff --git a/sys-libs/db/db-4.6.21_p1.ebuild b/sys-libs/db/db-4.6.21_p1.ebuild
index 75b2aa342577..d0a5dbd90776 100644
--- a/sys-libs/db/db-4.6.21_p1.ebuild
+++ b/sys-libs/db/db-4.6.21_p1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/db/db-4.6.21_p1.ebuild,v 1.3 2009/02/07 08:06:45 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/db/db-4.6.21_p1.ebuild,v 1.4 2009/02/07 09:10:23 vapier Exp $
inherit eutils db flag-o-matic java-pkg-opt-2
@@ -57,7 +57,7 @@ src_compile() {
# compilation with -O0 fails on amd64, see bug #171231
if use amd64; then
replace-flags -O0 -O2
- is-flag -O[s123] || append-flags -O2
+ is-flagq -O[s123] || append-flags -O2
fi
local myconf=""
diff --git a/sys-libs/db/db-4.6.21_p3-r1.ebuild b/sys-libs/db/db-4.6.21_p3-r1.ebuild
index a716de222b72..9093c086e681 100644
--- a/sys-libs/db/db-4.6.21_p3-r1.ebuild
+++ b/sys-libs/db/db-4.6.21_p3-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/db/db-4.6.21_p3-r1.ebuild,v 1.4 2009/02/07 08:06:45 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/db/db-4.6.21_p3-r1.ebuild,v 1.5 2009/02/07 09:10:23 vapier Exp $
inherit eutils db flag-o-matic java-pkg-opt-2 autotools libtool
@@ -78,7 +78,7 @@ src_compile() {
# compilation with -O0 fails on amd64, see bug #171231
if use amd64; then
replace-flags -O0 -O2
- is-flag -O[s123] || append-flags -O2
+ is-flagq -O[s123] || append-flags -O2
fi
local myconf=""
diff --git a/sys-libs/db/db-4.6.21_p3.ebuild b/sys-libs/db/db-4.6.21_p3.ebuild
index 28824ad803a8..95b586707a16 100644
--- a/sys-libs/db/db-4.6.21_p3.ebuild
+++ b/sys-libs/db/db-4.6.21_p3.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/db/db-4.6.21_p3.ebuild,v 1.2 2009/02/07 08:06:45 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/db/db-4.6.21_p3.ebuild,v 1.3 2009/02/07 09:10:23 vapier Exp $
inherit eutils db flag-o-matic java-pkg-opt-2
@@ -57,7 +57,7 @@ src_compile() {
# compilation with -O0 fails on amd64, see bug #171231
if use amd64; then
replace-flags -O0 -O2
- is-flag -O[s123] || append-flags -O2
+ is-flagq -O[s123] || append-flags -O2
fi
local myconf=""
diff --git a/sys-libs/db/db-4.7.25.ebuild b/sys-libs/db/db-4.7.25.ebuild
index 15963d7ef77d..4c9b6b545472 100644
--- a/sys-libs/db/db-4.7.25.ebuild
+++ b/sys-libs/db/db-4.7.25.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/db/db-4.7.25.ebuild,v 1.3 2009/02/07 08:06:45 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/db/db-4.7.25.ebuild,v 1.4 2009/02/07 09:10:23 vapier Exp $
inherit eutils db flag-o-matic java-pkg-opt-2
@@ -57,7 +57,7 @@ src_compile() {
# compilation with -O0 fails on amd64, see bug #171231
if use amd64; then
replace-flags -O0 -O2
- is-flag -O[s123] || append-flags -O2
+ is-flagq -O[s123] || append-flags -O2
fi
local myconf=""
diff --git a/sys-libs/db/db-4.7.25_p1-r1.ebuild b/sys-libs/db/db-4.7.25_p1-r1.ebuild
index cd1a910c5636..dfe055225220 100644
--- a/sys-libs/db/db-4.7.25_p1-r1.ebuild
+++ b/sys-libs/db/db-4.7.25_p1-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/db/db-4.7.25_p1-r1.ebuild,v 1.6 2009/02/07 09:04:45 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/db/db-4.7.25_p1-r1.ebuild,v 1.7 2009/02/07 09:10:23 vapier Exp $
inherit eutils db flag-o-matic java-pkg-opt-2 autotools libtool
@@ -80,7 +80,7 @@ src_compile() {
# compilation with -O0 fails on amd64, see bug #171231
if use amd64; then
replace-flags -O0 -O2
- is-flag -O[s123] || append-flags -O2
+ is-flagq -O[s123] || append-flags -O2
fi
# use `set` here since the java opts will contain whitespace
diff --git a/sys-libs/db/db-4.7.25_p1.ebuild b/sys-libs/db/db-4.7.25_p1.ebuild
index 5888b7407bf7..f72bd8e4645b 100644
--- a/sys-libs/db/db-4.7.25_p1.ebuild
+++ b/sys-libs/db/db-4.7.25_p1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/db/db-4.7.25_p1.ebuild,v 1.2 2009/02/07 08:06:45 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/db/db-4.7.25_p1.ebuild,v 1.3 2009/02/07 09:10:23 vapier Exp $
inherit eutils db flag-o-matic java-pkg-opt-2
@@ -57,7 +57,7 @@ src_compile() {
# compilation with -O0 fails on amd64, see bug #171231
if use amd64; then
replace-flags -O0 -O2
- is-flag -O[s123] || append-flags -O2
+ is-flagq -O[s123] || append-flags -O2
fi
local myconf=""