summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChris PeBenito <pebenito@gentoo.org>2006-03-18 14:43:16 +0000
committerChris PeBenito <pebenito@gentoo.org>2006-03-18 14:43:16 +0000
commit301db070bb3fedd459238f7cfff94edca81db764 (patch)
treebd1969e6ee62fb9f6f652e34d160963116fc2fd9 /sys-libs
parentStable on hppa (bug #119722). (diff)
downloadgentoo-2-301db070bb3fedd459238f7cfff94edca81db764.tar.gz
gentoo-2-301db070bb3fedd459238f7cfff94edca81db764.tar.bz2
gentoo-2-301db070bb3fedd459238f7cfff94edca81db764.zip
new upstream release
(Portage version: 2.1_pre6-r1)
Diffstat (limited to 'sys-libs')
-rw-r--r--sys-libs/libsepol/ChangeLog7
-rw-r--r--sys-libs/libsepol/files/digest-libsepol-1.123
-rw-r--r--sys-libs/libsepol/libsepol-1.12.ebuild41
3 files changed, 50 insertions, 1 deletions
diff --git a/sys-libs/libsepol/ChangeLog b/sys-libs/libsepol/ChangeLog
index 86a56d34a93d..26b82d79f641 100644
--- a/sys-libs/libsepol/ChangeLog
+++ b/sys-libs/libsepol/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sys-libs/libsepol
# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/libsepol/ChangeLog,v 1.15 2006/02/22 16:57:27 spb Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/libsepol/ChangeLog,v 1.16 2006/03/18 14:43:16 pebenito Exp $
+
+*libsepol-1.12 (18 Mar 2006)
+
+ 18 Mar 2006; Chris PeBenito <pebenito@gentoo.org> +libsepol-1.12.ebuild:
+ New upstream release.
22 Feb 2006; Stephen Bennett <spb@gentoo.org> libsepol-1.10.ebuild:
Alpha stable
diff --git a/sys-libs/libsepol/files/digest-libsepol-1.12 b/sys-libs/libsepol/files/digest-libsepol-1.12
new file mode 100644
index 000000000000..0a968d5aa0f8
--- /dev/null
+++ b/sys-libs/libsepol/files/digest-libsepol-1.12
@@ -0,0 +1,3 @@
+MD5 937885f1fcbfe597a0f02aa9af044710 libsepol-1.12.tgz 144082
+RMD160 f3b4a7a86c7d5ad50640752855566275760ae8cd libsepol-1.12.tgz 144082
+SHA256 019588ebc21b82dba18de9b20fb8e412abe7c59c42ce696f1759854f9177cad4 libsepol-1.12.tgz 144082
diff --git a/sys-libs/libsepol/libsepol-1.12.ebuild b/sys-libs/libsepol/libsepol-1.12.ebuild
new file mode 100644
index 000000000000..c3749d9f4f7c
--- /dev/null
+++ b/sys-libs/libsepol/libsepol-1.12.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/libsepol/libsepol-1.12.ebuild,v 1.1 2006/03/18 14:43:16 pebenito Exp $
+
+IUSE=""
+
+inherit multilib
+
+DESCRIPTION="SELinux binary policy representation library"
+HOMEPAGE="http://www.nsa.gov/selinux"
+SRC_URI="http://www.nsa.gov/selinux/archives/${P}.tgz"
+LICENSE="GPL-2"
+SLOT="0"
+
+KEYWORDS="~alpha ~amd64 ~mips ~ppc ~sparc ~x86"
+
+DEPEND="virtual/libc"
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+
+ sed -i -e "s:-Wall:-Wall ${CFLAGS}:g" src/Makefile \
+ || die "src Makefile CFLAGS fix failed."
+ sed -i -e "s:-Wall:-Wall ${CFLAGS}:g" utils/Makefile \
+ || die "utils Makefile CFLAGS fix failed."
+
+ # fix up paths for multilib
+ sed -i -e "/^LIBDIR/s/lib/$(get_libdir)/" src/Makefile \
+ || die "Fix for multilib LIBDIR failed."
+ sed -i -e "/^SHLIBDIR/s/lib/$(get_libdir)/" src/Makefile \
+ || die "Fix for multilib SHLIBDIR failed."
+}
+
+src_compile() {
+ emake || die
+}
+
+src_install() {
+ make DESTDIR="${D}" install
+}