summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2005-08-19 05:22:21 +0000
committerMike Frysinger <vapier@gentoo.org>2005-08-19 05:22:21 +0000
commit57302e24d2612df0d1a75aacfc01e15fb3c9e3e1 (patch)
tree781b70bc9a7c7122d86daa963443450fb92b6b8c /sys-libs
parentfilter -fstack-protector again for bug #88899 - Upstream says it's a gcc-3 is... (diff)
downloadgentoo-2-57302e24d2612df0d1a75aacfc01e15fb3c9e3e1.tar.gz
gentoo-2-57302e24d2612df0d1a75aacfc01e15fb3c9e3e1.tar.bz2
gentoo-2-57302e24d2612df0d1a75aacfc01e15fb3c9e3e1.zip
try to autoguess UCLIBC_CPU based upon CTARGET
(Portage version: 2.0.51.22-r2)
Diffstat (limited to 'sys-libs')
-rw-r--r--sys-libs/uclibc/uclibc-0.9.28.ebuild9
1 files changed, 7 insertions, 2 deletions
diff --git a/sys-libs/uclibc/uclibc-0.9.28.ebuild b/sys-libs/uclibc/uclibc-0.9.28.ebuild
index ec52213f9011..e337527f85ba 100644
--- a/sys-libs/uclibc/uclibc-0.9.28.ebuild
+++ b/sys-libs/uclibc/uclibc-0.9.28.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/uclibc/uclibc-0.9.28.ebuild,v 1.2 2005/08/19 04:21:59 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/uclibc/uclibc-0.9.28.ebuild,v 1.3 2005/08/19 05:22:21 vapier Exp $
#ESVN_REPO_URI="svn://uclibc.org/trunk/uClibc"
#inherit subversion
@@ -103,7 +103,12 @@ check_cpu_opts() {
ewarn "Available CPU options:"
UCLIBC_CPU=$(eval echo ${!cpu_var})
echo ${UCLIBC_CPU}
- export UCLIBC_CPU=${UCLIBC_CPU%% *}
+ case ${CTARGET} in
+ mips[1234]*) export UCLIBC_CPU="MIPS_ISA_${CTARGET:4:1}";;
+ sh[2345]*) export UCLIBC_CPU="SH${CTARGET:2:1}";;
+ i[456]86*) export UCLIBC_CPU="${CTARGET:1:1}86";;
+ *) export UCLIBC_CPU=${UCLIBC_CPU%% *};;
+ esac
else
local cpu found=0
for cpu in $(eval echo ${!cpu_var}) ; do