summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2005-03-16 23:26:14 +0000
committerMike Frysinger <vapier@gentoo.org>2005-03-16 23:26:14 +0000
commit62cfbb87dcdf9fc44dedc11fc7ca75d52a485cc0 (patch)
treeba6fccabe551a068ffd312816615e6ae746a9a9b /sys-libs
parentDrop sys-apps/sed from DEPEND. (diff)
downloadgentoo-2-62cfbb87dcdf9fc44dedc11fc7ca75d52a485cc0.tar.gz
gentoo-2-62cfbb87dcdf9fc44dedc11fc7ca75d52a485cc0.tar.bz2
gentoo-2-62cfbb87dcdf9fc44dedc11fc7ca75d52a485cc0.zip
make sure we create sys-include link for 2nd stage gcc
(Portage version: 2.0.51.19)
Diffstat (limited to 'sys-libs')
-rw-r--r--sys-libs/glibc/glibc-2.3.4.20050125-r1.ebuild10
1 files changed, 8 insertions, 2 deletions
diff --git a/sys-libs/glibc/glibc-2.3.4.20050125-r1.ebuild b/sys-libs/glibc/glibc-2.3.4.20050125-r1.ebuild
index 0b52f3104cf7..f7088cba7e52 100644
--- a/sys-libs/glibc/glibc-2.3.4.20050125-r1.ebuild
+++ b/sys-libs/glibc/glibc-2.3.4.20050125-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/glibc/glibc-2.3.4.20050125-r1.ebuild,v 1.26 2005/03/16 11:33:30 eradicator Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/glibc/glibc-2.3.4.20050125-r1.ebuild,v 1.27 2005/03/16 23:26:14 vapier Exp $
# Here's how the cross-compile logic breaks down ...
# CTARGET - machine that will target the binaries
@@ -412,7 +412,13 @@ toolchain-glibc_src_install() {
#################################################################
# EVERYTHING AFTER THIS POINT IS FOR NATIVE GLIBC INSTALLS ONLY #
- is_crosscompile && return 0
+ # Make sure we install the sys-include symlink so that when
+ # we build a 2nd stage cross-compiler, gcc finds the target
+ # system headers correctly. See gcc/doc/gccinstall.info
+ if is_crosscompile ; then
+ dosym include $(alt_prefix)/sys-include
+ return 0
+ fi
# Everything past this point just needs to be done once... don't waste time building locale files twice...
is_final_abi || return 0