summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2006-11-04 23:42:33 +0000
committerMike Frysinger <vapier@gentoo.org>2006-11-04 23:42:33 +0000
commit6ce8cec09867551ee944d12581ee655bed8bfec5 (patch)
treec30abaf0904dce10780f880bacf6d44f2ec73f0e /sys-libs
parentstable on amd64 (diff)
downloadgentoo-2-6ce8cec09867551ee944d12581ee655bed8bfec5.tar.gz
gentoo-2-6ce8cec09867551ee944d12581ee655bed8bfec5.tar.bz2
gentoo-2-6ce8cec09867551ee944d12581ee655bed8bfec5.zip
Add support for USE=nls #154070 by Benno Schulenberg.
(Portage version: 2.1.2_rc1-r2)
Diffstat (limited to 'sys-libs')
-rw-r--r--sys-libs/timezone-data/ChangeLog6
-rw-r--r--sys-libs/timezone-data/files/timezone-data-2005n-makefile.patch5
-rw-r--r--sys-libs/timezone-data/timezone-data-2006n.ebuild18
3 files changed, 18 insertions, 11 deletions
diff --git a/sys-libs/timezone-data/ChangeLog b/sys-libs/timezone-data/ChangeLog
index 6281609f75bb..fe92504e6d8c 100644
--- a/sys-libs/timezone-data/ChangeLog
+++ b/sys-libs/timezone-data/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for sys-libs/timezone-data
# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/timezone-data/ChangeLog,v 1.50 2006/10/27 16:41:52 wolf31o2 Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/timezone-data/ChangeLog,v 1.51 2006/11/04 23:42:33 vapier Exp $
+
+ 04 Nov 2006; Mike Frysinger <vapier@gentoo.org>
+ files/timezone-data-2005n-makefile.patch, timezone-data-2006n.ebuild:
+ Add support for USE=nls #154070 by Benno Schulenberg.
27 Oct 2006; Chris Gianelloni <wolf31o2@gentoo.org>
timezone-data-2006n.ebuild:
diff --git a/sys-libs/timezone-data/files/timezone-data-2005n-makefile.patch b/sys-libs/timezone-data/files/timezone-data-2005n-makefile.patch
index b591ac8a7ed0..79e88a993bf2 100644
--- a/sys-libs/timezone-data/files/timezone-data-2005n-makefile.patch
+++ b/sys-libs/timezone-data/files/timezone-data-2005n-makefile.patch
@@ -58,13 +58,16 @@
+AWK= awk
# The path where SGML DTDs are kept.
-@@ -241,8 +241,7 @@
+@@ -241,8 +241,10 @@
###############################################################################
-cc= cc
-CC= $(cc) -DTZDIR=\"$(TZDIR)\"
+CC+= -DTZDIR=\"$(TZDIR)\"
++ifeq ($(NLS),1)
++CC += -DHAVE_GETTEXT=1 -DTZ_DOMAIN=\"libc\"
++endif
TZCSRCS= zic.c localtime.c asctime.c scheck.c ialloc.c
TZCOBJS= zic.o localtime.o asctime.o scheck.o ialloc.o
diff --git a/sys-libs/timezone-data/timezone-data-2006n.ebuild b/sys-libs/timezone-data/timezone-data-2006n.ebuild
index 5d10badb3a42..bcb7a7e185ad 100644
--- a/sys-libs/timezone-data/timezone-data-2006n.ebuild
+++ b/sys-libs/timezone-data/timezone-data-2006n.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/timezone-data/timezone-data-2006n.ebuild,v 1.10 2006/10/27 16:41:52 wolf31o2 Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/timezone-data/timezone-data-2006n.ebuild,v 1.11 2006/11/04 23:42:33 vapier Exp $
inherit eutils toolchain-funcs flag-o-matic
@@ -14,7 +14,7 @@ SRC_URI="ftp://elsie.nci.nih.gov/pub/tzdata${data_ver}.tar.gz
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="alpha amd64 arm hppa ia64 m68k ~mips ppc ppc64 s390 sh sparc ~sparc-fbsd x86 ~x86-fbsd"
-IUSE="elibc_FreeBSD"
+IUSE="nls"
DEPEND=""
@@ -23,22 +23,22 @@ S=${WORKDIR}
src_unpack() {
unpack ${A}
epatch "${FILESDIR}"/${PN}-2005n-makefile.patch
- tc-is-cross-compiler && cp -pR ${S} ${S}-native
+ tc-is-cross-compiler && cp -pR "${S}" "${S}"-native
}
src_compile() {
tc-export CC
- # Fixes bug #138251.
- use elibc_FreeBSD && append-flags -DSTD_INSPIRED
+ use elibc_FreeBSD && append-flags -DSTD_INSPIRED #138251
+ use nls && export NLS=1 || export NLS=0
emake || die "emake failed"
+ if tc-is-cross-compiler ; then
+ make -C "${S}"-native CC=$(tc-getBUILD_CC) zic || die
+ fi
}
src_install() {
local zic=""
- if tc-is-cross-compiler; then
- make -C ${S}-native CC=$(tc-getBUILD_CC) zic || die
- zic="zic=${S}-native/zic"
- fi
+ tc-is-cross-compiler && zic="zic=${S}-native/zic"
make install ${zic} DESTDIR="${D}" || die
rm -rf "${D}"/usr/share/zoneinfo-leaps
dodoc README Theory