summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarkus Duft <mduft@gentoo.org>2010-07-13 08:33:06 +0000
committerMarkus Duft <mduft@gentoo.org>2010-07-13 08:33:06 +0000
commit819349597d0dc31536b0b58f8efda78bcee75286 (patch)
tree7517056d027e2c228a6934daff2d6ce60a6fbc5a /sys-libs
parentStable on amd64 wrt bug #328015 (diff)
downloadgentoo-2-819349597d0dc31536b0b58f8efda78bcee75286.tar.gz
gentoo-2-819349597d0dc31536b0b58f8efda78bcee75286.tar.bz2
gentoo-2-819349597d0dc31536b0b58f8efda78bcee75286.zip
initial add of suacomp, required for x86-interix prefix.
(Portage version: 2.1.8.3/cvs/Linux i686)
Diffstat (limited to 'sys-libs')
-rw-r--r--sys-libs/suacomp/ChangeLog10
-rw-r--r--sys-libs/suacomp/metadata.xml15
-rw-r--r--sys-libs/suacomp/suacomp-0.4.ebuild35
3 files changed, 60 insertions, 0 deletions
diff --git a/sys-libs/suacomp/ChangeLog b/sys-libs/suacomp/ChangeLog
new file mode 100644
index 000000000000..05fe018ef24b
--- /dev/null
+++ b/sys-libs/suacomp/ChangeLog
@@ -0,0 +1,10 @@
+# ChangeLog for sys-libs/suacomp
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/suacomp/ChangeLog,v 1.1 2010/07/13 08:33:06 mduft Exp $
+
+*suacomp-0.4 (13 Jul 2010)
+
+ 13 Jul 2010; Markus Duft <mduft@gentoo.org> +suacomp-0.4.ebuild,
+ +metadata.xml:
+ initial add of suacomp to the tree. for interix-prefix only
+
diff --git a/sys-libs/suacomp/metadata.xml b/sys-libs/suacomp/metadata.xml
new file mode 100644
index 000000000000..ecc84987be00
--- /dev/null
+++ b/sys-libs/suacomp/metadata.xml
@@ -0,0 +1,15 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd></herd>
+<maintainer>
+<email>mduft@gentoo.org</email>
+<name>Markus Duft</name>
+</maintainer>
+<longdescription lang="en">
+ A small library, trying to overcome the problems occuring when building
+ (and using) gentoo-prefix on an interix based system. This has no use
+ on non-interix systems.
+</longdescription>
+</pkgmetadata>
+
diff --git a/sys-libs/suacomp/suacomp-0.4.ebuild b/sys-libs/suacomp/suacomp-0.4.ebuild
new file mode 100644
index 000000000000..d29fbd0b6659
--- /dev/null
+++ b/sys-libs/suacomp/suacomp-0.4.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/suacomp/suacomp-0.4.ebuild,v 1.1 2010/07/13 08:33:06 mduft Exp $
+
+EAPI=2
+
+inherit toolchain-funcs
+
+DESCRIPTION="library wrapping the interix lib-c to make it less buggy."
+HOMEPAGE="http://dev.gentoo.org/~mduft/suacomp"
+SRC_URI="${HOMEPAGE}/${P}.tar.gz"
+
+LICENSE="BEER-WARE"
+SLOT="0"
+KEYWORDS="-* ~x86-interix"
+IUSE=""
+
+DEPEND=""
+RDEPEND=""
+
+src_compile() {
+ # no windows xp support for now (name of libc hardcoded!)
+ [[ ${CHOST} == *-interix3* ]] && return 0;
+
+ emake all CC=$(tc-getCC) CFLAGS="${CFLAGS}"
+}
+
+src_install() {
+ [[ ${CHOST} == *-interix3* ]] && return 0;
+
+ # installing to EPREFIX (not EPREFIX/usr) intentionally, since this
+ # falls into the category "low-level-system-library" :)
+ emake install PREFIX="${EPREFIX}/usr" DESTDIR="${D}"
+}
+