summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2013-08-26 21:19:18 +0000
committerAlexis Ballier <aballier@gentoo.org>2013-08-26 21:19:18 +0000
commit948288a82ae3d9210f362098c57ac8e20d9f6335 (patch)
tree351b41fcd4c2c76c461f1a285de474543166885a /sys-libs
parentUse LD_* variables for 32bits too instead of the FreeBSD invention LD_32_*. W... (diff)
downloadgentoo-2-948288a82ae3d9210f362098c57ac8e20d9f6335.tar.gz
gentoo-2-948288a82ae3d9210f362098c57ac8e20d9f6335.tar.bz2
gentoo-2-948288a82ae3d9210f362098c57ac8e20d9f6335.zip
drop LD_32_LIBRARY_PATH hacks for FreeBSD. These should not be needed anymore.
(Portage version: 2.2.1/cvs/Linux x86_64, signed Manifest commit with key 160F534A)
Diffstat (limited to 'sys-libs')
-rw-r--r--sys-libs/libcxxrt/ChangeLog7
-rw-r--r--sys-libs/libcxxrt/libcxxrt-0.0_p20130725.ebuild5
-rw-r--r--sys-libs/libcxxrt/libcxxrt-9999.ebuild5
3 files changed, 10 insertions, 7 deletions
diff --git a/sys-libs/libcxxrt/ChangeLog b/sys-libs/libcxxrt/ChangeLog
index 0c8a8ef0e948..80978829bb97 100644
--- a/sys-libs/libcxxrt/ChangeLog
+++ b/sys-libs/libcxxrt/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sys-libs/libcxxrt
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/libcxxrt/ChangeLog,v 1.15 2013/07/26 00:48:53 aballier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/libcxxrt/ChangeLog,v 1.16 2013/08/26 21:19:18 aballier Exp $
+
+ 26 Aug 2013; Alexis Ballier <aballier@gentoo.org>
+ libcxxrt-0.0_p20130725.ebuild, libcxxrt-9999.ebuild:
+ drop LD_32_LIBRARY_PATH hacks for FreeBSD. These should not be needed
+ anymore.
*libcxxrt-0.0_p20130725 (26 Jul 2013)
diff --git a/sys-libs/libcxxrt/libcxxrt-0.0_p20130725.ebuild b/sys-libs/libcxxrt/libcxxrt-0.0_p20130725.ebuild
index db1b4110af00..9bc3a6aa6cd9 100644
--- a/sys-libs/libcxxrt/libcxxrt-0.0_p20130725.ebuild
+++ b/sys-libs/libcxxrt/libcxxrt-0.0_p20130725.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/libcxxrt/libcxxrt-0.0_p20130725.ebuild,v 1.1 2013/07/26 00:48:53 aballier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/libcxxrt/libcxxrt-0.0_p20130725.ebuild,v 1.2 2013/08/26 21:19:18 aballier Exp $
EAPI=5
@@ -52,8 +52,7 @@ multilib_src_compile() {
multilib_src_test() {
cd "${BUILD_DIR}/test"
- LD_32_LIBRARY_PATH="${BUILD_DIR}/src:${LD_32_LIBRARY_PATH}" \
- LD_LIBRARY_PATH="${BUILD_DIR}/src:${LD_LIBRARY_PATH}" \
+ LD_LIBRARY_PATH="${BUILD_DIR}/src:${LD_LIBRARY_PATH}" \
LIBS="-L${BUILD_DIR}/src -lcxxrt -lc" \
emake check
}
diff --git a/sys-libs/libcxxrt/libcxxrt-9999.ebuild b/sys-libs/libcxxrt/libcxxrt-9999.ebuild
index 1c97dc406be3..8e792b15f187 100644
--- a/sys-libs/libcxxrt/libcxxrt-9999.ebuild
+++ b/sys-libs/libcxxrt/libcxxrt-9999.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/libcxxrt/libcxxrt-9999.ebuild,v 1.8 2013/07/03 21:30:05 aballier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/libcxxrt/libcxxrt-9999.ebuild,v 1.9 2013/08/26 21:19:18 aballier Exp $
EAPI=5
@@ -52,8 +52,7 @@ multilib_src_compile() {
multilib_src_test() {
cd "${BUILD_DIR}/test"
- LD_32_LIBRARY_PATH="${BUILD_DIR}/src:${LD_32_LIBRARY_PATH}" \
- LD_LIBRARY_PATH="${BUILD_DIR}/src:${LD_LIBRARY_PATH}" \
+ LD_LIBRARY_PATH="${BUILD_DIR}/src:${LD_LIBRARY_PATH}" \
LIBS="-L${BUILD_DIR}/src -lcxxrt -lc" \
emake check
}