summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2008-03-16 08:10:21 +0000
committerMike Frysinger <vapier@gentoo.org>2008-03-16 08:10:21 +0000
commit96a9a2592b639a59b32bc642af20d6f1ff9c1de9 (patch)
tree958e26882e39435df65f2ea73acfc533f90b9316 /sys-libs
parentarm/s390/sh stable (diff)
downloadgentoo-2-96a9a2592b639a59b32bc642af20d6f1ff9c1de9.tar.gz
gentoo-2-96a9a2592b639a59b32bc642af20d6f1ff9c1de9.tar.bz2
gentoo-2-96a9a2592b639a59b32bc642af20d6f1ff9c1de9.zip
Use a linker script rather than symlink and use emake in src_install.
(Portage version: 2.2_pre2)
Diffstat (limited to 'sys-libs')
-rw-r--r--sys-libs/ss/ChangeLog5
-rw-r--r--sys-libs/ss/ss-1.40.8.ebuild13
2 files changed, 12 insertions, 6 deletions
diff --git a/sys-libs/ss/ChangeLog b/sys-libs/ss/ChangeLog
index a23e92932d1a..61371e70f86d 100644
--- a/sys-libs/ss/ChangeLog
+++ b/sys-libs/ss/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for sys-libs/ss
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/ss/ChangeLog,v 1.52 2008/03/14 01:40:40 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/ss/ChangeLog,v 1.53 2008/03/16 08:10:21 vapier Exp $
+
+ 16 Mar 2008; Mike Frysinger <vapier@gentoo.org> ss-1.40.8.ebuild:
+ Use a linker script rather than symlink and use emake in src_install.
*ss-1.40.8 (14 Mar 2008)
diff --git a/sys-libs/ss/ss-1.40.8.ebuild b/sys-libs/ss/ss-1.40.8.ebuild
index 2eec6e54c99f..0a5c35529eb6 100644
--- a/sys-libs/ss/ss-1.40.8.ebuild
+++ b/sys-libs/ss/ss-1.40.8.ebuild
@@ -1,8 +1,8 @@
# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/ss/ss-1.40.8.ebuild,v 1.1 2008/03/14 01:40:40 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/ss/ss-1.40.8.ebuild,v 1.2 2008/03/16 08:10:21 vapier Exp $
-inherit eutils flag-o-matic toolchain-funcs
+inherit eutils flag-o-matic toolchain-funcs multilib
DESCRIPTION="Subsystem command parsing library"
HOMEPAGE="http://e2fsprogs.sourceforge.net/"
@@ -29,6 +29,11 @@ src_unpack() {
unpack ${A}
cd "${S}"
epatch "${FILESDIR}"/${PN}-1.39-makefile.patch
+
+ # since we've split out com_err/ss into their own ebuilds, we
+ # need to fake out the local files. let the toolchain find them.
+ echo "GROUP ( /usr/$(get_libdir)/libcom_err.a )" > lib/libcom_err.a
+ echo "GROUP ( /usr/$(get_libdir)/libcom_err.so )" > lib/libcom_err.so
}
src_compile() {
@@ -52,8 +57,6 @@ src_compile() {
src_test() {
env_setup
-
- ln -s $(${CC} -print-file-name=libcom_err.so) lib/libcom_err.so
emake -j1 -C lib/ss check || die "make check failed"
}
@@ -61,7 +64,7 @@ src_install() {
env_setup
dodir /usr/share/man/man1
- make -C lib/ss DESTDIR="${D}" install || die
+ emake -C lib/ss DESTDIR="${D}" install || die
# Move shared libraries to /lib/, install static libraries to /usr/lib/,
# and install linker scripts to /usr/lib/.