summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHanno Böck <hanno@gentoo.org>2006-01-27 23:03:28 +0000
committerHanno Böck <hanno@gentoo.org>2006-01-27 23:03:28 +0000
commit9c2c7617af923908999151cedd3302c8908898d8 (patch)
treed89657f851a483b19df9e09a434476c4fd7e7a46 /sys-libs
parentVersion bump to 2.0_rc26. This resolves an error when kernel packages aren't... (diff)
downloadgentoo-2-9c2c7617af923908999151cedd3302c8908898d8.tar.gz
gentoo-2-9c2c7617af923908999151cedd3302c8908898d8.tar.bz2
gentoo-2-9c2c7617af923908999151cedd3302c8908898d8.zip
gwenhywfar bump
(Portage version: 2.1_pre3-r1)
Diffstat (limited to 'sys-libs')
-rw-r--r--sys-libs/gwenhywfar/ChangeLog7
-rw-r--r--sys-libs/gwenhywfar/files/digest-gwenhywfar-1.99.51
-rw-r--r--sys-libs/gwenhywfar/gwenhywfar-1.99.5.ebuild42
3 files changed, 49 insertions, 1 deletions
diff --git a/sys-libs/gwenhywfar/ChangeLog b/sys-libs/gwenhywfar/ChangeLog
index 23396ff07782..3d2776e8142d 100644
--- a/sys-libs/gwenhywfar/ChangeLog
+++ b/sys-libs/gwenhywfar/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sys-libs/gwenhywfar
# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/gwenhywfar/ChangeLog,v 1.22 2006/01/17 21:46:17 hanno Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/gwenhywfar/ChangeLog,v 1.23 2006/01/27 23:03:28 hanno Exp $
+
+*gwenhywfar-1.99.5 (27 Jan 2006)
+
+ 27 Jan 2006; Hanno Boeck <hanno@gentoo.org> +gwenhywfar-1.99.5.ebuild:
+ Version bump.
*gwenhywfar-1.99.4 (17 Jan 2006)
diff --git a/sys-libs/gwenhywfar/files/digest-gwenhywfar-1.99.5 b/sys-libs/gwenhywfar/files/digest-gwenhywfar-1.99.5
new file mode 100644
index 000000000000..7e538af8dbc6
--- /dev/null
+++ b/sys-libs/gwenhywfar/files/digest-gwenhywfar-1.99.5
@@ -0,0 +1 @@
+MD5 a335a38901bf0e9e274d25eff828a608 gwenhywfar-1.99.5.tar.gz 1122748
diff --git a/sys-libs/gwenhywfar/gwenhywfar-1.99.5.ebuild b/sys-libs/gwenhywfar/gwenhywfar-1.99.5.ebuild
new file mode 100644
index 000000000000..63f023bcb7ca
--- /dev/null
+++ b/sys-libs/gwenhywfar/gwenhywfar-1.99.5.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/gwenhywfar/gwenhywfar-1.99.5.ebuild,v 1.1 2006/01/27 23:03:28 hanno Exp $
+
+DESCRIPTION="A multi-platform helper library for other libraries"
+HOMEPAGE="http://gwenhywfar.sourceforge.net"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~ia64 ~ppc ~sparc ~x86"
+
+IUSE="debug ssl doc ncurses"
+
+DEPEND="ssl? ( >=dev-libs/openssl-0.9.6b )
+ sys-libs/ncurses
+ doc? ( app-doc/doxygen )
+ ncurses? ( sys-libs/ncurses )"
+S=${WORKDIR}/${P}
+
+src_compile() {
+ if use doc; then
+ APIDOC="--with-docpath=/usr/share/doc/${P}/apidoc"
+ fi
+ econf \
+ `use_enable ssl` \
+ `use_enable debug` \
+ `use_enable doc full-doc` \
+ `use_enable ncurses gwenui` \
+ ${APIDOC} || die "configure failed"
+ emake || die "emake failed"
+ if use doc; then
+ emake srcdoc || die "Building the api-doc failed"
+ fi
+}
+
+src_install() {
+ make DESTDIR=${D} install || die
+ dodoc README* AUTHORS ABOUT-NLS COPYING ChangeLog INSTALL TODO
+ if use doc; then
+ make DESTDIR=${D} install-srcdoc || die "Installing the API-Doc failed"
+ fi
+}