summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorFabian Groffen <grobian@gentoo.org>2015-02-03 21:04:09 +0000
committerFabian Groffen <grobian@gentoo.org>2015-02-03 21:04:09 +0000
commita16644cd9781e7bbdee8554246f5a099e45a41d6 (patch)
tree36a0516d2c4be55c5747f60d83af724a12b37740 /sys-libs
parentversion bump (diff)
downloadgentoo-2-a16644cd9781e7bbdee8554246f5a099e45a41d6.tar.gz
gentoo-2-a16644cd9781e7bbdee8554246f5a099e45a41d6.tar.bz2
gentoo-2-a16644cd9781e7bbdee8554246f5a099e45a41d6.zip
Version bump to version from Darwin14, based on ebuild and patch by Michael Weiser, bug #538602
(Portage version: 2.2.14-prefix/cvs/Darwin i386, signed Manifest commit with key 0x5F75F607C5C74E89)
Diffstat (limited to 'sys-libs')
-rw-r--r--sys-libs/csu/ChangeLog12
-rw-r--r--sys-libs/csu/csu-79.ebuild15
-rw-r--r--sys-libs/csu/csu-85.ebuild54
-rw-r--r--sys-libs/csu/files/csu-85-darwin8.patch23
4 files changed, 98 insertions, 6 deletions
diff --git a/sys-libs/csu/ChangeLog b/sys-libs/csu/ChangeLog
index b6b7c25bd51e..e1bcd70fd92a 100644
--- a/sys-libs/csu/ChangeLog
+++ b/sys-libs/csu/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for sys-libs/csu
-# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/csu/ChangeLog,v 1.7 2011/09/04 13:20:29 grobian Exp $
+# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/csu/ChangeLog,v 1.8 2015/02/03 21:04:09 grobian Exp $
+
+*csu-85 (03 Feb 2015)
+
+ 03 Feb 2015; Fabian Groffen <grobian@gentoo.org> +csu-85.ebuild,
+ +files/csu-85-darwin8.patch, csu-79.ebuild:
+ Version bump to version from Darwin14, based on ebuild and patch by Michael
+ Weiser, bug #538602
04 Sep 2011; Fabian Groffen <grobian@gentoo.org> csu-79.ebuild:
Fix build on case-sensitive volumes, bug #381779
@@ -28,4 +35,3 @@
15 Nov 2004; Kito <kito@gentoo.org> +csu-46.ebuild:
initial import. added ~ppc-macos
-
diff --git a/sys-libs/csu/csu-79.ebuild b/sys-libs/csu/csu-79.ebuild
index 7acc2059bd32..04a22032f955 100644
--- a/sys-libs/csu/csu-79.ebuild
+++ b/sys-libs/csu/csu-79.ebuild
@@ -1,10 +1,10 @@
-# Copyright 1999-2011 Gentoo Foundation
+# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/csu/csu-79.ebuild,v 1.3 2011/09/04 13:20:29 grobian Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/csu/csu-79.ebuild,v 1.4 2015/02/03 21:04:09 grobian Exp $
EAPI=3
-DESCRIPTION="Darwin Csu (crt1.o) - Mac OS X 10.6.6 and 10.7 versions"
+DESCRIPTION="Darwin Csu (crt1.o) - Mac OS X 10.6.6 to 10.9.5 versions"
HOMEPAGE="http://www.opensource.apple.com/"
SRC_URI="http://www.opensource.apple.com/tarballs/Csu/Csu-${PV}.tar.gz"
@@ -21,6 +21,15 @@ src_prepare() {
-e 's:$(SYMROOT)/crt0.o::' \
-e '/LOCLIBDIR)\/crt0.o/d' \
Makefile || die
+
+ if [[ ${CHOST} == powerpc-*-darwin* && ${CHOST##*-darwin} -le 8 ]] ; then
+ # *must not* be compiled with -Os on PPC because that will
+ # optimize out _pointer_to__darwin_gcc3_preregister_frame_info
+ # which causes linker errors for large programs because the
+ # jump to ___darwin_gcc3_preregister_frame_info gets to be more
+ # than 16MB away
+ sed -i -e "s, -Os , -O ,g" Makefile || die
+ fi
}
src_compile() {
diff --git a/sys-libs/csu/csu-85.ebuild b/sys-libs/csu/csu-85.ebuild
new file mode 100644
index 000000000000..fec699cdf02d
--- /dev/null
+++ b/sys-libs/csu/csu-85.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/csu/csu-85.ebuild,v 1.1 2015/02/03 21:04:09 grobian Exp $
+
+EAPI=5
+
+inherit eutils
+
+DESCRIPTION="Darwin Csu (crt1.o) - Mac OS X 10.10 version"
+HOMEPAGE="http://www.opensource.apple.com/"
+SRC_URI="http://www.opensource.apple.com/tarballs/Csu/Csu-${PV}.tar.gz"
+
+LICENSE="APSL-2"
+
+SLOT="0"
+KEYWORDS="~ppc-macos ~x64-macos ~x86-macos"
+IUSE=""
+S=${WORKDIR}/Csu-${PV}
+
+src_prepare() {
+ # since we don't have crt0, we can't build it either
+ sed -i \
+ -e 's:$(SYMROOT)/crt0.o::' \
+ -e '/LOCLIBDIR)\/crt0.o/d' \
+ -e '/^CC = /d' \
+ Makefile || die
+
+ if [[ ${CHOST##*-darwin} -le 8 ]] ; then
+ # Availability.h missing
+ epatch "${FILESDIR}"/${P}-darwin8.patch
+
+ if [[ ${CHOST} == powerpc* ]] ; then
+ # *must not* be compiled with -Os on PPC because that
+ # will optimize out
+ # _pointer_to__darwin_gcc3_preregister_frame_info which
+ # causes linker errors for large programs because the
+ # jump to ___darwin_gcc3_preregister_frame_info gets to
+ # be more than 16MB away
+ sed -i -e "s, -Os , -O ,g" Makefile || die
+ fi
+ fi
+}
+
+src_compile() {
+ emake USRLIBDIR="${EPREFIX}"/lib || die
+}
+
+src_install() {
+ emake -j1 \
+ USRLIBDIR="${EPREFIX}"/lib \
+ LOCLIBDIR="${EPREFIX}"/lib \
+ DSTROOT="${D}" \
+ install || die
+}
diff --git a/sys-libs/csu/files/csu-85-darwin8.patch b/sys-libs/csu/files/csu-85-darwin8.patch
new file mode 100644
index 000000000000..a62a6f6b7045
--- /dev/null
+++ b/sys-libs/csu/files/csu-85-darwin8.patch
@@ -0,0 +1,23 @@
+--- Csu-85/start.s
++++ Csu-85/start.s
+@@ -22,7 +22,10 @@
+ * @APPLE_LICENSE_HEADER_END@
+ */
+
+-#include <Availability.h>
++/* This is fun: We could use AvailabilityMacros.h to check if we're compiling
++ * for < 10.5 and not inclue Availability.h then. But we are compiling with
++ * deployment target 10.5 *on this host* where we still won't have
++ * Availability.h. So just drop the include */
+
+ #if __ppc__ && __DYNAMIC__
+ //
+@@ -203,7 +206,7 @@
+ cmp r4, #0
+ bne Lapple
+ // "apple" param now in r3
+-#if __STATIC__ || ((__IPHONE_OS_VERSION_MIN_REQUIRED >= 30100) && !__ARM_ARCH_4T__)
++#if __STATIC__
+ bl _main
+ b _exit
+ #else