summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMartin Schlemmer <azarah@gentoo.org>2005-07-24 20:01:56 +0000
committerMartin Schlemmer <azarah@gentoo.org>2005-07-24 20:01:56 +0000
commitb79c6043ddbc68bfa6efae38fe6e2dda38a0ff35 (patch)
tree4bc596be633d11ccc0ad5feeeffd123a2db885d9 /sys-libs
parentNew snapshot release. (diff)
downloadgentoo-2-b79c6043ddbc68bfa6efae38fe6e2dda38a0ff35.tar.gz
gentoo-2-b79c6043ddbc68bfa6efae38fe6e2dda38a0ff35.tar.bz2
gentoo-2-b79c6043ddbc68bfa6efae38fe6e2dda38a0ff35.zip
Add the stripping of the dynamic linker from the snapshot ebuilds, else we
cannot set breakpoints in shared libraries. Make sure we only move actual files and not symlinks to the tmp directory. (Portage version: 2.0.51.22-r2)
Diffstat (limited to 'sys-libs')
-rw-r--r--sys-libs/glibc/ChangeLog7
-rw-r--r--sys-libs/glibc/glibc-2.3.5-r1.ebuild15
2 files changed, 17 insertions, 5 deletions
diff --git a/sys-libs/glibc/ChangeLog b/sys-libs/glibc/ChangeLog
index ec2bbd0845db..7c8da51ad931 100644
--- a/sys-libs/glibc/ChangeLog
+++ b/sys-libs/glibc/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sys-libs/glibc
# Copyright 1999-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/glibc/ChangeLog,v 1.369 2005/07/24 19:58:11 azarah Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/glibc/ChangeLog,v 1.370 2005/07/24 20:01:56 azarah Exp $
+
+ 24 Jul 2005; Martin Schlemmer <azarah@gentoo.org> glibc-2.3.5-r1.ebuild:
+ Add the stripping of the dynamic linker from the snapshot ebuilds, else we
+ cannot set breakpoints in shared libraries. Make sure we only move actual
+ files and not symlinks to the tmp directory.
*glibc-2.3.5.20050722 (24 Jul 2005)
diff --git a/sys-libs/glibc/glibc-2.3.5-r1.ebuild b/sys-libs/glibc/glibc-2.3.5-r1.ebuild
index da70dbcf4330..a3c2657ad4db 100644
--- a/sys-libs/glibc/glibc-2.3.5-r1.ebuild
+++ b/sys-libs/glibc/glibc-2.3.5-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/glibc/glibc-2.3.5-r1.ebuild,v 1.6 2005/07/24 07:10:44 corsair Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/glibc/glibc-2.3.5-r1.ebuild,v 1.7 2005/07/24 20:01:56 azarah Exp $
# Here's how the cross-compile logic breaks down ...
# CTARGET - machine that will target the binaries
@@ -377,12 +377,19 @@ toolchain-glibc_src_install() {
rm -rf ${D}/nptl
fi
- # now, strip everything but the thread libs #46186
+ # Now, strip everything but the thread libs #46186, as well as the dynamic
+ # linker, else we cannot set breakpoints in shared libraries.
+ # Fix for ld-* by Lonnie Princehouse.
mkdir -p ${T}/thread-backup
- mv -f ${D}$(alt_libdir)/lib{pthread,thread_db}* ${T}/thread-backup/
+ for x in ${D}$(alt_libdir)/lib{pthread,thread_db}* \
+ ${D}$(alt_libdir)/ld-* ; do
+ [[ -f ${x} ]] && mv -f ${x} ${T}/thread-backup/
+ done
if want_linuxthreads && want_nptl ; then
mkdir -p ${T}/thread-backup/tls
- mv -f ${D}$(alt_libdir)/tls/lib{pthread,thread_db}* ${T}/thread-backup/tls
+ for x in ${D}$(alt_libdir)/tls/lib{pthread,thread_db}* ; do
+ [[ -f ${x} ]] && mv -f ${T}/thread-backup/tls
+ done
fi
env -uRESTRICT CHOST=${CTARGET} prepallstrip
cp -a -- ${T}/thread-backup/* ${D}$(alt_libdir)/ || die