summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeremy Huddleston <eradicator@gentoo.org>2005-10-07 03:12:03 +0000
committerJeremy Huddleston <eradicator@gentoo.org>2005-10-07 03:12:03 +0000
commitbab0ae55d2f31bf108f65a23bb30fd3864521b29 (patch)
tree40b8ce2b2ac19f202c2bf2180348a1fd9b3f6621 /sys-libs
parentWork around use of D as a directory separator. Bug #74090 (diff)
downloadgentoo-2-bab0ae55d2f31bf108f65a23bb30fd3864521b29.tar.gz
gentoo-2-bab0ae55d2f31bf108f65a23bb30fd3864521b29.tar.bz2
gentoo-2-bab0ae55d2f31bf108f65a23bb30fd3864521b29.zip
Avoid using CFLAGS_ for sparc as that is deprecated (and won't work with the default eselect-compiler settings).
(Portage version: 2.0.53_rc3)
Diffstat (limited to 'sys-libs')
-rw-r--r--sys-libs/glibc/ChangeLog7
-rw-r--r--sys-libs/glibc/glibc-2.3.5-r2.ebuild35
-rw-r--r--sys-libs/glibc/glibc-2.3.5.20050722.ebuild36
3 files changed, 51 insertions, 27 deletions
diff --git a/sys-libs/glibc/ChangeLog b/sys-libs/glibc/ChangeLog
index 3fa64567e0c0..a98a059fa33c 100644
--- a/sys-libs/glibc/ChangeLog
+++ b/sys-libs/glibc/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sys-libs/glibc
# Copyright 1999-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/glibc/ChangeLog,v 1.392 2005/10/07 00:40:10 eradicator Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/glibc/ChangeLog,v 1.393 2005/10/07 03:12:03 eradicator Exp $
+
+ 07 Oct 2005; Jeremy Huddleston <eradicator@gentoo.org>
+ glibc-2.3.5-r2.ebuild, glibc-2.3.5.20050722.ebuild:
+ Avoid using CFLAGS_${ABI} for sparc64 as that is deprecated (and won't work
+ with the default eselect-compiler settings).
07 Oct 2005; Jeremy Huddleston <eradicator@gentoo.org>
glibc-2.3.5-r2.ebuild, glibc-2.3.5.20050722.ebuild:
diff --git a/sys-libs/glibc/glibc-2.3.5-r2.ebuild b/sys-libs/glibc/glibc-2.3.5-r2.ebuild
index 6f097c618817..4fa01619e774 100644
--- a/sys-libs/glibc/glibc-2.3.5-r2.ebuild
+++ b/sys-libs/glibc/glibc-2.3.5-r2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/glibc/glibc-2.3.5-r2.ebuild,v 1.3 2005/10/07 00:54:44 eradicator Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/glibc/glibc-2.3.5-r2.ebuild,v 1.4 2005/10/07 03:12:03 eradicator Exp $
# Here's how the cross-compile logic breaks down ...
# CTARGET - machine that will target the binaries
@@ -610,6 +610,13 @@ alt_usrlibdir() {
}
setup_flags() {
+ # Store our CFLAGS because it's changed depending on which CTARGET
+ # we are building when pulling glibc on a multilib profile
+ CFLAGS_BASE=${CFLAGS_BASE-${CFLAGS}}
+ CFLAGS=${CFLAGS_BASE}
+ ASFLAGS_BASE=${ASFLAGS_BASE-${ASFLAGS}}
+ ASFLAGS=${ASFLAGS_BASE}
+
# Over-zealous CFLAGS can often cause problems. What may work for one
# person may not work for another. To avoid a large influx of bugs
# relating to failed builds, we strip most CFLAGS out to ensure as few
@@ -620,10 +627,11 @@ setup_flags() {
unset CBUILD_OPT CTARGET_OPT
has_multilib_profile && CTARGET_OPT=$(get_abi_CHOST)
+ [[ -z ${CTARGET_OPT} ]] && CTARGET_OPT=$(get_abi_CHOST)
case $(tc-arch) in
- # Punt this when amd64's 2004.3 is removed
amd64)
+ # Punt this when amd64's 2004.3 is removed
CFLAGS_x86="-m32"
;;
ppc)
@@ -638,15 +646,17 @@ setup_flags() {
if is_crosscompile || [[ ${PROFILE_ARCH} == "sparc64" ]] || { has_multilib_profile && ! tc-is-cross-compiler; } ; then
case ${ABI} in
sparc64)
+ filter-flags -Wa,-xarch -Wa,-A
+
if is-flag "-mcpu=ultrasparc3"; then
CTARGET_OPT="sparc64b-unknown-linux-gnu"
- CFLAGS_sparc64="$(get_abi_CFLAGS) -Wa,-xarch=v9b"
+ append-flags "-Wa,-xarch=v9b"
+ export ASFLAGS="${ASFLAGS} -Wa,-xarch=v9b"
else
CTARGET_OPT="sparc64-unknown-linux-gnu"
- CFLAGS_sparc64="$(get_abi_CFLAGS) -Wa,-xarch=v9a"
+ append-flags "-Wa,-xarch=v9a"
+ export ASFLAGS="${ASFLAGS} -Wa,-xarch=v9a"
fi
-
- filter-flags -Wa,-xarch -Wa,-A
;;
*)
if is-flag "-mcpu=ultrasparc3"; then
@@ -958,23 +968,22 @@ use_multilib() {
# Setup toolchain variables that would be defined in the profiles for these archs.
setup_env() {
- setup_flags
-
if is_crosscompile || tc-is-cross-compiler ; then
multilib_env ${CTARGET}
+ # We only install for this CTARGET on crosscompilers
+ MULTILIB_ABIS=${DEFAULT_ABI}
+ ABI=${DEFAULT_ABI}
+
# We need to export CFLAGS with abi information in them because
# glibc's configure script checks CFLAGS for some targets (like mips)
local VAR="CFLAGS_"${CTARGET//[-.]/_}
CFLAGS=${!VAR-"-O2 -pipe"}
-
- # We only install for this CTARGET on crosscompilers
- MULTILIB_ABIS=${DEFAULT_ABI}
-
- ABI=${DEFAULT_ABI:-default}
fi
export ABI=${ABI:-${DEFAULT_ABI:-default}}
+
+ setup_flags
}
### /ECLASS PUNTAGE ###
diff --git a/sys-libs/glibc/glibc-2.3.5.20050722.ebuild b/sys-libs/glibc/glibc-2.3.5.20050722.ebuild
index ca514aece034..4c2fd23403fd 100644
--- a/sys-libs/glibc/glibc-2.3.5.20050722.ebuild
+++ b/sys-libs/glibc/glibc-2.3.5.20050722.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/glibc/glibc-2.3.5.20050722.ebuild,v 1.19 2005/10/07 00:54:44 eradicator Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/glibc/glibc-2.3.5.20050722.ebuild,v 1.20 2005/10/07 03:12:03 eradicator Exp $
# Here's how the cross-compile logic breaks down ...
# CTARGET - machine that will target the binaries
@@ -613,6 +613,13 @@ alt_usrlibdir() {
}
setup_flags() {
+ # Store our CFLAGS because it's changed depending on which CTARGET
+ # we are building when pulling glibc on a multilib profile
+ CFLAGS_BASE=${CFLAGS_BASE-${CFLAGS}}
+ CFLAGS=${CFLAGS_BASE}
+ ASFLAGS_BASE=${ASFLAGS_BASE-${ASFLAGS}}
+ ASFLAGS=${ASFLAGS_BASE}
+
# Over-zealous CFLAGS can often cause problems. What may work for one
# person may not work for another. To avoid a large influx of bugs
# relating to failed builds, we strip most CFLAGS out to ensure as few
@@ -621,7 +628,9 @@ setup_flags() {
strip-unsupported-flags
filter-flags -m32 -m64 -mabi=*
- has_multilib_profile && CTARGET_OPT=$(get_abi_CHOST)
+ unset CBUILD_OPT CTARGET_OPT
+ has_multilib_profile && CTARGET_OPT=$(get_abi_CTARGET)
+ [[ -z ${CTARGET_OPT} ]] && CTARGET_OPT=$(get_abi_CHOST)
case $(tc-arch) in
ppc)
@@ -636,15 +645,17 @@ setup_flags() {
if is_crosscompile || [[ ${PROFILE_ARCH} == "sparc64" ]] || { has_multilib_profile && ! tc-is-cross-compiler; } ; then
case ${ABI} in
sparc64)
+ filter-flags -Wa,-xarch -Wa,-A
+
if is-flag "-mcpu=ultrasparc3"; then
CTARGET_OPT="sparc64b-unknown-linux-gnu"
- CFLAGS_sparc64="$(get_abi_CFLAGS) -Wa,-xarch=v9b"
+ append-flags "-Wa,-xarch=v9b"
+ export ASFLAGS="${ASFLAGS} -Wa,-xarch=v9b"
else
CTARGET_OPT="sparc64-unknown-linux-gnu"
- CFLAGS_sparc64="$(get_abi_CFLAGS) -Wa,-xarch=v9a"
+ append-flags "-Wa,-xarch=v9a"
+ export ASFLAGS="${ASFLAGS} -Wa,-xarch=v9a"
fi
-
- filter-flags -Wa,-xarch -Wa,-A
;;
*)
if is-flag "-mcpu=ultrasparc3"; then
@@ -961,23 +972,22 @@ use_multilib() {
# Setup toolchain variables that would be defined in the profiles for these archs.
setup_env() {
- setup_flags
-
if is_crosscompile || tc-is-cross-compiler; then
multilib_env ${CTARGET}
+ # We only install for this CTARGET on crosscompilers
+ MULTILIB_ABIS=${DEFAULT_ABI}
+ ABI=${DEFAULT_ABI}
+
# We need to export CFLAGS with abi information in them because
# glibc's configure script checks CFLAGS for some targets (like mips)
local VAR="CFLAGS_"${CTARGET//[-.]/_}
CFLAGS=${!VAR-"-O2 -pipe"}
-
- # We only install for this CTARGET on crosscompilers
- MULTILIB_ABIS=${DEFAULT_ABI}
-
- ABI=${DEFAULT_ABI:-default}
fi
export ABI=${ABI:-${DEFAULT_ABI:-default}}
+
+ setup_flags
}
### /ECLASS PUNTAGE ###