summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMartin Schlemmer <azarah@gentoo.org>2003-08-16 04:44:55 +0000
committerMartin Schlemmer <azarah@gentoo.org>2003-08-16 04:44:55 +0000
commitd7ba9f86309c1cf48830b95afe7e9a4e1c973f90 (patch)
tree2846b1bc7f027d897c3d72e88f9256e6ce1d9701 /sys-libs
parentGet db to link libdb* to correct dependencies ... for example if we use (diff)
downloadgentoo-2-d7ba9f86309c1cf48830b95afe7e9a4e1c973f90.tar.gz
gentoo-2-d7ba9f86309c1cf48830b95afe7e9a4e1c973f90.tar.bz2
gentoo-2-d7ba9f86309c1cf48830b95afe7e9a4e1c973f90.zip
Get db to link libdb* to correct dependencies ... for example if we use
NPTL or NGPT, db detects usable mutexes, and should link against libpthread, but does not do so ...
Diffstat (limited to 'sys-libs')
-rw-r--r--sys-libs/db/ChangeLog10
-rw-r--r--sys-libs/db/Manifest5
-rw-r--r--sys-libs/db/db-4.0.14-r1.ebuild104
-rw-r--r--sys-libs/db/files/db-4.0.14-fix-dep-link.patch38
-rw-r--r--sys-libs/db/files/digest-db-4.0.14-r11
5 files changed, 155 insertions, 3 deletions
diff --git a/sys-libs/db/ChangeLog b/sys-libs/db/ChangeLog
index 1c31f5da3176..52d61d466c4d 100644
--- a/sys-libs/db/ChangeLog
+++ b/sys-libs/db/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for sys-libs/db
# Copyright 2002-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/db/ChangeLog,v 1.38 2003/08/05 10:21:53 pauldv Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/db/ChangeLog,v 1.39 2003/08/16 04:44:34 azarah Exp $
+
+*db-4.0.14-r1 (16 Aug 2003)
+
+ 16 Aug 2003; Martin Schlemmer <azarah@gentoo.org> db-4.0.14-r1.ebuild,
+ files/db-4.0.14-fix-dep-link.patch:
+ Get db to link libdb* to correct dependencies ... for example if we use
+ NPTL or NGPT, db detects usable mutexes, and should link against
+ libpthread, but does not do so ...
*db-4.1.25_p1 (05 Aug 2003)
diff --git a/sys-libs/db/Manifest b/sys-libs/db/Manifest
index 896664e489a9..bdfe02c7ca38 100644
--- a/sys-libs/db/Manifest
+++ b/sys-libs/db/Manifest
@@ -1,9 +1,10 @@
-MD5 119f3908892478c62f3afef358d87ac7 ChangeLog 7387
+MD5 4c39f02a56211a1bb4c3c8293f648395 ChangeLog 7706
MD5 f5688fefc8d29c29aa1ae2833131eaa3 db-1.85-r1.ebuild 1412
MD5 5f58370f7996039a42c4805b7739715b db-3.2.3h-r4.ebuild 2456
-MD5 b52ee37e6d304b52e4b45beb6a52e649 db-4.0.14-r1.ebuild 2702
+MD5 c6009731de4a567b77ffb70b5be0da4a db-4.0.14-r1.ebuild 2707
MD5 bb23c5ae6636a708085812b7832e2c60 db-3.2.9.ebuild 2465
MD5 0dcedfa3f8fa0c10ac06b6f27217e45d db-3.3.11.ebuild 2408
+MD5 0493e4704292527cfb123d8b1f770d1d db-4.0.14.ebuild 2387
MD5 a037a9713737ca0f498c85f7e0e1dbd6 db-3.2.9-r2.ebuild 3222
MD5 7bbdb8e7c9f500b78b934c556a7f5eeb db-3.2.9-r1.ebuild 2585
MD5 89aa256dfbcb71045963bc17ea439796 db-3.2.9-r5.ebuild 4264
diff --git a/sys-libs/db/db-4.0.14-r1.ebuild b/sys-libs/db/db-4.0.14-r1.ebuild
new file mode 100644
index 000000000000..96de40464126
--- /dev/null
+++ b/sys-libs/db/db-4.0.14-r1.ebuild
@@ -0,0 +1,104 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/db/db-4.0.14-r1.ebuild,v 1.1 2003/08/16 04:44:34 azarah Exp $
+
+IUSE="tcltk java"
+
+S="${WORKDIR}/${P}/build_unix"
+DESCRIPTION="Berkeley DB"
+SRC_URI="http://www.sleepycat.com/update/snapshot/${P}.tar.gz"
+HOMEPAGE="http://www.sleepycat.com"
+SLOT="4"
+LICENSE="DB"
+KEYWORDS="~x86"
+
+DEPEND="tcltk? ( dev-lang/tcl )
+ java? ( virtual/jdk )"
+
+src_unpack() {
+ unpack ${A}
+
+ # Get db to link libdb* to correct dependencies ... for example if we use
+ # NPTL or NGPT, db detects usable mutexes, and should link against
+ # libpthread, but does not do so ...
+ # <azarah@gentoo.org> (23 Feb 2003)
+ cd ${WORKDIR}/${P}; epatch ${FILESDIR}/${P}-fix-dep-link.patch
+}
+
+src_compile() {
+
+ local myconf=
+
+ use java \
+ && myconf="${myconf} --enable-java" \
+ || myconf="${myconf} --disable-java"
+
+ use tcltk \
+ && myconf="${myconf} --enable-tcl --with-tcl=/usr/lib" \
+ || myconf="${myconf} --disable-tcl"
+
+ if [ -n "${JAVAC}" ]; then
+ export PATH=`dirname ${JAVAC}`:${PATH}
+ export JAVAC=`basename ${JAVAC}`
+ fi
+
+ ../dist/configure \
+ --prefix=/usr \
+ --mandir=/usr/share/man \
+ --infodir=/usr/share/info \
+ --datadir=/usr/share \
+ --sysconfdir=/etc \
+ --localstatedir=/var/lib \
+ --enable-compat185 \
+ --enable-cxx \
+ --with-uniquename \
+ ${myconf} || die
+
+# disable posix mutexes as they are not available in linuxthreads from
+# the standard profile and they should be autodetected if available
+#
+# --enable-posixmutexes \
+
+ emake || make || die
+}
+
+src_install () {
+
+ einstall || die
+ for fname in ${D}/usr/bin/db_*
+ do
+ mv ${fname} ${fname//\/db_/\/db4_}
+ done
+
+ dodir /usr/include/db4
+ mv ${D}/usr/include/*.h ${D}/usr/include/db4/
+
+ dodir /usr/share/doc/${PF}/html
+ mv ${D}/usr/docs/* ${D}/usr/share/doc/${PF}/html/
+ ln -s /usr/include/db4/db.h ${D}/usr/include/db.h
+}
+
+fix_so () {
+ cd ${ROOT}/usr/lib
+ target=`find -type f -maxdepth 1 -name "libdb-*.so" |sort |tail -n 1`
+ [ -n "${target}" ] && ln -sf ${target//.\//} libdb.so
+ target=`find -type f -maxdepth 1 -name "libdb_cxx*.so" |sort |tail -n 1`
+ [ -n "${target}" ] && ln -sf ${target//.\//} libdb_cxx.so
+ target=`find -type f -maxdepth 1 -name "libdb_tcl*.so" |sort |tail -n 1`
+ [ -n "${target}" ] && ln -sf ${target//.\//} libdb_tcl.so
+ target=`find -type f -maxdepth 1 -name "libdb_java*.so" |sort |tail -n 1`
+ [ -n "${target}" ] && ln -sf ${target//.\//} libdb_java.so
+
+ cd ${ROOT}/usr/include
+ target=`ls -d db? |sort |tail -n 1`
+ [ -n "${target}" ] && ln -sf ${target}/db.h .
+ [ -n "${target}" ] && ln -sf ${target}/db_185.h .
+}
+
+pkg_postinst () {
+ fix_so
+}
+
+pkg_postrm () {
+ fix_so
+}
diff --git a/sys-libs/db/files/db-4.0.14-fix-dep-link.patch b/sys-libs/db/files/db-4.0.14-fix-dep-link.patch
new file mode 100644
index 000000000000..f54f064640e6
--- /dev/null
+++ b/sys-libs/db/files/db-4.0.14-fix-dep-link.patch
@@ -0,0 +1,38 @@
+--- db-4.0.14/dist/Makefile.in.orig 2003-08-16 06:21:53.763400112 +0200
++++ db-4.0.14/dist/Makefile.in 2003-08-16 06:23:16.036892640 +0200
+@@ -58,7 +58,7 @@
+
+ LDFLAGS= @LDFLAGS@
+ LIBS= @LIBS@
+-LIBSO_LIBS= @LIBSO_LIBS@
++LIBSO_LIBS= @LIBSO_LIBS@ $(LIBS)
+
+ libdb= libdb.a
+ libso_base= libdb
+@@ -77,7 +77,7 @@
+ CXX= @MAKEFILE_CXX@
+ CXXLINK= @MAKEFILE_CXXLINK@
+ XSOLINK= @MAKEFILE_XSOLINK@
+-LIBXSO_LIBS= @LIBXSO_LIBS@
++LIBXSO_LIBS= @LIBXSO_LIBS@ $(LIBS)
+
+ libcxx= libdb_cxx.a
+ libxso_base= libdb_cxx
+@@ -93,7 +93,7 @@
+ # Java support is optional and requires shared librarires.
+ ##################################################
+ CLASSPATH= $(JAVA_CLASSTOP)
+-LIBJSO_LIBS= @LIBJSO_LIBS@
++LIBJSO_LIBS= @LIBJSO_LIBS@ $(LIBS)
+
+ JAR= @JAR@
+ JAVAC= env CLASSPATH="$(CLASSPATH)" @JAVAC@
+@@ -121,7 +121,7 @@
+ # Tcl support is optional and requires shared libraries.
+ ##################################################
+ TCFLAGS= @TCFLAGS@
+-LIBTSO_LIBS= @LIBTSO_LIBS@
++LIBTSO_LIBS= @LIBTSO_LIBS@ $(LIBS)
+ libtso_base= libdb_tcl
+ libtso= $(libtso_base)-$(SOVERSION).@SOSUFFIX@
+ libtso_static= $(libtso_base)-$(SOVERSION).a
diff --git a/sys-libs/db/files/digest-db-4.0.14-r1 b/sys-libs/db/files/digest-db-4.0.14-r1
new file mode 100644
index 000000000000..cb9924c89b80
--- /dev/null
+++ b/sys-libs/db/files/digest-db-4.0.14-r1
@@ -0,0 +1 @@
+MD5 12262c64fcd64b772e7cffad8e4d0ebc db-4.0.14.tar.gz 2701799