summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeremy Huddleston <eradicator@gentoo.org>2005-03-05 23:45:05 +0000
committerJeremy Huddleston <eradicator@gentoo.org>2005-03-05 23:45:05 +0000
commitdb0d18e987c658123c1d5f8704e95ba4e4aa7c7d (patch)
tree0202e75bb728b1a5288c7227d6e888bf668313fc /sys-libs
parentMarked ~ppc. (diff)
downloadgentoo-2-db0d18e987c658123c1d5f8704e95ba4e4aa7c7d.tar.gz
gentoo-2-db0d18e987c658123c1d5f8704e95ba4e4aa7c7d.tar.bz2
gentoo-2-db0d18e987c658123c1d5f8704e95ba4e4aa7c7d.zip
Fixed crosscompile want_nptl. Fixed broken src_install logic which resulted in only nptl version being installed.
(Portage version: 2.0.51.19)
Diffstat (limited to 'sys-libs')
-rw-r--r--sys-libs/glibc/ChangeLog7
-rw-r--r--sys-libs/glibc/glibc-2.3.4.20050125-r1.ebuild11
2 files changed, 11 insertions, 7 deletions
diff --git a/sys-libs/glibc/ChangeLog b/sys-libs/glibc/ChangeLog
index 0c51e4b6c6b9..dba58addba65 100644
--- a/sys-libs/glibc/ChangeLog
+++ b/sys-libs/glibc/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sys-libs/glibc
# Copyright 2002-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/glibc/ChangeLog,v 1.322 2005/03/05 22:13:31 eradicator Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/glibc/ChangeLog,v 1.323 2005/03/05 23:45:05 eradicator Exp $
+
+ 05 Mar 2005; Jeremy Huddleston <eradicator@gentoo.org>
+ glibc-2.3.4.20050125-r1.ebuild:
+ Fixed crosscompile want_nptl. Fixed broken src_install logic which resulted
+ in only nptl version being installed.
05 Mar 2005; Jeremy Huddleston <eradicator@gentoo.org>
glibc-2.3.4.20050125-r1.ebuild:
diff --git a/sys-libs/glibc/glibc-2.3.4.20050125-r1.ebuild b/sys-libs/glibc/glibc-2.3.4.20050125-r1.ebuild
index b5ef850f8910..6a6813942266 100644
--- a/sys-libs/glibc/glibc-2.3.4.20050125-r1.ebuild
+++ b/sys-libs/glibc/glibc-2.3.4.20050125-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/glibc/glibc-2.3.4.20050125-r1.ebuild,v 1.13 2005/03/05 23:33:28 eradicator Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/glibc/glibc-2.3.4.20050125-r1.ebuild,v 1.14 2005/03/05 23:45:05 eradicator Exp $
# Here's how the cross-compile logic breaks down ...
# CTARGET - machine that will target the binaries
@@ -301,8 +301,7 @@ toolchain-glibc_src_install() {
make PARALLELMFLAGS="${MAKEOPTS} -j1" \
install_root=${D} \
install || die
- fi
- if want_nptl ; then
+ elif use nptlonly ; then
cd ${WORKDIR}/build-${ABI}-${CTARGET}-nptl
einfo "Installing GLIBC with NPTL..."
make PARALLELMFLAGS="${MAKEOPTS} -j1" \
@@ -625,7 +624,7 @@ setup_flags() {
else
if is-flag "-mcpu=ultrasparc3"; then
CTARGET_OPT="sparcv9b-unknown-linux-gnu"
- elif { is_crosscompile && use nptl; } || is-flag "-mcpu=ultrasparc2" || is-flag "-mcpu=ultrasparc"; then
+ elif { is_crosscompile && want_nptl; } || is-flag "-mcpu=ultrasparc2" || is-flag "-mcpu=ultrasparc"; then
CTARGET_OPT="sparcv9-unknown-linux-gnu"
fi
fi
@@ -722,7 +721,7 @@ want_nptl() {
return 0;
;;
x86)
- case ${CHOST/-*} in
+ case ${CTARGET/-*} in
i486|i586|i686) return 0 ;;
esac
;;
@@ -1232,7 +1231,7 @@ src_install() {
dosed "s:/lib/:/$(get_libdir)/:g" /usr/$(get_libdir)/lib{c,pthread}.so
- if use nptl && want_linuxthreads ; then
+ if want_nptl && want_linuxthreads ; then
dosed "s:/lib/:/$(get_libdir)/:g" /usr/$(get_libdir)/nptl/lib{c,pthread}.so
fi
fi