summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAnthony G. Basile <blueness@gentoo.org>2015-01-14 12:50:05 +0000
committerAnthony G. Basile <blueness@gentoo.org>2015-01-14 12:50:05 +0000
commitf387b0ab0525ac76604d5332167ab92545bbc29a (patch)
treeb56f2f543afe7b9bde44d07ea2e65807fb5e6e02 /sys-libs
parentReverse the version numbers so that users will see an upgrade instead of a do... (diff)
downloadgentoo-2-f387b0ab0525ac76604d5332167ab92545bbc29a.tar.gz
gentoo-2-f387b0ab0525ac76604d5332167ab92545bbc29a.tar.bz2
gentoo-2-f387b0ab0525ac76604d5332167ab92545bbc29a.zip
Version bump
(Portage version: 2.2.14/cvs/Linux x86_64, signed Manifest commit with key 0xF52D4BBA)
Diffstat (limited to 'sys-libs')
-rw-r--r--sys-libs/musl/ChangeLog9
-rw-r--r--sys-libs/musl/musl-1.1.6.ebuild99
2 files changed, 106 insertions, 2 deletions
diff --git a/sys-libs/musl/ChangeLog b/sys-libs/musl/ChangeLog
index 18ff059074ca..260d941c8cd4 100644
--- a/sys-libs/musl/ChangeLog
+++ b/sys-libs/musl/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sys-libs/musl
-# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/musl/ChangeLog,v 1.39 2014/11/18 18:29:40 blueness Exp $
+# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/musl/ChangeLog,v 1.40 2015/01/14 12:50:05 blueness Exp $
+
+*musl-1.1.6 (14 Jan 2015)
+
+ 14 Jan 2015; Anthony G. Basile <blueness@gentoo.org> +musl-1.1.6.ebuild:
+ Version bump
18 Nov 2014; Anthony G. Basile <blueness@gentoo.org> musl-1.1.5.ebuild:
Stable on ppc
diff --git a/sys-libs/musl/musl-1.1.6.ebuild b/sys-libs/musl/musl-1.1.6.ebuild
new file mode 100644
index 000000000000..51a268a122eb
--- /dev/null
+++ b/sys-libs/musl/musl-1.1.6.ebuild
@@ -0,0 +1,99 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/musl/musl-1.1.6.ebuild,v 1.1 2015/01/14 12:50:05 blueness Exp $
+
+EAPI=5
+
+inherit eutils flag-o-matic multilib toolchain-funcs
+if [[ ${PV} == "9999" ]] ; then
+ EGIT_REPO_URI="git://git.musl-libc.org/musl"
+ inherit git-2
+fi
+
+export CBUILD=${CBUILD:-${CHOST}}
+export CTARGET=${CTARGET:-${CHOST}}
+if [[ ${CTARGET} == ${CHOST} ]] ; then
+ if [[ ${CATEGORY/cross-} != ${CATEGORY} ]] ; then
+ export CTARGET=${CATEGORY/cross-}
+ fi
+fi
+
+DESCRIPTION="Lightweight, fast and simple C library focused on standards-conformance and safety"
+HOMEPAGE="http://www.musl-libc.org/"
+if [[ ${PV} != "9999" ]] ; then
+ PATCH_VER=""
+ SRC_URI="http://www.musl-libc.org/releases/${P}.tar.gz"
+ KEYWORDS="-* ~amd64 ~arm ~mips ~ppc ~x86"
+fi
+
+LICENSE="MIT"
+SLOT="0"
+IUSE="crosscompile_opts_headers-only"
+
+if [[ ${CATEGORY} != cross-* ]] ; then
+ RDEPEND+=" sys-apps/getent"
+fi
+
+is_crosscompile() {
+ [[ ${CHOST} != ${CTARGET} ]]
+}
+
+just_headers() {
+ use crosscompile_opts_headers-only && is_crosscompile
+}
+
+pkg_setup() {
+ if [ ${CTARGET} == ${CHOST} ] ; then
+ case ${CHOST} in
+ *-musl*) ;;
+ *) die "Use sys-devel/crossdev to build a musl toolchain" ;;
+ esac
+ fi
+
+ epatch_user
+}
+
+src_configure() {
+ tc-getCC ${CTARGET}
+ just_headers && export CC=true
+
+ ./configure \
+ --target="${CTARGET}" \
+ --prefix="/usr" \
+ --disable-gcc-wrapper
+}
+
+src_compile() {
+ emake include/bits/alltypes.h || die
+ just_headers && return 0
+
+ emake || die
+}
+
+src_install() {
+ local sysroot=${D}
+ is_crosscompile && sysroot+="/usr/${CTARGET}"
+
+ local target="install"
+ just_headers && target="install-headers"
+ emake DESTDIR="${sysroot}" ${target} || die
+
+ # Make sure we install the sys-include symlink so that when
+ # we build a 2nd stage cross-compiler, gcc finds the target
+ # system headers correctly. See gcc/doc/gccinstall.info
+ if is_crosscompile ; then
+ dosym usr/include /usr/${CTARGET}/sys-include
+ fi
+}
+
+pkg_postinst() {
+ is_crosscompile && return 0
+
+ [ "${ROOT}" != "/" ] && return 0
+
+ # TODO: musl doesn't use ldconfig, instead here we can
+ # create sym links to libraries outside of /lib and /usr/lib
+ ldconfig
+ # reload init ...
+ /sbin/telinit U 2>/dev/null
+}