summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeremy Huddleston <eradicator@gentoo.org>2005-08-21 04:25:11 +0000
committerJeremy Huddleston <eradicator@gentoo.org>2005-08-21 04:25:11 +0000
commitf7775dacb0ab0e27a62dcd22fa311d6758dc923b (patch)
tree793b42a6f28211fa6df58188157b59cb8c9e9bc4 /sys-libs
parentinitial import -bug #94921 (diff)
downloadgentoo-2-f7775dacb0ab0e27a62dcd22fa311d6758dc923b.tar.gz
gentoo-2-f7775dacb0ab0e27a62dcd22fa311d6758dc923b.tar.bz2
gentoo-2-f7775dacb0ab0e27a62dcd22fa311d6758dc923b.zip
Force builds of x86 glibc on amd64 to ignore /emul.
(Portage version: 2.0.51.22-r2)
Diffstat (limited to 'sys-libs')
-rw-r--r--sys-libs/glibc/glibc-2.3.5-r1.ebuild5
-rw-r--r--sys-libs/glibc/glibc-2.3.5.20050722.ebuild5
-rw-r--r--sys-libs/glibc/glibc-2.3.5.ebuild5
3 files changed, 12 insertions, 3 deletions
diff --git a/sys-libs/glibc/glibc-2.3.5-r1.ebuild b/sys-libs/glibc/glibc-2.3.5-r1.ebuild
index 0b7a2678903d..757b4ae7f72e 100644
--- a/sys-libs/glibc/glibc-2.3.5-r1.ebuild
+++ b/sys-libs/glibc/glibc-2.3.5-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/glibc/glibc-2.3.5-r1.ebuild,v 1.19 2005/08/17 00:36:34 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/glibc/glibc-2.3.5-r1.ebuild,v 1.20 2005/08/21 04:25:11 eradicator Exp $
# Here's how the cross-compile logic breaks down ...
# CTARGET - machine that will target the binaries
@@ -619,6 +619,9 @@ setup_flags() {
has_multilib_profile && CTARGET_OPT="$(get_abi_CHOST)"
case $(tc-arch) in
+ amd64)
+ CFLAGS_x86="-m32"
+ ;;
ppc)
append-flags "-freorder-blocks"
;;
diff --git a/sys-libs/glibc/glibc-2.3.5.20050722.ebuild b/sys-libs/glibc/glibc-2.3.5.20050722.ebuild
index d251bb882190..db85b609622b 100644
--- a/sys-libs/glibc/glibc-2.3.5.20050722.ebuild
+++ b/sys-libs/glibc/glibc-2.3.5.20050722.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/glibc/glibc-2.3.5.20050722.ebuild,v 1.9 2005/08/17 00:36:34 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/glibc/glibc-2.3.5.20050722.ebuild,v 1.10 2005/08/21 04:25:11 eradicator Exp $
# Here's how the cross-compile logic breaks down ...
# CTARGET - machine that will target the binaries
@@ -625,6 +625,9 @@ setup_flags() {
has_multilib_profile && CTARGET_OPT="$(get_abi_CHOST)"
case $(tc-arch) in
+ amd64)
+ CFLAGS_x86="-m32"
+ ;;
ppc)
append-flags "-freorder-blocks"
;;
diff --git a/sys-libs/glibc/glibc-2.3.5.ebuild b/sys-libs/glibc/glibc-2.3.5.ebuild
index 103625a2d564..d90daf719fde 100644
--- a/sys-libs/glibc/glibc-2.3.5.ebuild
+++ b/sys-libs/glibc/glibc-2.3.5.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/glibc/glibc-2.3.5.ebuild,v 1.40 2005/08/13 03:54:31 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/glibc/glibc-2.3.5.ebuild,v 1.41 2005/08/21 04:25:11 eradicator Exp $
# Here's how the cross-compile logic breaks down ...
# CTARGET - machine that will target the binaries
@@ -623,6 +623,9 @@ setup_flags() {
has_multilib_profile && CTARGET_OPT="$(get_abi_CHOST)"
case $(tc-arch) in
+ amd64)
+ CFLAGS_x86="-m32"
+ ;;
ppc)
append-flags "-freorder-blocks"
;;