summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2010-01-16 23:57:40 +0000
committerMike Frysinger <vapier@gentoo.org>2010-01-16 23:57:40 +0000
commit8f068c1accd41e968b7c98ecec5b6cc80e5d813e (patch)
tree59bbfae6e1ac60b09491354624115a80b8e775d0 /sys-power/cpufrequtils
parentold (diff)
downloadgentoo-2-8f068c1accd41e968b7c98ecec5b6cc80e5d813e.tar.gz
gentoo-2-8f068c1accd41e968b7c98ecec5b6cc80e5d813e.tar.bz2
gentoo-2-8f068c1accd41e968b7c98ecec5b6cc80e5d813e.zip
Version bump.
(Portage version: 2.2_rc61/cvs/Linux x86_64)
Diffstat (limited to 'sys-power/cpufrequtils')
-rw-r--r--sys-power/cpufrequtils/ChangeLog8
-rw-r--r--sys-power/cpufrequtils/cpufrequtils-007.ebuild49
-rw-r--r--sys-power/cpufrequtils/files/cpufrequtils-007-build.patch14
-rw-r--r--sys-power/cpufrequtils/files/cpufrequtils-007-nls.patch76
4 files changed, 146 insertions, 1 deletions
diff --git a/sys-power/cpufrequtils/ChangeLog b/sys-power/cpufrequtils/ChangeLog
index a478b226f546..e00b29ba4e15 100644
--- a/sys-power/cpufrequtils/ChangeLog
+++ b/sys-power/cpufrequtils/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sys-power/cpufrequtils
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-power/cpufrequtils/ChangeLog,v 1.48 2010/01/15 19:50:27 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-power/cpufrequtils/ChangeLog,v 1.49 2010/01/16 23:57:40 vapier Exp $
+
+*cpufrequtils-007 (16 Jan 2010)
+
+ 16 Jan 2010; Mike Frysinger <vapier@gentoo.org> +cpufrequtils-007.ebuild,
+ +files/cpufrequtils-007-build.patch, +files/cpufrequtils-007-nls.patch:
+ Version bump.
15 Jan 2010; Mike Frysinger <vapier@gentoo.org> cpufrequtils-006.ebuild,
-files/cpufrequtils-006-modprobe-gov.patch:
diff --git a/sys-power/cpufrequtils/cpufrequtils-007.ebuild b/sys-power/cpufrequtils/cpufrequtils-007.ebuild
new file mode 100644
index 000000000000..19a3bf644d85
--- /dev/null
+++ b/sys-power/cpufrequtils/cpufrequtils-007.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-power/cpufrequtils/cpufrequtils-007.ebuild,v 1.1 2010/01/16 23:57:40 vapier Exp $
+
+inherit eutils toolchain-funcs multilib
+
+DESCRIPTION="Userspace utilities for the Linux kernel cpufreq subsystem"
+HOMEPAGE="http://www.kernel.org/pub/linux/utils/kernel/cpufreq/cpufrequtils.html"
+SRC_URI="mirror://kernel/linux/utils/kernel/cpufreq/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE="debug nls"
+
+DEPEND="sys-fs/sysfsutils"
+
+ft() { use $1 && echo true || echo false ; }
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}"/${PN}-007-build.patch
+ epatch "${FILESDIR}"/${PN}-007-nls.patch #205576 #292246
+
+ export DEBUG=$(ft debug) V=true NLS=$(ft nls)
+ unset bindir sbindir includedir localedir confdir
+ export mandir="/usr/share/man"
+ export libdir="/usr/$(get_libdir)"
+ export docdir="/usr/share/doc/${PF}"
+}
+
+src_compile() {
+ emake \
+ CC="$(tc-getCC)" \
+ LD="$(tc-getCC)" \
+ AR="$(tc-getAR)" \
+ STRIP=: \
+ RANLIB="$(tc-getRANLIB)" \
+ || die
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die
+ dodoc AUTHORS README
+
+ newinitd "${FILESDIR}"/${PN}-init.d-006 ${PN} || die
+ newconfd "${FILESDIR}"/${PN}-conf.d-006 ${PN}
+}
diff --git a/sys-power/cpufrequtils/files/cpufrequtils-007-build.patch b/sys-power/cpufrequtils/files/cpufrequtils-007-build.patch
new file mode 100644
index 000000000000..3e0d18b0ab3d
--- /dev/null
+++ b/sys-power/cpufrequtils/files/cpufrequtils-007-build.patch
@@ -0,0 +1,14 @@
+--- Makefile
++++ Makefile
+@@ -158,11 +158,9 @@ endif
+
+ # if DEBUG is enabled, then we do not strip or optimize
+ ifeq ($(strip $(DEBUG)),true)
+- CFLAGS += -O1 -g
+ CPPFLAGS += -DDEBUG
+ STRIPCMD = /bin/true -Since_we_are_debugging
+ else
+- CFLAGS += $(OPTIMIZATION) -fomit-frame-pointer
+ STRIPCMD = $(STRIP) -s --remove-section=.note --remove-section=.comment
+ endif
+
diff --git a/sys-power/cpufrequtils/files/cpufrequtils-007-nls.patch b/sys-power/cpufrequtils/files/cpufrequtils-007-nls.patch
new file mode 100644
index 000000000000..83ab0b11f0cd
--- /dev/null
+++ b/sys-power/cpufrequtils/files/cpufrequtils-007-nls.patch
@@ -0,0 +1,76 @@
+make nls/gettext support optional
+
+patch by
+Jos van der Ende <seraph@xs4all.nl>
+Lars Wendler <polynomial-c@gentoo.org>
+
+http://bugs.gentoo.org/205576
+http://bugs.gentoo.org/292246
+
+--- cpufrequtils-006/Makefile
++++ cpufrequtils-006/Makefile
+@@ -147,6 +147,7 @@
+ ifeq ($(strip $(NLS)),true)
+ INSTALL_NLS += install-gmo
+ COMPILE_NLS += update-gmo
++ CPPFLAGS += -DNLS
+ endif
+
+ ifeq ($(strip $(CPUFRQ_BENCH)),true)
+--- cpufrequtils-006/utils/info.c
++++ cpufrequtils-006/utils/info.c
+@@ -10,7 +10,6 @@
+ #include <errno.h>
+ #include <stdlib.h>
+ #include <string.h>
+-#include <libintl.h>
+ #include <locale.h>
+
+ #include <getopt.h>
+@@ -18,9 +17,18 @@
+ #include "cpufreq.h"
+
+
++#ifdef NLS
++#include <libintl.h>
+ #define _(String) gettext (String)
+ #define gettext_noop(String) String
+ #define N_(String) gettext_noop (String)
++#else
++#define gettext_noop(String) String
++#define _(String) gettext_noop (String)
++#define gettext(String) gettext_noop (String)
++#define N_(String) gettext_noop (String)
++#define textdomain(String)
++#endif
+
+ #define LINE_LEN 10
+
+--- cpufrequtils-006/utils/set.c
++++ cpufrequtils-006/utils/set.c
+@@ -12,16 +12,24 @@
+ #include <limits.h>
+ #include <string.h>
+ #include <ctype.h>
+-#include <libintl.h>
+ #include <locale.h>
+
+ #include <getopt.h>
+
+ #include "cpufreq.h"
+
++#ifdef NLS
++#include <libintl.h>
+ #define _(String) gettext(String)
+ #define gettext_noop(String) String
+ #define N_(String) gettext_noop(String)
++#else
++#define gettext_noop(String) String
++#define _(String) gettext_noop (String)
++#define gettext(String) gettext_noop (String)
++#define N_(String) gettext_noop (String)
++#define textdomain(String)
++#endif
+
+ #define NORM_FREQ_LEN 32
+