summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2011-12-25 22:45:59 +0000
committerRobin H. Johnson <robbat2@gentoo.org>2011-12-25 22:45:59 +0000
commitad18ed814da3623ed648079adee609462d871c2a (patch)
treef479e7299b8bd18f8ada417140774464ae66cfd1 /sys-power/iasl
parentdev-util/weka: version bump (diff)
downloadgentoo-2-ad18ed814da3623ed648079adee609462d871c2a.tar.gz
gentoo-2-ad18ed814da3623ed648079adee609462d871c2a.tar.bz2
gentoo-2-ad18ed814da3623ed648079adee609462d871c2a.zip
Bug #288144: check both features and use for test, so we get the correct result with FEATURES=-test USE=test.
(Portage version: 2.2.0_alpha81/cvs/Linux x86_64)
Diffstat (limited to 'sys-power/iasl')
-rw-r--r--sys-power/iasl/ChangeLog9
-rw-r--r--sys-power/iasl/iasl-20080514.ebuild7
-rw-r--r--sys-power/iasl/iasl-20080701.ebuild7
-rw-r--r--sys-power/iasl/iasl-20090123.ebuild7
-rw-r--r--sys-power/iasl/iasl-20090521.ebuild7
-rw-r--r--sys-power/iasl/iasl-20090903.ebuild7
-rw-r--r--sys-power/iasl/iasl-20091013.ebuild7
-rw-r--r--sys-power/iasl/iasl-20100428.ebuild7
-rw-r--r--sys-power/iasl/iasl-20100528.ebuild7
-rw-r--r--sys-power/iasl/iasl-20110922.ebuild7
-rw-r--r--sys-power/iasl/iasl-20111123.ebuild7
11 files changed, 38 insertions, 41 deletions
diff --git a/sys-power/iasl/ChangeLog b/sys-power/iasl/ChangeLog
index 7ec87acec6cf..e0df1711344b 100644
--- a/sys-power/iasl/ChangeLog
+++ b/sys-power/iasl/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for sys-power/iasl
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-power/iasl/ChangeLog,v 1.36 2011/12/11 19:05:42 robbat2 Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-power/iasl/ChangeLog,v 1.37 2011/12/25 22:45:59 robbat2 Exp $
+
+ 25 Dec 2011; Robin H. Johnson <robbat2@gentoo.org> iasl-20080514.ebuild,
+ iasl-20080701.ebuild, iasl-20090123.ebuild, iasl-20090521.ebuild,
+ iasl-20090903.ebuild, iasl-20091013.ebuild, iasl-20100428.ebuild,
+ iasl-20100528.ebuild, iasl-20110922.ebuild, iasl-20111123.ebuild:
+ Bug #288144: check both features and use for test, so we get the correct
+ result with FEATURES=-test USE=test.
*iasl-20111123 (11 Dec 2011)
diff --git a/sys-power/iasl/iasl-20080514.ebuild b/sys-power/iasl/iasl-20080514.ebuild
index 837799d6c07d..72fe83972abc 100644
--- a/sys-power/iasl/iasl-20080514.ebuild
+++ b/sys-power/iasl/iasl-20080514.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-power/iasl/iasl-20080514.ebuild,v 1.5 2011/09/30 16:56:57 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-power/iasl/iasl-20080514.ebuild,v 1.6 2011/12/25 22:45:59 robbat2 Exp $
inherit toolchain-funcs flag-o-matic eutils
@@ -24,8 +24,7 @@ RDEPEND=""
S=${WORKDIR}/${MY_P}
pkg_setup() {
- if use test
- then
+ if use test && has test ${FEATURES}; then
ewarn 'You have selected USE="test". This will install the test results'
ewarn "into /usr/share/${PF}/, compressed as a tarball."
ewarn 'The tests themselves will only rarely die, but the test results'
@@ -73,7 +72,7 @@ src_install() {
dobin "${T}"/${bin}
done
dodoc README changes.txt
- if use test ; then
+ if use test && has test ${FEATURES}; then
tb="${T}"/testresults.tar.bz2
export ASLTSDIR="$(<"${T}"/asltdir)"
ebegin "Creating Test Tarball"
diff --git a/sys-power/iasl/iasl-20080701.ebuild b/sys-power/iasl/iasl-20080701.ebuild
index 3c9e71adaab5..25d0a0423734 100644
--- a/sys-power/iasl/iasl-20080701.ebuild
+++ b/sys-power/iasl/iasl-20080701.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-power/iasl/iasl-20080701.ebuild,v 1.4 2011/09/30 16:56:57 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-power/iasl/iasl-20080701.ebuild,v 1.5 2011/12/25 22:45:59 robbat2 Exp $
inherit toolchain-funcs flag-o-matic eutils
@@ -24,8 +24,7 @@ RDEPEND=""
S=${WORKDIR}/${MY_P}
pkg_setup() {
- if use test
- then
+ if use test && has test ${FEATURES}; then
ewarn 'You have selected USE="test". This will install the test results'
ewarn "into /usr/share/${PF}/, compressed as a tarball."
ewarn 'The tests themselves will only rarely die, but the test results'
@@ -79,7 +78,7 @@ src_install() {
dobin "${T}"/${bin}
done
dodoc README changes.txt
- if use test ; then
+ if use test && has test ${FEATURES}; then
tb="${T}"/testresults.tar.bz2
export ASLTSDIR="$(<"${T}"/asltdir)"
ebegin "Creating Test Tarball"
diff --git a/sys-power/iasl/iasl-20090123.ebuild b/sys-power/iasl/iasl-20090123.ebuild
index 55dea828a50c..99d0595ac317 100644
--- a/sys-power/iasl/iasl-20090123.ebuild
+++ b/sys-power/iasl/iasl-20090123.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-power/iasl/iasl-20090123.ebuild,v 1.7 2011/09/30 16:56:57 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-power/iasl/iasl-20090123.ebuild,v 1.8 2011/12/25 22:45:59 robbat2 Exp $
inherit toolchain-funcs flag-o-matic eutils
@@ -24,8 +24,7 @@ RDEPEND=""
S=${WORKDIR}/${MY_P}
pkg_setup() {
- if use test
- then
+ if use test && has test ${FEATURES}; then
ewarn 'You have selected USE="test". This will install the test results'
ewarn "into /usr/share/${PF}/, compressed as a tarball."
ewarn 'The tests themselves will only rarely die, but the test results'
@@ -82,7 +81,7 @@ src_install() {
dobin "${T}"/${bin}
done
dodoc README changes.txt
- if use test ; then
+ if use test && has test ${FEATURES}; then
tb="${T}"/testresults.tar.bz2
export ASLTSDIR="$(<"${T}"/asltdir)"
ebegin "Creating Test Tarball"
diff --git a/sys-power/iasl/iasl-20090521.ebuild b/sys-power/iasl/iasl-20090521.ebuild
index a09c4b7faeed..66276e9701a6 100644
--- a/sys-power/iasl/iasl-20090521.ebuild
+++ b/sys-power/iasl/iasl-20090521.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-power/iasl/iasl-20090521.ebuild,v 1.3 2011/09/30 16:56:57 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-power/iasl/iasl-20090521.ebuild,v 1.4 2011/12/25 22:45:59 robbat2 Exp $
inherit toolchain-funcs flag-o-matic eutils
@@ -24,8 +24,7 @@ RDEPEND=""
S=${WORKDIR}/${MY_P}
pkg_setup() {
- if use test
- then
+ if use test && has test ${FEATURES}; then
ewarn 'You have selected USE="test". This will install the test results'
ewarn "into /usr/share/${PF}/, compressed as a tarball."
ewarn 'The tests themselves will only rarely die, but the test results'
@@ -82,7 +81,7 @@ src_install() {
dobin "${T}"/${bin}
done
dodoc README changes.txt
- if use test ; then
+ if use test && has test ${FEATURES}; then
tb="${T}"/testresults.tar.bz2
export ASLTSDIR="$(<"${T}"/asltdir)"
ebegin "Creating Test Tarball"
diff --git a/sys-power/iasl/iasl-20090903.ebuild b/sys-power/iasl/iasl-20090903.ebuild
index bd0d5fe4a7a3..2c199247c557 100644
--- a/sys-power/iasl/iasl-20090903.ebuild
+++ b/sys-power/iasl/iasl-20090903.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-power/iasl/iasl-20090903.ebuild,v 1.2 2011/09/30 16:56:57 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-power/iasl/iasl-20090903.ebuild,v 1.3 2011/12/25 22:45:59 robbat2 Exp $
inherit toolchain-funcs flag-o-matic eutils
@@ -24,8 +24,7 @@ RDEPEND=""
S=${WORKDIR}/${MY_P}
pkg_setup() {
- if use test
- then
+ if use test && has test ${FEATURES}; then
ewarn 'You have selected USE="test". This will install the test results'
ewarn "into /usr/share/${PF}/, compressed as a tarball."
ewarn 'The tests themselves will only rarely die, but the test results'
@@ -83,7 +82,7 @@ src_install() {
dobin "${T}"/${bin}
done
dodoc README changes.txt
- if use test ; then
+ if use test && has test ${FEATURES}; then
tb="${T}"/testresults.tar.bz2
export ASLTSDIR="$(<"${T}"/asltdir)"
ebegin "Creating Test Tarball"
diff --git a/sys-power/iasl/iasl-20091013.ebuild b/sys-power/iasl/iasl-20091013.ebuild
index a2282425dc22..3e879edde706 100644
--- a/sys-power/iasl/iasl-20091013.ebuild
+++ b/sys-power/iasl/iasl-20091013.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-power/iasl/iasl-20091013.ebuild,v 1.2 2011/09/30 16:56:57 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-power/iasl/iasl-20091013.ebuild,v 1.3 2011/12/25 22:45:59 robbat2 Exp $
inherit toolchain-funcs flag-o-matic eutils
@@ -24,8 +24,7 @@ RDEPEND=""
S=${WORKDIR}/${MY_P}
pkg_setup() {
- if use test
- then
+ if use test && has test ${FEATURES}; then
ewarn 'You have selected USE="test". This will install the test results'
ewarn "into /usr/share/${PF}/, compressed as a tarball."
ewarn 'The tests themselves will only rarely die, but the test results'
@@ -83,7 +82,7 @@ src_install() {
dobin "${T}"/${bin}
done
dodoc README changes.txt
- if use test ; then
+ if use test && has test ${FEATURES}; then
tb="${T}"/testresults.tar.bz2
export ASLTSDIR="$(<"${T}"/asltdir)"
ebegin "Creating Test Tarball"
diff --git a/sys-power/iasl/iasl-20100428.ebuild b/sys-power/iasl/iasl-20100428.ebuild
index 26ad691aab5a..3aa1294e926f 100644
--- a/sys-power/iasl/iasl-20100428.ebuild
+++ b/sys-power/iasl/iasl-20100428.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-power/iasl/iasl-20100428.ebuild,v 1.2 2011/09/30 16:56:57 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-power/iasl/iasl-20100428.ebuild,v 1.3 2011/12/25 22:45:59 robbat2 Exp $
inherit toolchain-funcs flag-o-matic eutils
@@ -24,8 +24,7 @@ RDEPEND=""
S=${WORKDIR}/${MY_P}
pkg_setup() {
- if use test
- then
+ if use test && has test ${FEATURES}; then
ewarn 'You have selected USE="test". This will install the test results'
ewarn "into /usr/share/${PF}/, compressed as a tarball."
ewarn 'The tests themselves will only rarely die, but the test results'
@@ -83,7 +82,7 @@ src_install() {
dobin "${T}"/${bin}
done
dodoc README changes.txt
- if use test ; then
+ if use test && has test ${FEATURES}; then
tb="${T}"/testresults.tar.bz2
export ASLTSDIR="$(<"${T}"/asltdir)"
ebegin "Creating Test Tarball"
diff --git a/sys-power/iasl/iasl-20100528.ebuild b/sys-power/iasl/iasl-20100528.ebuild
index d319afd0a27f..0c9f6fb54577 100644
--- a/sys-power/iasl/iasl-20100528.ebuild
+++ b/sys-power/iasl/iasl-20100528.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-power/iasl/iasl-20100528.ebuild,v 1.2 2011/09/30 16:56:57 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-power/iasl/iasl-20100528.ebuild,v 1.3 2011/12/25 22:45:59 robbat2 Exp $
inherit toolchain-funcs flag-o-matic eutils
@@ -24,8 +24,7 @@ RDEPEND=""
S=${WORKDIR}/${MY_P}
pkg_setup() {
- if use test
- then
+ if use test && has test ${FEATURES}; then
ewarn 'You have selected USE="test". This will install the test results'
ewarn "into /usr/share/${PF}/, compressed as a tarball."
ewarn 'The tests themselves will only rarely die, but the test results'
@@ -83,7 +82,7 @@ src_install() {
dobin "${T}"/${bin}
done
dodoc README changes.txt
- if use test ; then
+ if use test && has test ${FEATURES}; then
tb="${T}"/testresults.tar.bz2
export ASLTSDIR="$(<"${T}"/asltdir)"
ebegin "Creating Test Tarball"
diff --git a/sys-power/iasl/iasl-20110922.ebuild b/sys-power/iasl/iasl-20110922.ebuild
index d7bc7beae9c5..751acb8cd8ed 100644
--- a/sys-power/iasl/iasl-20110922.ebuild
+++ b/sys-power/iasl/iasl-20110922.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-power/iasl/iasl-20110922.ebuild,v 1.2 2011/11/07 11:30:29 robbat2 Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-power/iasl/iasl-20110922.ebuild,v 1.3 2011/12/25 22:45:59 robbat2 Exp $
EAPI=4
@@ -26,8 +26,7 @@ RDEPEND=""
S=${WORKDIR}/${MY_P}
pkg_setup() {
- if use test
- then
+ if use test && has test ${FEATURES}; then
ewarn 'You have selected USE="test". This will install the test results'
ewarn "into /usr/share/${PF}/, compressed as a tarball."
ewarn 'The tests themselves will only rarely die, but the test results'
@@ -91,7 +90,7 @@ src_install() {
dobin "${T}"/${bin}
done
dodoc README changes.txt
- if use test ; then
+ if use test && has test ${FEATURES}; then
tb="${T}"/testresults.tar.bz2
export ASLTSDIR="$(<"${T}"/asltdir)"
ebegin "Creating Test Tarball"
diff --git a/sys-power/iasl/iasl-20111123.ebuild b/sys-power/iasl/iasl-20111123.ebuild
index 3f50341da805..44768d3febb8 100644
--- a/sys-power/iasl/iasl-20111123.ebuild
+++ b/sys-power/iasl/iasl-20111123.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-power/iasl/iasl-20111123.ebuild,v 1.1 2011/12/11 19:05:42 robbat2 Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-power/iasl/iasl-20111123.ebuild,v 1.2 2011/12/25 22:45:59 robbat2 Exp $
EAPI=4
@@ -26,8 +26,7 @@ RDEPEND=""
S=${WORKDIR}/${MY_P}
pkg_setup() {
- if use test
- then
+ if use test && has test ${FEATURES}; then
ewarn 'You have selected USE="test". This will install the test results'
ewarn "into /usr/share/${PF}/, compressed as a tarball."
ewarn 'The tests themselves will only rarely die, but the test results'
@@ -91,7 +90,7 @@ src_install() {
dobin "${T}"/${bin}
done
dodoc README changes.txt
- if use test ; then
+ if use test && has test ${FEATURES}; then
tb="${T}"/testresults.tar.bz2
export ASLTSDIR="$(<"${T}"/asltdir)"
ebegin "Creating Test Tarball"