summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2008-06-07 02:55:49 +0000
committerRobin H. Johnson <robbat2@gentoo.org>2008-06-07 02:55:49 +0000
commitf4cb5512ad1326ae7b2492c69ac912e0460b19b4 (patch)
tree5c9474ed2b10ce38c4cdfa080bf7e1f814139c61 /sys-power/iasl
parentResolve bug #198352 where the binaries were built before the new lib sometime... (diff)
downloadgentoo-2-f4cb5512ad1326ae7b2492c69ac912e0460b19b4.tar.gz
gentoo-2-f4cb5512ad1326ae7b2492c69ac912e0460b19b4.tar.bz2
gentoo-2-f4cb5512ad1326ae7b2492c69ac912e0460b19b4.zip
Per bug #224505, we need to check FEATURES in src_install, as ASLTDIR will not be defined unless USE=test AND FEATURES=test.
(Portage version: 2.1.5.4)
Diffstat (limited to 'sys-power/iasl')
-rw-r--r--sys-power/iasl/ChangeLog6
-rw-r--r--sys-power/iasl/iasl-20080514.ebuild7
2 files changed, 9 insertions, 4 deletions
diff --git a/sys-power/iasl/ChangeLog b/sys-power/iasl/ChangeLog
index b831f9351390..5827f64152d9 100644
--- a/sys-power/iasl/ChangeLog
+++ b/sys-power/iasl/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for sys-power/iasl
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-power/iasl/ChangeLog,v 1.18 2008/05/26 21:51:01 robbat2 Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-power/iasl/ChangeLog,v 1.19 2008/06/07 02:55:49 robbat2 Exp $
+
+ 07 Jun 2008; Robin H. Johnson <robbat2@gentoo.org> iasl-20080514.ebuild:
+ Per bug #224505, we need to check FEATURES in src_install, as ASLTDIR will
+ not be defined unless USE=test AND FEATURES=test.
26 May 2008; Robin H. Johnson <robbat2@gentoo.org> iasl-20060912.ebuild:
Overquoted ${S} causes epatch failure, undo it per bug #223619.
diff --git a/sys-power/iasl/iasl-20080514.ebuild b/sys-power/iasl/iasl-20080514.ebuild
index 5e94ab51bc8c..9ac0969d9380 100644
--- a/sys-power/iasl/iasl-20080514.ebuild
+++ b/sys-power/iasl/iasl-20080514.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-power/iasl/iasl-20080514.ebuild,v 1.2 2008/05/22 21:21:59 robbat2 Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-power/iasl/iasl-20080514.ebuild,v 1.3 2008/06/07 02:55:49 robbat2 Exp $
inherit toolchain-funcs flag-o-matic eutils
@@ -74,8 +74,8 @@ src_install() {
dobin "${T}"/${bin}
done
dodoc README changes.txt
- if use test
- then
+ if hasq test $FEATURES ; then
+ export ASLTSDIR="$(<"${T}"/asltdir)"
cd "${ASLTSDIR}"/tmp/RESULTS || die "cd ${ASLTSDIR}/tmp/RESULTS failed"
ebegin "Creating Test Tarball"
tar -cjf testresults.tar.bz2 * || die "tar failed"
@@ -92,6 +92,7 @@ aslts_test() {
acpiexec="${T}"/acpiexec \
ASLTSDIR="${WORKDIR}/${MY_TESTS_P}"/tests/aslts
export PATH="${PATH}:${ASLTSDIR}/bin"
+ echo "$ASLTSDIR" >"${T}"/asltdir
cd "${ASLTSDIR}"
edos2unix $(find . -type 'f') || die "edos2unix failed in aslts"
make install || die "make install aslts test failed"