summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRick Farina <zerochaos@gentoo.org>2014-05-17 02:23:35 +0000
committerRick Farina <zerochaos@gentoo.org>2014-05-17 02:23:35 +0000
commit8db8931746ab141d187c7dc4fb0d6c03fbe9c5cf (patch)
tree23d1c3a5831df4dfe8dc4caf6164c704adcd90fe /sys-power/powertop
parentBeta channel bump. (diff)
downloadgentoo-2-8db8931746ab141d187c7dc4fb0d6c03fbe9c5cf.tar.gz
gentoo-2-8db8931746ab141d187c7dc4fb0d6c03fbe9c5cf.tar.bz2
gentoo-2-8db8931746ab141d187c7dc4fb0d6c03fbe9c5cf.zip
version bump. tunables went nuts on me once and messed up the display but things are roughly working
(Portage version: 2.2.8-r1/cvs/Linux x86_64, signed Manifest commit with key DD11F94A)
Diffstat (limited to 'sys-power/powertop')
-rw-r--r--sys-power/powertop/ChangeLog9
-rw-r--r--sys-power/powertop/powertop-2.6.ebuild100
-rw-r--r--sys-power/powertop/powertop-9999.ebuild11
3 files changed, 111 insertions, 9 deletions
diff --git a/sys-power/powertop/ChangeLog b/sys-power/powertop/ChangeLog
index 207627defcff..11a18f72ef7b 100644
--- a/sys-power/powertop/ChangeLog
+++ b/sys-power/powertop/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for sys-power/powertop
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-power/powertop/ChangeLog,v 1.100 2014/03/12 10:18:06 ago Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-power/powertop/ChangeLog,v 1.101 2014/05/17 02:23:35 zerochaos Exp $
+
+*powertop-2.6 (17 May 2014)
+
+ 17 May 2014; Rick Farina <zerochaos@gentoo.org> +powertop-2.6.ebuild,
+ powertop-9999.ebuild:
+ version bump. tunables went nuts on me once and messed up the display but
+ things are roughly working
12 Mar 2014; Agostino Sarubbo <ago@gentoo.org> powertop-2.5.ebuild:
Stable for sparc, wrt bug #500036
diff --git a/sys-power/powertop/powertop-2.6.ebuild b/sys-power/powertop/powertop-2.6.ebuild
new file mode 100644
index 000000000000..08e82cfbd41c
--- /dev/null
+++ b/sys-power/powertop/powertop-2.6.ebuild
@@ -0,0 +1,100 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-power/powertop/powertop-2.6.ebuild,v 1.1 2014/05/17 02:23:35 zerochaos Exp $
+
+EAPI="5"
+
+inherit eutils linux-info autotools
+if [[ ${PV} == "9999" ]] ; then
+ EGIT_REPO_URI="git://github.com/fenrus75/powertop.git"
+ inherit git-2 autotools
+ SRC_URI=""
+else
+ SRC_URI="https://01.org/sites/default/files/downloads/${PN}/${P}.tar.gz"
+ KEYWORDS="~amd64 ~arm ~ppc ~sparc ~x86 ~amd64-linux ~x86-linux"
+fi
+
+DESCRIPTION="tool that helps you find what software is using the most power"
+HOMEPAGE="https://01.org/powertop/"
+
+LICENSE="GPL-2"
+SLOT="0"
+IUSE="unicode X"
+
+COMMON_DEPEND="
+ dev-libs/libnl:3
+ sys-apps/pciutils
+ sys-libs/ncurses[unicode?]
+"
+
+DEPEND="${COMMON_DEPEND}
+ virtual/pkgconfig
+ sys-devel/gettext
+"
+RDEPEND="
+ ${COMMON_DEPEND}
+ X? ( x11-apps/xset )
+ virtual/libintl
+"
+
+DOCS=( TODO README )
+
+S="${WORKDIR}/${PN}"
+
+pkg_setup() {
+ CONFIG_CHECK="
+ ~X86_MSR
+ ~DEBUG_FS
+ ~PERF_EVENTS
+ ~TRACEPOINTS
+ ~NO_HZ
+ ~HIGH_RES_TIMERS
+ ~HPET_TIMER
+ ~CPU_FREQ_STAT
+ ~CPU_FREQ_GOV_ONDEMAND
+ ~PM_RUNTIME
+ ~FTRACE
+ ~BLK_DEV_IO_TRACE
+ ~TIMER_STATS
+ ~TRACING
+ "
+ ERROR_KERNEL_X86_MSR="X86_MSR is not enabled in the kernel, you almost certainly need it"
+ ERROR_KERNEL_DEBUG_FS="DEBUG_FS is not enabled in the kernel, you almost certainly need it"
+ ERROR_KERNEL_PERF_EVENTS="PERF_EVENTS should be enabled in the kernel for full powertop function"
+ ERROR_KERNEL_TRACEPOINTS="TRACEPOINTS should be enabled in the kernel for full powertop function"
+ ERROR_KERNEL_NO_HZ="NO_HZ should be enabled in the kernel for full powertop function"
+ ERROR_KERNEL_HIGH_RES_TIMERS="HIGH_RES_TIMERS should be enabled in the kernel for full powertop function"
+ ERROR_KERNEL_HPET_TIMER="HPET_TIMER should be enabled in the kernel for full powertop function"
+ ERROR_KERNEL_CPU_FREQ_STAT="CPU_FREQ_STAT should be enabled in the kernel for full powertop function"
+ ERROR_KERNEL_CPU_FREQ_GOV_ONDEMAND="CPU_FREQ_GOV_ONDEMAND should be enabled in the kernel for full powertop function"
+ ERROR_KERNEL_PM_RUNTIME="PM_RUNTIME should be enabled in the kernel for full powertop function"
+ ERROR_KERNEL_FTRACE="FTRACE needs to be turned on to enable BLK_DEV_IO_TRACE"
+ ERROR_KERNEL_BLK_DEV_IO_TRACE="BLK_DEV_IO_TRACE needs to be turned on to enable TIMER_STATS, TRACING and EVENT_POWER_TRACING_DEPRECATED"
+ ERROR_KERNEL_TIMER_STATS="TIMER_STATS should be enabled in the kernel for full powertop function"
+ ERROR_KERNEL_TRACING="TRACING should be enabled in the kernel for full powertop function"
+ linux-info_pkg_setup
+ if linux_config_exists; then
+ if kernel_is -lt 3 7 0; then
+ if linux_chkconfig_present SND_HDA_INTEL; then
+ CONFIG_CHECK="~SND_HDA_POWER_SAVE"
+ ERROR_KERNEL_SND_HDA_POWER_SAVE="SND_HDA_POWER_SAVE should be enabled in the kernel for full powertop function"
+ check_extra_config
+ fi
+ fi
+ if kernel_is -lt 3 9 0; then
+ CONFIG_CHECK="~EVENT_POWER_TRACING_DEPRECATED"
+ ERROR_KERNEL_EVENT_POWER_TRACING_DEPRECATED="EVENT_POWER_TRACING_DEPRECATED should be enabled in the kernel for full powertop function"
+ check_extra_config
+ fi
+ fi
+}
+
+src_prepare() {
+ epatch "${FILESDIR}"/powertop-2.4-tinfo.patch
+ eautoreconf
+}
+
+src_configure() {
+ export ac_cv_search_delwin=$(usex unicode -lncursesw -lncurses)
+ default
+}
diff --git a/sys-power/powertop/powertop-9999.ebuild b/sys-power/powertop/powertop-9999.ebuild
index da01792c6ac9..fc1b32d30608 100644
--- a/sys-power/powertop/powertop-9999.ebuild
+++ b/sys-power/powertop/powertop-9999.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2013 Gentoo Foundation
+# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-power/powertop/powertop-9999.ebuild,v 1.26 2013/10/03 19:51:51 zerochaos Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-power/powertop/powertop-9999.ebuild,v 1.27 2014/05/17 02:23:35 zerochaos Exp $
EAPI="5"
@@ -10,7 +10,7 @@ if [[ ${PV} == "9999" ]] ; then
inherit git-2 autotools
SRC_URI=""
else
- SRC_URI="https://01.org/powertop/sites/default/files/downloads/${P}.tar.gz"
+ SRC_URI="https://01.org/sites/default/files/downloads/${PN}/${P}.tar.gz"
KEYWORDS="~amd64 ~arm ~ppc ~sparc ~x86 ~amd64-linux ~x86-linux"
fi
@@ -96,8 +96,3 @@ src_configure() {
export ac_cv_search_delwin=$(usex unicode -lncursesw -lncurses)
default
}
-
-src_install() {
- default
- keepdir /var/cache/powertop
-}