summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Weber <xmw@gentoo.org>2010-10-03 20:29:33 +0000
committerMichael Weber <xmw@gentoo.org>2010-10-03 20:29:33 +0000
commit6630d0e052d3ae71e6b835c7e83141b17bb47e4b (patch)
tree1d2f4693a34e1985de96970c12838bcac32869fc /sys-power
parentRemove old ebuilds (diff)
downloadgentoo-2-6630d0e052d3ae71e6b835c7e83141b17bb47e4b.tar.gz
gentoo-2-6630d0e052d3ae71e6b835c7e83141b17bb47e4b.tar.bz2
gentoo-2-6630d0e052d3ae71e6b835c7e83141b17bb47e4b.zip
Version bump
(Portage version: 2.1.8.3/cvs/Linux x86_64)
Diffstat (limited to 'sys-power')
-rw-r--r--sys-power/suspend/ChangeLog7
-rw-r--r--sys-power/suspend/metadata.xml4
-rw-r--r--sys-power/suspend/suspend-0.9_pre0.ebuild58
3 files changed, 66 insertions, 3 deletions
diff --git a/sys-power/suspend/ChangeLog b/sys-power/suspend/ChangeLog
index 61269712f94b..cad155f783a1 100644
--- a/sys-power/suspend/ChangeLog
+++ b/sys-power/suspend/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sys-power/suspend
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-power/suspend/ChangeLog,v 1.14 2010/06/24 21:12:13 pacho Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-power/suspend/ChangeLog,v 1.15 2010/10/03 20:29:33 xmw Exp $
+
+*suspend-0.9_pre0 (03 Oct 2010)
+
+ 03 Oct 2010; Michael Weber <xmw@gentoo.org> +suspend-0.9_pre0.ebuild:
+ Version bump to git tag, thanks to Kevin Pyle on bug 339521
24 Jun 2010; Pacho Ramos <pacho@gentoo.org> suspend-0.8-r1.ebuild:
stable amd64, bug 322491
diff --git a/sys-power/suspend/metadata.xml b/sys-power/suspend/metadata.xml
index bb8397f01f5a..025be98596a4 100644
--- a/sys-power/suspend/metadata.xml
+++ b/sys-power/suspend/metadata.xml
@@ -3,8 +3,8 @@
<pkgmetadata>
<herd>no-herd</herd>
<maintainer>
- <email>maintainer-needed@gentoo.org</email>
- <name>Default assignee for orphaned packages</name>
+ <email>xmw@gentoo.org</email>
+ <name>Michael Weber</name>
</maintainer>
<use>
<flag name='fbsplash'>Add support for framebuffer splash</flag>
diff --git a/sys-power/suspend/suspend-0.9_pre0.ebuild b/sys-power/suspend/suspend-0.9_pre0.ebuild
new file mode 100644
index 000000000000..fe16bae6ced9
--- /dev/null
+++ b/sys-power/suspend/suspend-0.9_pre0.ebuild
@@ -0,0 +1,58 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-power/suspend/suspend-0.9_pre0.ebuild,v 1.1 2010/10/03 20:29:33 xmw Exp $
+
+EAPI=2
+
+inherit autotools eutils
+
+# Name based on the git tag from which the tarball was created
+MY_GIT_SHORT_COMMIT=9a5329f
+MY_P=suspend-utils-${MY_GIT_SHORT_COMMIT}
+DESCRIPTION="Userspace Software Suspend and S2Ram"
+HOMEPAGE="http://suspend.sourceforge.net/"
+SRC_URI="http://xmw.de/mirror/${PN}/${MY_P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="fbsplash crypt"
+
+X86_RDEPEND="dev-libs/libx86"
+X86_DEPEND="
+ ${X86_RDEPEND}
+ >=sys-apps/pciutils-2.2.4"
+RDEPEND=">=dev-libs/lzo-2
+ fbsplash? ( >=media-gfx/splashutils-1.5.2 )
+ crypt? ( dev-libs/libgcrypt )
+ x86? ( ${X86_RDEPEND} )
+ amd64? ( ${X86_RDEPEND} )"
+DEPEND="${RDEPEND}
+ x86? ( ${X86_DEPEND} )
+ amd64? ( ${X86_DEPEND} )
+ dev-util/pkgconfig"
+
+S="${WORKDIR}/${MY_P}"
+
+src_prepare() {
+ sed -i -e "/AC_INIT/s/0\.8/0.9-${MY_GIT_SHORT_COMMIT}/" configure.ac || die
+ eautoreconf
+}
+
+src_configure() {
+ econf \
+ --docdir="/usr/share/doc/${PF}" \
+ --enable-compress \
+ $(use_enable crypt encrypt) \
+ $(use_enable fbsplash) \
+ || die
+}
+
+src_install() {
+ emake install DESTDIR="${D}" || die
+}
+
+pkg_postinst() {
+ elog "In order to make this package work with genkernel see:"
+ elog "http://bugs.gentoo.org/show_bug.cgi?id=156445"
+}