summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2011-11-07 11:30:29 +0000
committerRobin H. Johnson <robbat2@gentoo.org>2011-11-07 11:30:29 +0000
commit6e6caa732c6ee6efd12cf0755a07aed08b2a6752 (patch)
tree9c313efa65cd334deda0523afc6f482d8a7cbdc2 /sys-power
parentVersion bump, as requested by Moyaze Shivji of the LINX engineering department. (diff)
downloadgentoo-2-6e6caa732c6ee6efd12cf0755a07aed08b2a6752.tar.gz
gentoo-2-6e6caa732c6ee6efd12cf0755a07aed08b2a6752.tar.bz2
gentoo-2-6e6caa732c6ee6efd12cf0755a07aed08b2a6752.zip
Bug #389799: more parallel make problems.
(Portage version: 2.2.0_alpha72/cvs/Linux x86_64)
Diffstat (limited to 'sys-power')
-rw-r--r--sys-power/iasl/ChangeLog6
-rw-r--r--sys-power/iasl/files/iasl-20110922-parallelmake-003.patch53
-rw-r--r--sys-power/iasl/iasl-20110922.ebuild3
3 files changed, 60 insertions, 2 deletions
diff --git a/sys-power/iasl/ChangeLog b/sys-power/iasl/ChangeLog
index 2d374d49adef..ba3f8d2bbd91 100644
--- a/sys-power/iasl/ChangeLog
+++ b/sys-power/iasl/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for sys-power/iasl
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-power/iasl/ChangeLog,v 1.34 2011/11/07 03:39:26 robbat2 Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-power/iasl/ChangeLog,v 1.35 2011/11/07 11:30:29 robbat2 Exp $
+
+ 07 Nov 2011; Robin H. Johnson <robbat2@gentoo.org> iasl-20110922.ebuild,
+ +files/iasl-20110922-parallelmake-003.patch:
+ Bug #389799: more parallel make problems.
*iasl-20110922 (07 Nov 2011)
diff --git a/sys-power/iasl/files/iasl-20110922-parallelmake-003.patch b/sys-power/iasl/files/iasl-20110922-parallelmake-003.patch
new file mode 100644
index 000000000000..6eb18a810c6d
--- /dev/null
+++ b/sys-power/iasl/files/iasl-20110922-parallelmake-003.patch
@@ -0,0 +1,53 @@
+Previous parallel make patches from user submission were not quite enough.
+
+Include this bit as well to fix up bison being invoked multiple times.
+
+X-Gentoo-Bug: 389799
+X-Gentoo-Bug-URL: https://bugs.gentoo.org/389799
+Signed-off-by: Robin H. Johnson <robbat2@gentoo.org>
+
+diff -Nuar acpica-unix-20110922.orig/compiler/Makefile acpica-unix-20110922/compiler/Makefile
+--- acpica-unix-20110922.orig/compiler/Makefile 2011-11-07 11:14:51.200026000 +0000
++++ acpica-unix-20110922/compiler/Makefile 2011-11-07 11:20:03.490637284 +0000
+@@ -274,14 +274,18 @@
+ aslcompilerlex.c : $(ASL_COMPILER)/aslcompiler.l
+ ${LEX} ${LFLAGS} -PAslCompiler -o$@ $?
+
+-aslcompiler.y.c aslcompiler.y.h aslcompiler.y.output : $(ASL_COMPILER)/aslcompiler.y
+- ${YACC} ${YFLAGS} -pAslCompiler -oaslcompiler.y.c $?
++aslcompiler.y.c : $(ASL_COMPILER)/aslcompiler.y
++ ${YACC} ${YFLAGS} -pAslCompiler -o aslcompiler.y.c $?
++aslcompiler.y.h : aslcompiler.y.c
++aslcompiler.y.output : aslcompiler.y.c
+
+ dtparserlex.c : $(ASL_COMPILER)/dtparser.l
+ ${LEX} ${LFLAGS} -PDtParser -o$@ $?
+
+-dtparser.y.c dtparser.y.h dtparser.y.output : $(ASL_COMPILER)/dtparser.y
+- ${YACC} ${YFLAGS} -pDtParser -odtparser.y.c $?
++dtparser.y.c : $(ASL_COMPILER)/dtparser.y
++ ${YACC} ${YFLAGS} -pDtParser -o dtparser.y.c $?
++dtparser.y.h : dtparser.y.c
++dtparser.y.output : dtparser.y.c
+
+ # Rename headers produced by bison/yacc
+
+@@ -294,14 +298,14 @@
+ aslcompilerlex.o : aslcompilerlex.c aslcompiler.y.h
+ $(CC) -c $(CFLAGS) -Wall -Werror -Wstrict-aliasing=0 -o$@ $<
+
+-aslcompiler.y.o : aslcompiler.y.c
+- $(CC) -c $(CFLAGS) -Wall -Werror -Wstrict-aliasing=0 -o$@ $?
++aslcompiler.y.o : aslcompiler.y.c aslcompiler.y.h
++ $(CC) -c $(CFLAGS) -Wall -Werror -Wstrict-aliasing=0 -o$@ $<
+
+ dtparserlex.o : dtparserlex.c dtparser.y.h
+ $(CC) -c $(CFLAGS) -Wall -Werror -Wstrict-aliasing=0 -o$@ $<
+
+-dtparser.y.o : dtparser.y.c
+- $(CC) -c $(CFLAGS) -Wall -Werror -Wstrict-aliasing=0 -o$@ $?
++dtparser.y.o : dtparser.y.c dtparser.y.h
++ $(CC) -c $(CFLAGS) -Wall -Werror -Wstrict-aliasing=0 -o$@ $<
+
+
+ %.o : %.c $(HEADERS) $(ACPICA_HEADERS)
diff --git a/sys-power/iasl/iasl-20110922.ebuild b/sys-power/iasl/iasl-20110922.ebuild
index 6c74eb91ba99..d7bc7beae9c5 100644
--- a/sys-power/iasl/iasl-20110922.ebuild
+++ b/sys-power/iasl/iasl-20110922.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-power/iasl/iasl-20110922.ebuild,v 1.1 2011/11/07 03:39:26 robbat2 Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-power/iasl/iasl-20110922.ebuild,v 1.2 2011/11/07 11:30:29 robbat2 Exp $
EAPI=4
@@ -41,6 +41,7 @@ src_prepare() {
epatch "${FILESDIR}/${PN}-20110922-locale.patch"
epatch "${FILESDIR}/${PN}-20110922-parallelmake-001.patch"
epatch "${FILESDIR}/${PN}-20110922-parallelmake-002.patch"
+ epatch "${FILESDIR}/${PN}-20110922-parallelmake-003.patch"
find "${S}" -type f -name 'Makefile*' -print0 | \
xargs -0 -I '{}' \