summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Weber <xmw@gentoo.org>2010-12-04 19:34:35 +0000
committerMichael Weber <xmw@gentoo.org>2010-12-04 19:34:35 +0000
commit77dd58c3c0c1c6634797871f14a67e21b49e9e4b (patch)
tree2225eaeb72ff7066e808d18b600bfe42a12218e8 /sys-power
parentAutomated update of use.local.desc (diff)
downloadgentoo-2-77dd58c3c0c1c6634797871f14a67e21b49e9e4b.tar.gz
gentoo-2-77dd58c3c0c1c6634797871f14a67e21b49e9e4b.tar.bz2
gentoo-2-77dd58c3c0c1c6634797871f14a67e21b49e9e4b.zip
version bump
(Portage version: 2.1.9.24/cvs/Linux x86_64)
Diffstat (limited to 'sys-power')
-rw-r--r--sys-power/phc-k8/ChangeLog8
-rw-r--r--sys-power/phc-k8/phc-k8-0.4.3.ebuild32
2 files changed, 39 insertions, 1 deletions
diff --git a/sys-power/phc-k8/ChangeLog b/sys-power/phc-k8/ChangeLog
index 4d40b7cd8fdc..878125c1cef2 100644
--- a/sys-power/phc-k8/ChangeLog
+++ b/sys-power/phc-k8/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sys-power/phc-k8
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-power/phc-k8/ChangeLog,v 1.2 2010/08/24 18:32:43 xmw Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-power/phc-k8/ChangeLog,v 1.3 2010/12/04 19:34:35 xmw Exp $
+
+*phc-k8-0.4.3 (04 Dec 2010)
+
+ 04 Dec 2010; Michael Weber <xmw@gentoo.org> +phc-k8-0.4.3.ebuild:
+ New upstream version, improved linux-mod description, src_prepare no longer
+ needed.
*phc-k8-0.4.2 (24 Aug 2010)
diff --git a/sys-power/phc-k8/phc-k8-0.4.3.ebuild b/sys-power/phc-k8/phc-k8-0.4.3.ebuild
new file mode 100644
index 000000000000..5c1eff8647ae
--- /dev/null
+++ b/sys-power/phc-k8/phc-k8-0.4.3.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-power/phc-k8/phc-k8-0.4.3.ebuild,v 1.1 2010/12/04 19:34:35 xmw Exp $
+
+EAPI=2
+
+inherit linux-info linux-mod
+
+DESCRIPTION="Processor Hardware Control for AMD K8 CPUs"
+HOMEPAGE="http://www.linux-phc.org/"
+SRC_URI="http://www.linux-phc.org/forum/download/file.php?id=107 -> ${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+S=${WORKDIR}/${PN}_v${PV}
+
+CONFIG_CHECK="~!X86_POWERNOW_K8"
+ERROR_X86_POWERNOW_K8="CONFIG_X86_POWERNOW_K8 should be configured to Module, to
+a) include needed symbol cpufreq_get_measured_perf and
+b) enable the replacemant of powernow-k8 with phc-k8."
+
+MODULE_NAMES="phc-k8(misc:)"
+BUILD_PARAMS="KERNELSRC=\"${KERNEL_DIR}\" -j1"
+BUILD_TARGETS="all"
+
+src_install() {
+ linux-mod_src_install
+ dodoc Changelog README || die
+}