summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <ssuominen@gentoo.org>2012-09-16 16:20:05 +0000
committerSamuli Suominen <ssuominen@gentoo.org>2012-09-16 16:20:05 +0000
commitf19a4093294fb8df37f86e1cc4a53f6d845919f2 (patch)
tree455f001607d993f422b9781c2d2bc4a338473e97 /sys-power
parentStable on amd64 arm ppc x86 (diff)
downloadgentoo-2-f19a4093294fb8df37f86e1cc4a53f6d845919f2.tar.gz
gentoo-2-f19a4093294fb8df37f86e1cc4a53f6d845919f2.tar.bz2
gentoo-2-f19a4093294fb8df37f86e1cc4a53f6d845919f2.zip
Version bump.
(Portage version: 2.2.0_alpha127/cvs/Linux x86_64)
Diffstat (limited to 'sys-power')
-rw-r--r--sys-power/acpid/ChangeLog7
-rw-r--r--sys-power/acpid/acpid-2.0.17.ebuild53
2 files changed, 59 insertions, 1 deletions
diff --git a/sys-power/acpid/ChangeLog b/sys-power/acpid/ChangeLog
index cac1e2a02194..945153d28d13 100644
--- a/sys-power/acpid/ChangeLog
+++ b/sys-power/acpid/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sys-power/acpid
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-power/acpid/ChangeLog,v 1.91 2012/07/01 19:06:55 ssuominen Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-power/acpid/ChangeLog,v 1.92 2012/09/16 16:20:05 ssuominen Exp $
+
+*acpid-2.0.17 (16 Sep 2012)
+
+ 16 Sep 2012; Samuli Suominen <ssuominen@gentoo.org> +acpid-2.0.17.ebuild:
+ Version bump.
01 Jul 2012; Samuli Suominen <ssuominen@gentoo.org>
-files/acpid-1.0.6-conf.d, -files/acpid-2.0.3.patch,
diff --git a/sys-power/acpid/acpid-2.0.17.ebuild b/sys-power/acpid/acpid-2.0.17.ebuild
new file mode 100644
index 000000000000..099d361b032f
--- /dev/null
+++ b/sys-power/acpid/acpid-2.0.17.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-power/acpid/acpid-2.0.17.ebuild,v 1.1 2012/09/16 16:20:05 ssuominen Exp $
+
+EAPI=4
+inherit systemd
+
+DESCRIPTION="Daemon for Advanced Configuration and Power Interface"
+HOMEPAGE="http://tedfelix.com/linux/acpid-netlink.html"
+SRC_URI="http://tedfelix.com/linux/${P}.tar.xz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ia64 -ppc ~x86"
+IUSE=""
+
+src_configure() {
+ econf --docdir=/usr/share/doc/${PF}
+}
+
+src_install() {
+ emake DESTDIR="${D}" install
+
+ newdoc kacpimon/README README.kacpimon
+ dodoc -r samples
+ rm -f "${D}"/usr/share/doc/${PF}/COPYING
+
+ exeinto /etc/acpi
+ newexe "${FILESDIR}"/${PN}-1.0.6-default.sh default.sh
+ insinto /etc/acpi/events
+ newins "${FILESDIR}"/${PN}-1.0.4-default default
+
+ newinitd "${FILESDIR}"/${PN}-2.0.16-init.d ${PN}
+ newconfd "${FILESDIR}"/${PN}-2.0.16-conf.d ${PN}
+
+ systemd_dounit "${FILESDIR}"/systemd/${PN}.{service,socket}
+}
+
+pkg_postinst() {
+ elog
+ elog "You may wish to read the Gentoo Linux Power Management Guide,"
+ elog "which can be found online at:"
+ elog "http://www.gentoo.org/doc/en/power-management-guide.xml"
+ elog
+
+ # files/systemd/acpid.socket -> ListenStream=/run/acpid.socket
+ mkdir -p "${ROOT}"/run
+
+ if ! grep -qs "^tmpfs.*/run " "${ROOT}"/proc/mounts ; then
+ echo
+ ewarn "You should reboot the system now to get /run mounted with tmpfs!"
+ fi
+}