summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIan Delaney <idella4@gentoo.org>2014-09-24 08:26:07 +0000
committerIan Delaney <idella4@gentoo.org>2014-09-24 08:26:07 +0000
commitcc2b726c0385278ab5a34933d951de6357da48ef (patch)
treec39ca9e6ec02dd71949029f777673845d8b0ee30 /sys-process/glances
parentversion bump, clean up old (diff)
downloadgentoo-2-cc2b726c0385278ab5a34933d951de6357da48ef.tar.gz
gentoo-2-cc2b726c0385278ab5a34933d951de6357da48ef.tar.bz2
gentoo-2-cc2b726c0385278ab5a34933d951de6357da48ef.zip
bump; drop py3.2, add IUSE chart for support of graph charts
(Portage version: 2.2.10/cvs/Linux x86_64, signed Manifest commit with key 0xB8072B0D)
Diffstat (limited to 'sys-process/glances')
-rw-r--r--sys-process/glances/ChangeLog8
-rw-r--r--sys-process/glances/glances-2.1.ebuild65
-rw-r--r--sys-process/glances/metadata.xml1
3 files changed, 73 insertions, 1 deletions
diff --git a/sys-process/glances/ChangeLog b/sys-process/glances/ChangeLog
index 45b4d87a3338..56c904f147c2 100644
--- a/sys-process/glances/ChangeLog
+++ b/sys-process/glances/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sys-process/glances
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-process/glances/ChangeLog,v 1.19 2014/07/07 14:49:56 idella4 Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-process/glances/ChangeLog,v 1.20 2014/09/24 08:26:07 idella4 Exp $
+
+*glances-2.1 (24 Sep 2014)
+
+ 24 Sep 2014; Ian Delaney <idella4@gentoo.org> +glances-2.1.ebuild,
+ metadata.xml:
+ bump; drop py3.2, add IUSE chart for support of graph charts
*glances-2.0.1 (07 Jul 2014)
diff --git a/sys-process/glances/glances-2.1.ebuild b/sys-process/glances/glances-2.1.ebuild
new file mode 100644
index 000000000000..ad20a77c6a75
--- /dev/null
+++ b/sys-process/glances/glances-2.1.ebuild
@@ -0,0 +1,65 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-process/glances/glances-2.1.ebuild,v 1.1 2014/09/24 08:26:07 idella4 Exp $
+
+EAPI=5
+
+PYTHON_COMPAT=( python{2_7,3_3,3_4} )
+PYTHON_REQ_USE="ncurses"
+
+inherit distutils-r1 linux-info
+
+MYPN=Glances
+MYP=${MYPN}-${PV}
+
+DESCRIPTION="CLI curses based monitoring tool"
+HOMEPAGE="https://github.com/nicolargo/glances"
+SRC_URI="mirror://pypi/${MYPN:0:1}/${MYPN}/${MYP}.tar.gz"
+
+LICENSE="LGPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~x86 ~amd64-linux ~x86-linux"
+IUSE="chart doc hddtemp snmp web"
+
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+# There is another optional extra batinfo, absent from portage
+RDEPEND="${DEPEND}
+ >=dev-python/psutil-2.0.0[${PYTHON_USEDEP}]
+ hddtemp? ( app-admin/hddtemp )
+ snmp? ( dev-python/pysnmp[${PYTHON_USEDEP}] )
+ web? ( dev-python/bottle[${PYTHON_USEDEP}] )
+ chart? ( dev-python/matplotlib[${PYTHON_USEDEP}] )"
+
+CONFIG_CHECK="~TASK_IO_ACCOUNTING ~TASK_DELAY_ACCT ~TASKSTATS"
+
+S="${WORKDIR}/${MYP}"
+
+pkg_setup() {
+ linux-info_pkg_setup
+}
+
+python_prepare_all() {
+ sed -e "s:share/doc/glances:share/doc/${PF}:g" \
+ -e "s/'COPYING',//" \
+ -e "s:/etc:${EPREFIX}/etc:" \
+ -i setup.py || die
+ distutils-r1_python_prepare_all
+}
+
+python_install_all() {
+ distutils-r1_python_install_all
+ if use doc; then
+ mkdir "${D}"usr/share/doc/${P}/html || die
+ mv "${D}"usr/share/doc/${P}/{glances-doc.html,images/} "${D}"usr/share/doc/${P}/html/ || die
+ else
+ rm -rf "${D}"usr/share/doc/${P}/{glances-doc.html,images/} || die
+ fi
+}
+
+pkg_postinst() {
+ if [[ -z ${REPLACING_VERSIONS} ]]; then
+ elog "${PN} can gain additional functionality with following packages:"
+ elog " dev-python/jinja - export statistics to HTML"
+ elog " app-admin/hddtemp - monitor hard drive temperatures"
+ fi
+}
diff --git a/sys-process/glances/metadata.xml b/sys-process/glances/metadata.xml
index 54d0505bd141..c97f410e18fb 100644
--- a/sys-process/glances/metadata.xml
+++ b/sys-process/glances/metadata.xml
@@ -9,6 +9,7 @@
<flag name='web'>Enables the web server mode</flag>
<flag name='hddtemp'>Enables hard drive temperature monitoring</flag>
<flag name='snmp'>Enables SNMP support</flag>
+ <flag name='chart'>Enables support of graph charts via matplotlib</flag>
</use>
<upstream>
<remote-id type="pypi">Glances</remote-id>