summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRoy Marples <uberlord@gentoo.org>2007-05-18 14:18:44 +0000
committerRoy Marples <uberlord@gentoo.org>2007-05-18 14:18:44 +0000
commit68bcb708949ddf7fca10fa7a3c0d58b941b4d78d (patch)
tree01d49da65dd0f9fd83c16844f9006adbc5948bdc /sys-process/lsof
parentia64 stable (diff)
downloadgentoo-2-68bcb708949ddf7fca10fa7a3c0d58b941b4d78d.tar.gz
gentoo-2-68bcb708949ddf7fca10fa7a3c0d58b941b4d78d.tar.bz2
gentoo-2-68bcb708949ddf7fca10fa7a3c0d58b941b4d78d.zip
Add patch to compile on FreeBSD and keyword ~x86-fbsd, #132085.
(Portage version: 2.1.2.7)
Diffstat (limited to 'sys-process/lsof')
-rw-r--r--sys-process/lsof/ChangeLog7
-rw-r--r--sys-process/lsof/files/lsof-4.78-answer-config.patch107
-rw-r--r--sys-process/lsof/files/lsof-4.78-freebsd.patch18
-rw-r--r--sys-process/lsof/lsof-4.78.ebuild11
4 files changed, 138 insertions, 5 deletions
diff --git a/sys-process/lsof/ChangeLog b/sys-process/lsof/ChangeLog
index 650282727537..15bd58e6d5f4 100644
--- a/sys-process/lsof/ChangeLog
+++ b/sys-process/lsof/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sys-process/lsof
# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-process/lsof/ChangeLog,v 1.30 2007/05/12 11:39:52 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-process/lsof/ChangeLog,v 1.31 2007/05/18 14:18:44 uberlord Exp $
+
+ 18 May 2007; Roy Marples <uberlord@gentoo.org>
+ +files/lsof-4.78-answer-config.patch, +files/lsof-4.78-freebsd.patch,
+ lsof-4.78.ebuild:
+ Add patch to compile on FreeBSD and keyword ~x86-fbsd, #132085.
*lsof-4.78 (12 May 2007)
diff --git a/sys-process/lsof/files/lsof-4.78-answer-config.patch b/sys-process/lsof/files/lsof-4.78-answer-config.patch
new file mode 100644
index 000000000000..8aa51c5a8c75
--- /dev/null
+++ b/sys-process/lsof/files/lsof-4.78-answer-config.patch
@@ -0,0 +1,107 @@
+diff -ur a/Configure b/Configure
+--- a/Configure 2007-05-18 15:02:13 +0100
++++ b/Configure 2007-05-18 15:03:04 +0100
+@@ -2294,7 +2294,7 @@
+
+ LSOF_VERS=`echo $LSOF_VSTR | sed 's/\./ /g' | awk '{printf "%d%d%03d",\$1,\$2,\$3}'`
+ fi # }
+- LSOF_CFGF="-DLINUXV=$LSOF_VERS"
++ LSOF_CFGF="${CFLAGS} -DLINUXV=$LSOF_VERS"
+ if test $LSOF_VERS -lt 21072 # {
+ then
+ echo ""
+@@ -4828,7 +4828,7 @@
+ if test "X$LSOF_LIB_NO" = "X" # {
+ then
+ echo "" >> $LSOF_MKFC
+- echo "CFGL= $LSOF_FCFGL -L./$LSOF_LIB -llsof $LSOF_CFGL" >> $LSOF_MKFC
++ echo "CFGL= $LSOF_FCFGL -L./$LSOF_LIB -llsof $LSOF_CFGL ${LDFLAGS}" >> $LSOF_MKFC
+ fi # }
+ echo "" >> $LSOF_MKFC
+ if test "X$LSOF_DEBUG" = "X" # {
+Only in b: Configure.orig
+diff -ur a/Customize b/Customize
+--- a/Customize 2007-05-18 15:02:13 +0100
++++ b/Customize 2007-05-18 15:05:46 +0100
+@@ -110,7 +110,7 @@
+ do
+ echo ""
+ echo $EO "Do you want to customize (y|n) [y]? $EC"
+- read ANS EXCESS
++ ANS=y
+ if test "X$ANS" = "Xn" -o "X$ANS" = "XN"
+ then
+ exit 0
+@@ -214,7 +214,7 @@
+ else
+ echo $EO "Enable HASSECURITY (y|n) [n]? $EC"
+ fi
+- read ANS EXCESS
++ ANS=y
+ if test "X$ANS" = "Xy" -o "X$ANS" = "XY"
+ then
+ echo ""
+@@ -277,7 +277,7 @@
+ else
+ echo $EO "Enable HASNOSOCKSECURITY (y|n) [n]? $EC"
+ fi
+- read ANS EXCESS
++ ANS=y
+ if test "X$ANS" = "Xy" -o "X$ANS" = "XY"
+ then
+ echo ""
+@@ -339,7 +339,7 @@
+ else
+ echo $EO "Disable WARNINGSTATE? (y|n) [n]? $EC"
+ fi
+- read ANS EXCESS
++ ANS=n
+ if test "X$ANS" = "Xy" -o "X$ANS" = "XY"
+ then
+ echo ""
+@@ -408,7 +408,7 @@
+ else
+ echo $EO "Enable WARNDEVACCESS (y|n) [n]? $EC"
+ fi
+- read ANS EXCESS
++ ANS=n
+ if test "X$ANS" = "Xy" -o "X$ANS" = "XY"
+ then
+ echo ""
+@@ -491,7 +491,7 @@
+ else
+ echo $EO "Enable HASDCACHE (y|n) [n]? $EC"
+ fi
+- read ANS EXCESS
++ ANS=n
+ if test "X$ANS" = "Xy" -o "X$ANS" = "XY"
+ then
+ echo ""
+@@ -545,7 +545,7 @@
+ do
+ echo ""
+ echo $EO "Do you want to change path options (y|n) [n]? $EC"
+- read ANS EXCESS
++ ANS=n
+ if test "X$ANS" = "Xy" -o "X$ANS" = "XY"
+ then
+ CDC=1
+@@ -928,7 +928,7 @@
+ else
+ echo $EO "Enable HASKERNIDCK (y|n) [n]? $EC"
+ fi
+- read ANS EXCESS
++ ANS=y
+ if test "X$ANS" = "Xy" -o "X$ANS" = "XY"
+ then
+ echo ""
+@@ -1125,7 +1125,7 @@
+ echo ""
+ echo "Do you want to rename $OLD to ${OLD}.old and replace it with"
+ echo $EO "$NEW (y|n) [y]? $EC"
+- read ANS EXCESS
++ ANS=y
+ if test "X$ANS" = "Xn" -o "X$ANS" = "XN"
+ then
+ END=1
+Only in b: Customize.orig
diff --git a/sys-process/lsof/files/lsof-4.78-freebsd.patch b/sys-process/lsof/files/lsof-4.78-freebsd.patch
new file mode 100644
index 000000000000..99a6cfd88be4
--- /dev/null
+++ b/sys-process/lsof/files/lsof-4.78-freebsd.patch
@@ -0,0 +1,18 @@
+diff -ur a/dialects/freebsd/dlsof.h b/dialects/freebsd/dlsof.h
+--- a/dialects/freebsd/dlsof.h 2006-03-28 00:29:11 +0100
++++ b/dialects/freebsd/dlsof.h 2007-05-18 15:08:19 +0100
+@@ -43,7 +43,6 @@
+ #include <nlist.h>
+ #include <setjmp.h>
+ #include <signal.h>
+-#include <string.h>
+ #include <unistd.h>
+
+ # if FREEBSDV>=4000
+@@ -550,4 +549,6 @@
+ #define NCACHE_VROOT VV_ROOT
+ #endif /* FREEBSDV>=5000 */
+
++#include <string.h>
++
+ #endif /* FREEBSD_LSOF_H */
diff --git a/sys-process/lsof/lsof-4.78.ebuild b/sys-process/lsof/lsof-4.78.ebuild
index 9de5745d4346..5c436196b326 100644
--- a/sys-process/lsof/lsof-4.78.ebuild
+++ b/sys-process/lsof/lsof-4.78.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-process/lsof/lsof-4.78.ebuild,v 1.1 2007/05/12 11:39:52 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-process/lsof/lsof-4.78.ebuild,v 1.2 2007/05/18 14:18:44 uberlord Exp $
inherit eutils flag-o-matic fixheadtails toolchain-funcs
@@ -13,7 +13,7 @@ SRC_URI="ftp://lsof.itap.purdue.edu/pub/tools/unix/lsof/${MY_P}.tar.bz2
LICENSE="lsof"
SLOT="0"
-KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x86-fbsd"
IUSE="static"
DEPEND=""
@@ -29,13 +29,16 @@ src_unpack() {
cd "${S}"
ht_fix_file Configure Customize
touch .neverInv
- epatch "${FILESDIR}"/4.73-answer-config.patch
+ epatch "${FILESDIR}/${P}"-answer-config.patch
+ epatch "${FILESDIR}/${P}"-freebsd.patch
}
src_compile() {
use static && append-ldflags -static
- ./Configure linux || die "configure failed"
+ local target="linux"
+ use kernel_FreeBSD && target=freebsd
+ ./Configure ${target} || die "configure failed"
# Make sure we use proper toolchain
sed -i \