summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDiego Elio Pettenò <flameeyes@gentoo.org>2008-10-03 16:50:46 +0000
committerDiego Elio Pettenò <flameeyes@gentoo.org>2008-10-03 16:50:46 +0000
commitaf3c8733949ca313d1afdb06fface7a7080c7572 (patch)
treee305178dcef836f13c9968d3514a17abda6eb6c0 /sys-process/lsof
parentUse EAPI=2 and USE dependencies (diff)
downloadgentoo-2-af3c8733949ca313d1afdb06fface7a7080c7572.tar.gz
gentoo-2-af3c8733949ca313d1afdb06fface7a7080c7572.tar.bz2
gentoo-2-af3c8733949ca313d1afdb06fface7a7080c7572.zip
Add a new revision that doesn't install the static library. Since we don't install any header file it's pointless to have it. Also, it's just an internal help library, of no use once lsof is installed.
(Portage version: 2.2_rc11/cvs/Linux 2.6.26-gentoo-r1 x86_64)
Diffstat (limited to 'sys-process/lsof')
-rw-r--r--sys-process/lsof/ChangeLog9
-rw-r--r--sys-process/lsof/lsof-4.80-r1.ebuild67
2 files changed, 75 insertions, 1 deletions
diff --git a/sys-process/lsof/ChangeLog b/sys-process/lsof/ChangeLog
index 2bc3b83b7c41..d0c08a38f41d 100644
--- a/sys-process/lsof/ChangeLog
+++ b/sys-process/lsof/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for sys-process/lsof
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-process/lsof/ChangeLog,v 1.49 2008/08/18 18:55:05 ranger Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-process/lsof/ChangeLog,v 1.50 2008/10/03 16:50:45 flameeyes Exp $
+
+*lsof-4.80-r1 (03 Oct 2008)
+
+ 03 Oct 2008; Diego Pettenò <flameeyes@gentoo.org> +lsof-4.80-r1.ebuild:
+ Add a new revision that doesn't install the static library. Since we don't
+ install any header file it's pointless to have it. Also, it's just an
+ internal help library, of no use once lsof is installed.
18 Aug 2008; Brent Baude <ranger@gentoo.org> lsof-4.78-r2.ebuild:
stable ppc64, bug 234929
diff --git a/sys-process/lsof/lsof-4.80-r1.ebuild b/sys-process/lsof/lsof-4.80-r1.ebuild
new file mode 100644
index 000000000000..1b878f485fb5
--- /dev/null
+++ b/sys-process/lsof/lsof-4.80-r1.ebuild
@@ -0,0 +1,67 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-process/lsof/lsof-4.80-r1.ebuild,v 1.1 2008/10/03 16:50:46 flameeyes Exp $
+
+inherit eutils flag-o-matic fixheadtails toolchain-funcs
+
+MY_P=${P/-/_}
+DESCRIPTION="Lists open files for running Unix processes"
+HOMEPAGE="ftp://lsof.itap.purdue.edu/pub/tools/unix/lsof/"
+SRC_URI="ftp://lsof.itap.purdue.edu/pub/tools/unix/lsof/${MY_P}.tar.bz2
+ ftp://vic.cc.purdue.edu/pub/tools/unix/lsof/${MY_P}.tar.bz2
+ ftp://ftp.cerias.purdue.edu/pub/tools/unix/sysutils/lsof/${MY_P}.tar.bz2"
+
+LICENSE="lsof"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x86-fbsd"
+IUSE="static selinux"
+
+DEPEND="selinux? ( sys-libs/libselinux )"
+
+S=${WORKDIR}/${MY_P}/${MY_P}_src
+
+src_unpack() {
+ unpack ${A}
+ cd ${MY_P}
+ unpack ./${MY_P}_src.tar
+
+ # now patch the scripts to automate everything
+ cd "${S}"
+ ht_fix_file Configure Customize
+ touch .neverInv
+ epatch "${FILESDIR}"/${PN}-4.78-answer-config.patch
+ #Fix automagic dependency on libselinux. Bug 188272.
+ if ! use selinux; then
+ sed -i \
+ -e 's/ -DHASSELINUX//' \
+ -e 's/ -lselinux//' \
+ Configure || die "Sed failed. 404. WTF..."
+ fi
+}
+
+src_compile() {
+ use static && append-ldflags -static
+
+ local target="linux"
+ use kernel_FreeBSD && target=freebsd
+ ./Configure ${target} || die "configure failed"
+
+ # Make sure we use proper toolchain
+ sed -i \
+ -e "/^CC=/s:cc:$(tc-getCC):" \
+ -e "/^AR=/s:ar:$(tc-getAR):" \
+ -e "/^RANLIB=/s:ranlib:$(tc-getRANLIB):" \
+ Makefile lib/Makefile
+
+ emake DEBUG="" all || die "emake failed"
+}
+
+src_install() {
+ dobin lsof || die "dosbin"
+
+ insinto /usr/share/lsof/scripts
+ doins scripts/*
+
+ doman lsof.8
+ dodoc 00*
+}