summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2009-02-08 19:53:55 +0000
committerMike Frysinger <vapier@gentoo.org>2009-02-08 19:53:55 +0000
commit17e6ae6a6db0ba4688d9c696769fb872d9973ad1 (patch)
treee206eee7acdddd2b32b2cca34de54e468fbf94b0 /sys-process/numactl
parentVersion bump (diff)
downloadgentoo-2-17e6ae6a6db0ba4688d9c696769fb872d9973ad1.tar.gz
gentoo-2-17e6ae6a6db0ba4688d9c696769fb872d9973ad1.tar.bz2
gentoo-2-17e6ae6a6db0ba4688d9c696769fb872d9973ad1.zip
old
Diffstat (limited to 'sys-process/numactl')
-rw-r--r--sys-process/numactl/files/numactl-0.9.11-make-jobs.patch19
-rw-r--r--sys-process/numactl/files/numactl-1.0.2-migrate_pages-fix.diff34
-rw-r--r--sys-process/numactl/numactl-1.0.2.ebuild45
3 files changed, 0 insertions, 98 deletions
diff --git a/sys-process/numactl/files/numactl-0.9.11-make-jobs.patch b/sys-process/numactl/files/numactl-0.9.11-make-jobs.patch
deleted file mode 100644
index 4db298f570f2..000000000000
--- a/sys-process/numactl/files/numactl-0.9.11-make-jobs.patch
+++ /dev/null
@@ -1,19 +0,0 @@
---- numactl-0.9.11/Makefile.orig 2007-04-03 13:44:54.000000000 +0200
-+++ numactl-0.9.11/Makefile 2007-04-03 13:46:21.000000000 +0200
-@@ -140,12 +140,13 @@
-
- html: ${HTML}
-
--html/numactl.html: numactl.8
-+htmldir:
- if [ ! -d html ] ; then mkdir html ; fi
-+
-+html/numactl.html: numactl.8 htmldir
- groff -Thtml -man numactl.8 > html/numactl.html
-
--html/numa.html: numa.3
-- if [ ! -d html ] ; then mkdir html ; fi
-+html/numa.html: numa.3 htmldir
- groff -Thtml -man numa.3 > html/numa.html
-
- depend: .depend
diff --git a/sys-process/numactl/files/numactl-1.0.2-migrate_pages-fix.diff b/sys-process/numactl/files/numactl-1.0.2-migrate_pages-fix.diff
deleted file mode 100644
index e2fb26476863..000000000000
--- a/sys-process/numactl/files/numactl-1.0.2-migrate_pages-fix.diff
+++ /dev/null
@@ -1,34 +0,0 @@
-Date: Thu, 1 Nov 2007 21:32:25 +0900
-From: Paul Mundt <lethal@linux-sh.org>
-To: Andi Kleen <ak@suse.de>
-Subject: [PATCH] numactl: Fix bogus __NR_migrate_pages reference.
-Message-ID: <20071101123225.GA28035@linux-sh.org>
-MIME-Version: 1.0
-Content-Type: text/plain; charset=us-ascii
-Content-Disposition: inline
-User-Agent: Mutt/1.5.13 (2006-08-11)
-Status: RO
-
-syscall.c does a bunch of ifdefs to make sure a platform has all of the
-syscall numbers defined in the headers or falls back on provided
-defaults. Unfortunately __NR_migrate_pages was wrong (it was written as
-NR_migratepages), so the common definitions were never picked up.
-
-Signed-off-by: Paul Mundt <lethal@linux-sh.org>
-
----
-
- syscall.c | 2 +-
- 1 file changed, 1 insertion(+), 1 deletion(-)
-
---- numactl-1.0.2.orig/syscall.c 2007-08-16 23:36:23.000000000 +0900
-+++ numactl-1.0.2/syscall.c 2007-11-01 21:22:47.000000000 +0900
-@@ -23,7 +23,7 @@
- #define WEAK __attribute__((weak))
-
- #if !defined(__NR_mbind) || !defined(__NR_set_mempolicy) || \
-- !defined(__NR_get_mempolicy) || !defined(NR_migratepages)
-+ !defined(__NR_get_mempolicy) || !defined(__NR_migrate_pages)
-
- #if defined(__x86_64__)
-
diff --git a/sys-process/numactl/numactl-1.0.2.ebuild b/sys-process/numactl/numactl-1.0.2.ebuild
deleted file mode 100644
index 8e0ab2abad48..000000000000
--- a/sys-process/numactl/numactl-1.0.2.ebuild
+++ /dev/null
@@ -1,45 +0,0 @@
-# Copyright 1999-2008 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-process/numactl/numactl-1.0.2.ebuild,v 1.1 2008/01/07 03:12:42 vapier Exp $
-
-inherit base eutils toolchain-funcs
-
-DESCRIPTION="Utilities and libraries for NUMA systems."
-HOMEPAGE="ftp://ftp.suse.com/pub/people/ak/numa/"
-SRC_URI="ftp://ftp.suse.com/pub/people/ak/numa/${P}.tar.gz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~amd64 ~ppc ~x86"
-IUSE=""
-
-RDEPEND="dev-lang/perl"
-DEPEND="${RDEPEND}
- sys-apps/groff"
-
-src_unpack() {
- unpack ${A}
- cd "${S}"
- epatch "${FILESDIR}"/numactl-1.0.2-migrate_pages-fix.diff
- sed -i 's:/man2:/man5:' Makefile || die
-}
-
-src_compile() {
- emake all html \
- CC="$(tc-getCC)" CFLAGS="${CFLAGS}" LDFLAGS="${LDFLAGS}" \
- || die "emake failed"
-}
-
-src_install() {
- emake install prefix="${D}/usr" || die
- doman *.8 || die # makefile doesnt get them all
- dodoc README TODO CHANGES DESIGN
- dohtml html/*html
-}
-
-src_test() {
- einfo "The only generically safe test is regress2."
- einfo "The other test cases require 2 NUMA nodes."
- cd test
- ./regress2 || die "regress2 failed!"
-}