summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorFabian Groffen <grobian@gentoo.org>2011-05-18 18:24:11 +0000
committerFabian Groffen <grobian@gentoo.org>2011-05-18 18:24:11 +0000
commit17c52a1545892e64ee6b6efac34d9a4128b18f10 (patch)
treecbf9bfcc2286d2d55e257d27d0d664adae69a9c0 /sys-process/pkill-darwin
parentfix build with long flag strings, bug #349085 (diff)
downloadgentoo-2-17c52a1545892e64ee6b6efac34d9a4128b18f10.tar.gz
gentoo-2-17c52a1545892e64ee6b6efac34d9a4128b18f10.tar.bz2
gentoo-2-17c52a1545892e64ee6b6efac34d9a4128b18f10.zip
Import pkill-darwin, a port of FreeBSD's pkill for Darwin that I made.
(Portage version: 2.2.01.18252-prefix/cvs/Darwin powerpc)
Diffstat (limited to 'sys-process/pkill-darwin')
-rw-r--r--sys-process/pkill-darwin/ChangeLog10
-rw-r--r--sys-process/pkill-darwin/metadata.xml5
-rw-r--r--sys-process/pkill-darwin/pkill-darwin-1.0.ebuild39
3 files changed, 54 insertions, 0 deletions
diff --git a/sys-process/pkill-darwin/ChangeLog b/sys-process/pkill-darwin/ChangeLog
new file mode 100644
index 000000000000..c9ac9b8fe955
--- /dev/null
+++ b/sys-process/pkill-darwin/ChangeLog
@@ -0,0 +1,10 @@
+# ChangeLog for sys-process/pkill-darwin
+# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sys-process/pkill-darwin/ChangeLog,v 1.1 2011/05/18 18:24:11 grobian Exp $
+
+*pkill-darwin-1.0 (18 May 2011)
+
+ 18 May 2011; Fabian Groffen <grobian@gentoo.org> +pkill-darwin-1.0.ebuild,
+ +metadata.xml:
+ Import pkill-darwin, a port of FreeBSD's pkill for Darwin that I made.
+
diff --git a/sys-process/pkill-darwin/metadata.xml b/sys-process/pkill-darwin/metadata.xml
new file mode 100644
index 000000000000..f737f232e3bf
--- /dev/null
+++ b/sys-process/pkill-darwin/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>prefix</herd>
+</pkgmetadata>
diff --git a/sys-process/pkill-darwin/pkill-darwin-1.0.ebuild b/sys-process/pkill-darwin/pkill-darwin-1.0.ebuild
new file mode 100644
index 000000000000..ff8edfa26a2f
--- /dev/null
+++ b/sys-process/pkill-darwin/pkill-darwin-1.0.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-process/pkill-darwin/pkill-darwin-1.0.ebuild,v 1.1 2011/05/18 18:24:11 grobian Exp $
+
+EAPI=3
+
+inherit toolchain-funcs
+
+DESCRIPTION="pgrep(1) and pkill(1) for Darwin"
+HOMEPAGE="http://prefix.gentooexperimental.org:8000/pkill-darwin/"
+SRC_URI="http://www.gentoo.org/~grobian/distfiles/${P}.tar.xz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~ppc-macos ~x86-macos ~x64-macos"
+IUSE=""
+
+src_compile() {
+ echo $(tc-getCC) ${CFLAGS} -o pkill ${LDFLAGS} pkill.c
+ $(tc-getCC) ${CFLAGS} -o pkill ${LDFLAGS} pkill.c || die
+ # don't link, such that the suid trick described below won't make people
+ # suid their pkill too
+ cp pkill pgrep || die
+ ln -s pkill.1 pgrep.1 || die
+}
+
+src_install() {
+ into /usr
+ dobin pkill pgrep
+ doman pkill.1 pgrep.1
+}
+
+pkg_postinst() {
+ einfo "If you you want pgrep to be able to show and match on the arguments"
+ ewarn "of all processes, you will have to make pgrep suid root. To do so"
+ ewarn "you have to perform the following steps:"
+ ewarn " % sudo chown root ${EPREFIX}/usr/bin/pgrep"
+ ewarn " % sudo chmod u+s ${EPREFIX}/usr/bin/prgep"
+}