summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2011-04-25 15:48:10 +0000
committerJustin Lecher <jlec@gentoo.org>2011-04-25 15:48:10 +0000
commit2e93c368602184e7ecfe2fa9519674a61d3139f7 (patch)
tree9bf58e87f3cc49bc6dbd6ec43a43fd9829d1791c /sys-process/psinfo/psinfo-0.12.ebuild
parentFix deprecation warnings. (diff)
downloadgentoo-2-2e93c368602184e7ecfe2fa9519674a61d3139f7.tar.gz
gentoo-2-2e93c368602184e7ecfe2fa9519674a61d3139f7.tar.bz2
gentoo-2-2e93c368602184e7ecfe2fa9519674a61d3139f7.zip
New addition, thanks Jiri Tyr for first ebuild, #242208
(Portage version: 2.2.0_alpha30/cvs/Linux x86_64)
Diffstat (limited to 'sys-process/psinfo/psinfo-0.12.ebuild')
-rw-r--r--sys-process/psinfo/psinfo-0.12.ebuild32
1 files changed, 32 insertions, 0 deletions
diff --git a/sys-process/psinfo/psinfo-0.12.ebuild b/sys-process/psinfo/psinfo-0.12.ebuild
new file mode 100644
index 000000000000..a0278348801a
--- /dev/null
+++ b/sys-process/psinfo/psinfo-0.12.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-process/psinfo/psinfo-0.12.ebuild,v 1.1 2011/04/25 15:48:10 jlec Exp $
+
+EAPI="4"
+
+inherit eutils toolchain-funcs
+
+DESCRIPTION="Process information and statistics using the kernel /proc interface"
+HOMEPAGE="http://www.ward.nu/computer/psinfo/"
+SRC_URI="http://www.ward.nu/computer/${PN}/${P}.tar.gz"
+
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+LICENSE="GPL-2"
+IUSE=""
+
+src_prepare () {
+ epatch "${FILESDIR}"/${P}-asneeded.patch
+ tc-export CC
+}
+
+#src_compile() {
+# emake \
+# CFLAGS="${CFLAGS}" \
+# CC=$(tc-getCC)
+#}
+
+#src_install() {
+# dobin ${PN}
+# dodoc README
+#}