summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2008-12-25 22:24:45 +0000
committerMike Frysinger <vapier@gentoo.org>2008-12-25 22:24:45 +0000
commit9d610326f5990ffc003a0d1e3f63cbd9e9157150 (patch)
tree21a0a2a298d3779b0ed18720c85b93691f432f37 /sys-process/runit
parentold (diff)
downloadgentoo-2-9d610326f5990ffc003a0d1e3f63cbd9e9157150.tar.gz
gentoo-2-9d610326f5990ffc003a0d1e3f63cbd9e9157150.tar.bz2
gentoo-2-9d610326f5990ffc003a0d1e3f63cbd9e9157150.zip
Version bump #190983 by Daniel Pielmeier (billie).
(Portage version: 2.2_rc18/cvs/Linux 2.6.28 x86_64)
Diffstat (limited to 'sys-process/runit')
-rw-r--r--sys-process/runit/ChangeLog7
-rw-r--r--sys-process/runit/runit-2.0.0.ebuild65
2 files changed, 71 insertions, 1 deletions
diff --git a/sys-process/runit/ChangeLog b/sys-process/runit/ChangeLog
index 47e54a9fef98..ea2c789b6fd8 100644
--- a/sys-process/runit/ChangeLog
+++ b/sys-process/runit/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sys-process/runit
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-process/runit/ChangeLog,v 1.29 2008/10/14 15:00:28 flameeyes Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-process/runit/ChangeLog,v 1.30 2008/12/25 22:24:45 vapier Exp $
+
+*runit-2.0.0 (25 Dec 2008)
+
+ 25 Dec 2008; Mike Frysinger <vapier@gentoo.org> +runit-2.0.0.ebuild:
+ Version bump #190983 by Daniel Pielmeier (billie).
14 Oct 2008; Diego Pettenò <flameeyes@gentoo.org> runit-1.7.0.ebuild:
Set compiler and linker during src_compile rather than unpack.
diff --git a/sys-process/runit/runit-2.0.0.ebuild b/sys-process/runit/runit-2.0.0.ebuild
new file mode 100644
index 000000000000..99b7d509b5e0
--- /dev/null
+++ b/sys-process/runit/runit-2.0.0.ebuild
@@ -0,0 +1,65 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-process/runit/runit-2.0.0.ebuild,v 1.1 2008/12/25 22:24:45 vapier Exp $
+
+inherit toolchain-funcs flag-o-matic
+
+DESCRIPTION="A UNIX init scheme with service supervision"
+HOMEPAGE="http://smarden.org/runit/"
+SRC_URI="http://smarden.org/runit/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
+IUSE="static"
+
+DEPEND=""
+
+S=${WORKDIR}/admin/${P}
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ # we either build everything or nothing static
+ sed -i -e 's:-static: :' src/Makefile
+}
+
+src_compile() {
+ cd src
+ use static && append-ldflags -static
+
+ echo "$(tc-getCC) ${CFLAGS}" > conf-cc
+ echo "$(tc-getCC) ${LDFLAGS}" > conf-ld
+
+ emake || die "make failed"
+}
+
+src_install() {
+ dodir /var
+ keepdir /etc/runit{,/runsvdir{,/default,/all}}
+ dosym default /etc/runit/runsvdir/current
+ dosym ../etc/runit/runsvdir/current /var/service
+
+ cd src
+ dobin $(<../package/commands) || die "dobin"
+ dodir /sbin
+ mv "${D}"/usr/bin/{runit-init,runit,utmpset} "${D}"/sbin/ || die "dosbin"
+
+ cd "${S}"
+ dodoc package/{CHANGES,README,THANKS,TODO}
+ dohtml doc/*.html
+ doman man/*.[18]
+
+ exeinto /etc/runit
+ doexe "${FILESDIR}"/{1,2,ctrlaltdel} || die
+ newexe "${FILESDIR}"/3-1.4 3 || die
+ for tty in tty1 tty2 tty3 tty4 tty5 tty6; do
+ exeinto /etc/runit/runsvdir/all/getty-$tty/
+ for script in run finish; do
+ newexe "${FILESDIR}"/$script.getty $script
+ dosed "s:TTY:${tty}:g" /etc/runit/runsvdir/all/getty-$tty/$script
+ done
+ dosym ../all/getty-$tty /etc/runit/runsvdir/default/getty-$tty
+ done
+}