summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThilo Bangert <bangert@gentoo.org>2011-01-28 22:11:08 +0000
committerThilo Bangert <bangert@gentoo.org>2011-01-28 22:11:08 +0000
commit0173fe73761528e9e5fd5f90061d0140bf5ec86b (patch)
treef784578e02ee566c4982bec1bf5ff2e8bd1599c3 /sys-process
parentFix typo in if statement (diff)
downloadgentoo-2-0173fe73761528e9e5fd5f90061d0140bf5ec86b.tar.gz
gentoo-2-0173fe73761528e9e5fd5f90061d0140bf5ec86b.tar.bz2
gentoo-2-0173fe73761528e9e5fd5f90061d0140bf5ec86b.zip
version bump
(Portage version: 2.2.0_alpha19/cvs/Linux i686)
Diffstat (limited to 'sys-process')
-rw-r--r--sys-process/daemontools-encore/ChangeLog8
-rw-r--r--sys-process/daemontools-encore/daemontools-encore-1.05.ebuild51
2 files changed, 58 insertions, 1 deletions
diff --git a/sys-process/daemontools-encore/ChangeLog b/sys-process/daemontools-encore/ChangeLog
index bb566e2f0814..f255b386bb8f 100644
--- a/sys-process/daemontools-encore/ChangeLog
+++ b/sys-process/daemontools-encore/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sys-process/daemontools-encore
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-process/daemontools-encore/ChangeLog,v 1.2 2011/01/18 19:31:39 bangert Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-process/daemontools-encore/ChangeLog,v 1.3 2011/01/28 22:11:07 bangert Exp $
+
+*daemontools-encore-1.05 (28 Jan 2011)
+
+ 28 Jan 2011; Thilo Bangert <bangert@gentoo.org>
+ +daemontools-encore-1.05.ebuild:
+ version bump
*daemontools-encore-1.04 (18 Jan 2011)
diff --git a/sys-process/daemontools-encore/daemontools-encore-1.05.ebuild b/sys-process/daemontools-encore/daemontools-encore-1.05.ebuild
new file mode 100644
index 000000000000..8081b909502d
--- /dev/null
+++ b/sys-process/daemontools-encore/daemontools-encore-1.05.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-process/daemontools-encore/daemontools-encore-1.05.ebuild,v 1.1 2011/01/28 22:11:08 bangert Exp $
+
+EAPI=3
+
+inherit flag-o-matic qmail
+
+DESCRIPTION="Collection of tools for managing UNIX services"
+HOMEPAGE="http://untroubled.org/daemontools-encore/"
+SRC_URI="${HOMEPAGE}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~x86 ~amd64"
+IUSE="selinux static"
+
+DEPEND=""
+RDEPEND="selinux? ( sec-policy/selinux-daemontools )
+ !sys-process/daemontools
+ !app-doc/daemontools-man"
+
+src_compile() {
+ use static && append-ldflags -static
+ qmail_set_cc
+ emake || die
+}
+
+src_install() {
+ keepdir /service
+
+ echo ${D}/usr/bin >conf-bin
+ echo ${D}/usr/share/man >conf-man
+ dodir /usr/bin
+ dodir /usr/share/man
+ emake install || die
+
+ dodoc ChangeLog CHANGES CHANGES.djb README TODO
+
+ newinitd "${FILESDIR}"/svscan.init-1.02 svscan || die
+}
+
+pkg_postinst() {
+ einfo
+ einfo "You can run daemontools using the svscan init.d script,"
+ einfo "or you could run it through inittab."
+ einfo "To use inittab, emerge supervise-scripts and run:"
+ einfo "svscan-add-to-inittab"
+ einfo "Then you can hup init with the command telinit q"
+ einfo
+}