summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeremy Olexa <darkside@gentoo.org>2009-10-30 03:59:48 +0000
committerJeremy Olexa <darkside@gentoo.org>2009-10-30 03:59:48 +0000
commit1f0262fcbc11c6546a48fd120506002e6f979724 (patch)
tree87c5a7bf17bfe8a10eb218967aad4a77d41ecb81 /sys-process
parentVersion bump (diff)
downloadgentoo-2-1f0262fcbc11c6546a48fd120506002e6f979724.tar.gz
gentoo-2-1f0262fcbc11c6546a48fd120506002e6f979724.tar.bz2
gentoo-2-1f0262fcbc11c6546a48fd120506002e6f979724.zip
revbump. Remove bundled setuptools and add it as a dep, patch by Kent Fredric in bug 289875. Other small cleanup
(Portage version: 2.1.6.13/cvs/Linux x86_64)
Diffstat (limited to 'sys-process')
-rw-r--r--sys-process/iotop/ChangeLog10
-rw-r--r--sys-process/iotop/files/iotop-0.3.2-rm-bundled-setuptools.patch11
-rw-r--r--sys-process/iotop/iotop-0.3.1.ebuild24
-rw-r--r--sys-process/iotop/iotop-0.3.2-r1.ebuild (renamed from sys-process/iotop/iotop-0.3.2.ebuild)19
-rw-r--r--sys-process/iotop/iotop-0.3.ebuild24
5 files changed, 34 insertions, 54 deletions
diff --git a/sys-process/iotop/ChangeLog b/sys-process/iotop/ChangeLog
index b28e04da120f..73ba3fc3b74c 100644
--- a/sys-process/iotop/ChangeLog
+++ b/sys-process/iotop/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for sys-process/iotop
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-process/iotop/ChangeLog,v 1.17 2009/10/02 15:23:49 darkside Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-process/iotop/ChangeLog,v 1.18 2009/10/30 03:59:47 darkside Exp $
+
+*iotop-0.3.2-r1 (30 Oct 2009)
+
+ 30 Oct 2009; Jeremy Olexa <darkside@gentoo.org> -iotop-0.3.ebuild,
+ -iotop-0.3.1.ebuild, -iotop-0.3.2.ebuild, +iotop-0.3.2-r1.ebuild,
+ +files/iotop-0.3.2-rm-bundled-setuptools.patch:
+ revbump. Remove bundled setuptools and add it as a dep, patch by Kent
+ Fredric in bug 289875. Other small cleanup
*iotop-0.3.2 (02 Oct 2009)
diff --git a/sys-process/iotop/files/iotop-0.3.2-rm-bundled-setuptools.patch b/sys-process/iotop/files/iotop-0.3.2-rm-bundled-setuptools.patch
new file mode 100644
index 000000000000..fd16f32bee8b
--- /dev/null
+++ b/sys-process/iotop/files/iotop-0.3.2-rm-bundled-setuptools.patch
@@ -0,0 +1,11 @@
+diff -Naur iotop-0.3.2/setup.py iotop-0.3.2.new/setup.py
+--- iotop-0.3.2/setup.py 2009-09-22 11:43:42.000000000 +0000
++++ iotop-0.3.2.new/setup.py 2009-10-20 14:28:59.158934815 +0000
+@@ -2,7 +2,6 @@
+
+ import sys
+
+-sys.path.insert(0, 'setuptools-0.6c9-py2.4.egg')
+ from setuptools import setup, find_packages
+ from iotop.version import VERSION
+
diff --git a/sys-process/iotop/iotop-0.3.1.ebuild b/sys-process/iotop/iotop-0.3.1.ebuild
deleted file mode 100644
index 21876259e2e4..000000000000
--- a/sys-process/iotop/iotop-0.3.1.ebuild
+++ /dev/null
@@ -1,24 +0,0 @@
-# Copyright 1999-2009 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-process/iotop/iotop-0.3.1.ebuild,v 1.2 2009/09/24 13:56:48 armin76 Exp $
-
-EAPI=2
-
-inherit distutils linux-info
-
-DESCRIPTION="Iotop has a top-like UI used to show which process is using the I/O."
-HOMEPAGE="http://guichaz.free.fr/iotop/"
-SRC_URI="${HOMEPAGE}/files/${P}.tar.bz2"
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~amd64 ~hppa ~ia64 ~ppc ~sparc ~x86"
-IUSE=""
-RDEPEND=">=dev-lang/python-2.5[ncurses]"
-DEPEND="${RDEPEND}"
-CONFIG_CHECK="~TASK_IO_ACCOUNTING ~TASKSTATS"
-DOCS="THANKS"
-
-src_install() {
- distutils_src_install
- doman iotop.1
-}
diff --git a/sys-process/iotop/iotop-0.3.2.ebuild b/sys-process/iotop/iotop-0.3.2-r1.ebuild
index f9d282c22c31..e514ef7bd9d6 100644
--- a/sys-process/iotop/iotop-0.3.2.ebuild
+++ b/sys-process/iotop/iotop-0.3.2-r1.ebuild
@@ -1,22 +1,31 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-process/iotop/iotop-0.3.2.ebuild,v 1.1 2009/10/02 15:23:49 darkside Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-process/iotop/iotop-0.3.2-r1.ebuild,v 1.1 2009/10/30 03:59:47 darkside Exp $
EAPI=2
inherit distutils linux-info
-DESCRIPTION="Iotop has a top-like UI used to show which process is using the I/O."
+DESCRIPTION="Iotop has a top-like UI used to show which process is using the I/O"
HOMEPAGE="http://guichaz.free.fr/iotop/"
-SRC_URI="${HOMEPAGE}/files/${P}.tar.bz2"
+SRC_URI="http://guichaz.free.fr/iotop//files/${P}.tar.bz2"
+
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~amd64 ~hppa ~ia64 ~ppc ~sparc ~x86"
IUSE=""
-RDEPEND=">=dev-lang/python-2.5[ncurses]"
+
+RDEPEND=">=dev-lang/python-2.5[ncurses]
+ dev-python/setuptools"
DEPEND="${RDEPEND}"
+
CONFIG_CHECK="~TASK_IO_ACCOUNTING ~TASKSTATS"
-DOCS="THANKS"
+DOCS="NEWS README THANKS"
+
+src_prepare() {
+ distutils_src_prepare
+ epatch "${FILESDIR}/${P}-rm-bundled-setuptools.patch"
+}
src_install() {
distutils_src_install
diff --git a/sys-process/iotop/iotop-0.3.ebuild b/sys-process/iotop/iotop-0.3.ebuild
deleted file mode 100644
index 73f80bafd608..000000000000
--- a/sys-process/iotop/iotop-0.3.ebuild
+++ /dev/null
@@ -1,24 +0,0 @@
-# Copyright 1999-2009 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-process/iotop/iotop-0.3.ebuild,v 1.2 2009/07/13 14:54:54 josejx Exp $
-
-EAPI=2
-
-inherit distutils linux-info
-
-DESCRIPTION="Iotop has a top-like UI used to show which process is using the I/O."
-HOMEPAGE="http://guichaz.free.fr/iotop/"
-SRC_URI="${HOMEPAGE}/files/${P}.tar.bz2"
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~amd64 ~hppa ~ppc ~sparc ~x86"
-IUSE=""
-RDEPEND=">=dev-lang/python-2.5[ncurses]"
-DEPEND="${RDEPEND}"
-CONFIG_CHECK="~TASK_IO_ACCOUNTING ~TASKSTATS"
-DOCS="THANKS"
-
-src_install() {
- distutils_src_install
- doman iotop.1
-}