summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLars Wendler <polynomial-c@gentoo.org>2014-11-30 13:47:18 +0000
committerLars Wendler <polynomial-c@gentoo.org>2014-11-30 13:47:18 +0000
commit5cdb88db906c622dc82492494126eb1db4409ea8 (patch)
treeb48e98a597ffc5aa292b37ff3b2827896b9d49f8 /sys-process
parentAdd missing REQUIRED_USE. (diff)
downloadgentoo-2-5cdb88db906c622dc82492494126eb1db4409ea8.tar.gz
gentoo-2-5cdb88db906c622dc82492494126eb1db4409ea8.tar.bz2
gentoo-2-5cdb88db906c622dc82492494126eb1db4409ea8.zip
Version bump (bug #531212). Removed old
(Portage version: 2.2.14/cvs/Linux x86_64, signed Manifest commit with key 0x981CA6FC)
Diffstat (limited to 'sys-process')
-rw-r--r--sys-process/atop/ChangeLog8
-rw-r--r--sys-process/atop/atop-1.23.ebuild31
-rw-r--r--sys-process/atop/atop-2.1.ebuild48
-rw-r--r--sys-process/atop/files/atop-2.1-build.patch36
4 files changed, 91 insertions, 32 deletions
diff --git a/sys-process/atop/ChangeLog b/sys-process/atop/ChangeLog
index 95ef48446bbd..6eaaa4a543c9 100644
--- a/sys-process/atop/ChangeLog
+++ b/sys-process/atop/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sys-process/atop
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-process/atop/ChangeLog,v 1.48 2014/10/28 21:52:26 jer Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-process/atop/ChangeLog,v 1.49 2014/11/30 13:47:18 polynomial-c Exp $
+
+*atop-2.1 (30 Nov 2014)
+
+ 30 Nov 2014; Lars Wendler <polynomial-c@gentoo.org> -atop-1.23.ebuild,
+ +atop-2.1.ebuild, +files/atop-2.1-build.patch:
+ Version bump (bug #531212). Removed old.
28 Oct 2014; Jeroen Roovers <jer@gentoo.org> atop-2.0.2.ebuild,
files/atop-2.0.2-build.patch:
diff --git a/sys-process/atop/atop-1.23.ebuild b/sys-process/atop/atop-1.23.ebuild
deleted file mode 100644
index 09a8923620ce..000000000000
--- a/sys-process/atop/atop-1.23.ebuild
+++ /dev/null
@@ -1,31 +0,0 @@
-# Copyright 1999-2010 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-process/atop/atop-1.23.ebuild,v 1.6 2010/03/29 17:51:11 jer Exp $
-
-DESCRIPTION="Resource-specific view of processes"
-HOMEPAGE="http://www.atcomputing.nl/Tools/atop"
-SRC_URI="http://www.atconsultancy.nl/atop/packages/${P}.tar.gz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="amd64 hppa ppc x86"
-IUSE=""
-
-DEPEND="sys-process/acct"
-
-src_unpack() {
- unpack ${A}
- cd "${S}"
- sed -i \
- -e '/^CFLAGS/s: = -O : += :' \
- -e '/^LDFLAGS/s: = : += :' \
- Makefile
- cp "${FILESDIR}"/atop.rc atop.init
- chmod a+rx atop.init
- sed -i 's: root : :' atop.cron #191926
-}
-
-src_install() {
- emake DESTDIR="${D}" INIPATH=/etc/init.d install || die
- dodoc README
-}
diff --git a/sys-process/atop/atop-2.1.ebuild b/sys-process/atop/atop-2.1.ebuild
new file mode 100644
index 000000000000..47b1cf40e814
--- /dev/null
+++ b/sys-process/atop/atop-2.1.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-process/atop/atop-2.1.ebuild,v 1.1 2014/11/30 13:47:18 polynomial-c Exp $
+
+EAPI="4"
+
+inherit eutils toolchain-funcs
+
+MY_PV=${PV//_p/-}
+MY_P=${PN}-${MY_PV}
+
+DESCRIPTION="Resource-specific view of processes"
+HOMEPAGE="http://www.atoptool.nl/"
+SRC_URI="http://www.atoptool.nl/download/${MY_P}-1.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~mips ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux"
+IUSE=""
+
+RDEPEND="
+ sys-libs/ncurses
+ sys-process/acct
+"
+DEPEND="
+ ${RDEPEND}
+ virtual/pkgconfig
+"
+
+S=${WORKDIR}/${MY_P}
+
+src_prepare() {
+ epatch "${FILESDIR}"/${PN}-2.1-build.patch
+ tc-export CC PKG_CONFIG
+ cp "${FILESDIR}"/atop.rc atop.init
+ chmod a+rx atop.init
+ sed -i 's: root : :' atop.cron #191926
+ # prefixify
+ sed -i "s:/\(usr\|etc\|var\):${EPREFIX}/\1:g" Makefile
+}
+
+src_install() {
+ default
+ # useless -${PV} copies ?
+ rm -f "${ED}"/usr/bin/atop*-${PV}
+ dodoc "${ED}"/etc/cron.d/*
+ rm -r "${ED}"/etc/cron.d || die
+}
diff --git a/sys-process/atop/files/atop-2.1-build.patch b/sys-process/atop/files/atop-2.1-build.patch
new file mode 100644
index 000000000000..530b8996f076
--- /dev/null
+++ b/sys-process/atop/files/atop-2.1-build.patch
@@ -0,0 +1,36 @@
+--- atop-2.1/Makefile
++++ atop-2.1/Makefile
+@@ -17,7 +17,7 @@
+ PMPATH1 = /usr/lib/pm-utils/sleep.d
+ PMPATH2 = /usr/lib64/pm-utils/sleep.d
+
+-CFLAGS += -O2 -I. -Wall # -DHTTPSTATS
++CFLAGS += -I. -Wall # -DHTTPSTATS
+ OBJMOD0 = version.o
+ OBJMOD1 = various.o deviate.o procdbase.o
+ OBJMOD2 = acctproc.o photoproc.o photosyst.o rawlog.o ifprop.o parseable.o
+@@ -30,13 +30,13 @@
+ all: atop atopsar atopacctd
+
+ atop: atop.o $(ALLMODS) Makefile
+- $(CC) atop.o $(ALLMODS) -o atop -lncurses -lz -lm -lrt $(LDFLAGS)
++ $(CC) $(CFLAGS) $(LDFLAGS) atop.o $(ALLMODS) -o atop -lncurses -lz -lm -lrt
+
+ atopsar: atop
+ ln -sf atop atopsar
+
+ atopacctd: atopacctd.o netlink.o
+- $(CC) atopacctd.o netlink.o -o atopacctd $(LDFLAGS)
++ $(CC) $(CFLAGS) $(LDFLAGS) atopacctd.o netlink.o -o atopacctd
+
+ netlink.o: netlink.c
+ $(CC) -I. -Wall -c netlink.c
+@@ -49,6 +49,8 @@
+ then mkdir -p $(DESTDIR)$(LOGPATH); fi
+ if [ ! -d $(DESTDIR)$(BINPATH) ]; \
+ then mkdir -p $(DESTDIR)$(BINPATH); fi
++ if [ ! -d $(DESTDIR)$(SBINPATH) ]; \
++ then mkdir -p $(DESTDIR)$(SBINPATH); fi
+ if [ ! -d $(DESTDIR)$(SCRPATH) ]; \
+ then mkdir -p $(DESTDIR)$(SCRPATH); fi
+ if [ ! -d $(DESTDIR)$(MAN1PATH) ]; \