summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorWolfram Schlich <wschlich@gentoo.org>2007-01-17 23:22:40 +0000
committerWolfram Schlich <wschlich@gentoo.org>2007-01-17 23:22:40 +0000
commit80fd2cd5cc103fd7d86bdf8c498fa83515428a14 (patch)
treea9b38ba1b91f19c61acf3e5a9a2083b153c97037 /sys-process
parentStable on alpha wrt bug 161360 (diff)
downloadgentoo-2-80fd2cd5cc103fd7d86bdf8c498fa83515428a14.tar.gz
gentoo-2-80fd2cd5cc103fd7d86bdf8c498fa83515428a14.tar.bz2
gentoo-2-80fd2cd5cc103fd7d86bdf8c498fa83515428a14.zip
fix EDITOR stuff, now depends on nano.
(Portage version: 2.1.2_rc3-r7)
Diffstat (limited to 'sys-process')
-rw-r--r--sys-process/fcron/ChangeLog7
-rw-r--r--sys-process/fcron/fcron-3.0.1-r2.ebuild29
2 files changed, 11 insertions, 25 deletions
diff --git a/sys-process/fcron/ChangeLog b/sys-process/fcron/ChangeLog
index 692259522dc9..c4bef7b4950a 100644
--- a/sys-process/fcron/ChangeLog
+++ b/sys-process/fcron/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for sys-process/fcron
-# Copyright 2002-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-process/fcron/ChangeLog,v 1.19 2006/10/07 09:15:38 flameeyes Exp $
+# Copyright 2002-2007 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sys-process/fcron/ChangeLog,v 1.20 2007/01/17 23:22:40 wschlich Exp $
+
+ 17 Jan 2007; Wolfram Schlich <wschlich@gentoo.org> fcron-3.0.1-r2.ebuild:
+ fix EDITOR stuff, now depends on nano.
07 Oct 2006; Diego Pettenò <flameeyes@gentoo.org> fcron-3.0.1-r2.ebuild:
Change pam dependency on virtual/pam and add ~x86-fbsd keyword as per bug
diff --git a/sys-process/fcron/fcron-3.0.1-r2.ebuild b/sys-process/fcron/fcron-3.0.1-r2.ebuild
index 5e13c5f8eeda..773c9a7dbff9 100644
--- a/sys-process/fcron/fcron-3.0.1-r2.ebuild
+++ b/sys-process/fcron/fcron-3.0.1-r2.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2006 Gentoo Foundation
+# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-process/fcron/fcron-3.0.1-r2.ebuild,v 1.4 2006/10/07 09:15:38 flameeyes Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-process/fcron/fcron-3.0.1-r2.ebuild,v 1.5 2007/01/17 23:22:40 wschlich Exp $
inherit cron pam eutils
@@ -12,31 +12,14 @@ LICENSE="GPL-2"
KEYWORDS="~amd64 ~hppa ~mips ppc sparc ~x86 ~x86-fbsd"
IUSE="debug doc pam selinux"
-DEPEND="virtual/editor
+DEPEND="app-editors/nano
doc? ( >=app-text/docbook-dsssl-stylesheets-1.77 )
selinux? ( sys-libs/libselinux )
pam? ( virtual/pam )"
pkg_setup() {
- # sudo unsets EDITOR
- if [[ -z "${EDITOR}" ]] ; then
- eerror "EDITOR seems to be unset. If you use sudo, it may be the cause."
- eerror "Try using 'sudo env EDITOR=\${EDITOR} emerge' instead."
- die "Please set the EDITOR env variable to the path of a valid executable."
- fi
-
- # bug #65263
- # fcron's ./configure complains if EDITOR is not set to an absolute path,
- # so try to set it to the abs path if it isn't
- if [[ "${EDITOR}" != */* ]] ; then
- einfo "Attempting to deduce absolute path of ${EDITOR}"
- EDITOR=$(which ${EDITOR} 2>/dev/null)
- [[ -x "${EDITOR}" ]] || \
- die "Please set the EDITOR env variable to the path of a valid executable."
- fi
-
- ROOTUSER=$(egetent passwd 0 | cut -d':' -f1)
- ROOTGROUP=$(egetent group 0 | cut -d':' -f1)
+ ROOTUSER=$(egetent passwd 0 | cut -d ':' -f 1)
+ ROOTGROUP=$(egetent group 0 | cut -d ':' -f 1)
}
src_unpack() {
@@ -74,7 +57,7 @@ src_compile() {
--with-fifodir=/var/run \
--with-sendmail=/usr/sbin/sendmail \
--with-fcrondyn=yes \
- --with-editor=${EDITOR} \
+ --with-editor=/bin/nano \
--with-shell=/bin/sh \
${myconf} \
|| die "Configure problem"