summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBenedikt Boehm <hollow@gentoo.org>2008-06-01 10:20:49 +0000
committerBenedikt Boehm <hollow@gentoo.org>2008-06-01 10:20:49 +0000
commitb10a8d05021dadb2db2bb7852150373a2c5aac8e (patch)
tree9a72abded0224e245d3392cea82cec8abab4bfb9 /sys-process
parentfix #221673 (diff)
downloadgentoo-2-b10a8d05021dadb2db2bb7852150373a2c5aac8e.tar.gz
gentoo-2-b10a8d05021dadb2db2bb7852150373a2c5aac8e.tar.bz2
gentoo-2-b10a8d05021dadb2db2bb7852150373a2c5aac8e.zip
fix #219673
(Portage version: 2.1.5.2)
Diffstat (limited to 'sys-process')
-rw-r--r--sys-process/incron/ChangeLog8
-rw-r--r--sys-process/incron/files/incron-0.5.7-gcc43.patch51
-rw-r--r--sys-process/incron/incron-0.5.7.ebuild5
-rw-r--r--sys-process/incron/metadata.xml9
4 files changed, 64 insertions, 9 deletions
diff --git a/sys-process/incron/ChangeLog b/sys-process/incron/ChangeLog
index a0bf494d6fc9..0ea5841717df 100644
--- a/sys-process/incron/ChangeLog
+++ b/sys-process/incron/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for sys-process/incron
-# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-process/incron/ChangeLog,v 1.2 2007/12/19 20:56:37 hollow Exp $
+# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sys-process/incron/ChangeLog,v 1.3 2008/06/01 10:20:48 hollow Exp $
+
+ 01 Jun 2008; Benedikt Böhm <hollow@gentoo.org>
+ +files/incron-0.5.7-gcc43.patch, metadata.xml, incron-0.5.7.ebuild:
+ fix #219673
19 Dec 2007; Benedikt Böhm <hollow@gentoo.org>
files/incron-0.5.7-gentoo.patch:
diff --git a/sys-process/incron/files/incron-0.5.7-gcc43.patch b/sys-process/incron/files/incron-0.5.7-gcc43.patch
new file mode 100644
index 000000000000..b6a813c9a925
--- /dev/null
+++ b/sys-process/incron/files/incron-0.5.7-gcc43.patch
@@ -0,0 +1,51 @@
+--- a/appargs.cpp
++++ b/appargs.cpp
+@@ -19,6 +19,7 @@
+ *
+ */
+
++#include <string.h>
+
+ #include "strtok.h"
+
+--- a/icd-main.cpp
++++ b/icd-main.cpp
+@@ -23,6 +23,7 @@
+ #include <errno.h>
+ #include <sys/poll.h>
+ #include <sys/stat.h>
++#include <string.h>
+
+ #include "inotify-cxx.h"
+ #include "appinst.h"
+--- a/ict-main.cpp
++++ b/ict-main.cpp
+@@ -25,6 +25,7 @@
+ #include <fcntl.h>
+ #include <stdlib.h>
+ #include <limits.h>
++#include <string.h>
+
+ #include "inotify-cxx.h"
+ #include "appargs.h"
+--- a/incroncfg.cpp
++++ b/incroncfg.cpp
+@@ -17,6 +17,8 @@
+ #include <fstream>
+ #include <sstream>
+
++#include <string.h>
++
+ #include "incroncfg.h"
+
+
+--- a/usertable.cpp
++++ b/usertable.cpp
+@@ -25,6 +25,7 @@
+ #include <grp.h>
+ #include <stdlib.h>
+ #include <sys/stat.h>
++#include <string.h>
+
+ #include "usertable.h"
+ #include "incroncfg.h"
diff --git a/sys-process/incron/incron-0.5.7.ebuild b/sys-process/incron/incron-0.5.7.ebuild
index d18174fc8d00..bc5c1275eda6 100644
--- a/sys-process/incron/incron-0.5.7.ebuild
+++ b/sys-process/incron/incron-0.5.7.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2007 Gentoo Foundation
+# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-process/incron/incron-0.5.7.ebuild,v 1.1 2007/12/19 20:50:03 hollow Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-process/incron/incron-0.5.7.ebuild,v 1.2 2008/06/01 10:20:48 hollow Exp $
inherit eutils linux-info toolchain-funcs
@@ -23,6 +23,7 @@ src_unpack() {
unpack ${A}
cd "${S}"
epatch "${FILESDIR}"/${P}-gentoo.patch
+ epatch "${FILESDIR}"/${P}-gcc43.patch
}
src_compile() {
diff --git a/sys-process/incron/metadata.xml b/sys-process/incron/metadata.xml
index 6d96727da5ca..443a97a31b66 100644
--- a/sys-process/incron/metadata.xml
+++ b/sys-process/incron/metadata.xml
@@ -1,9 +1,8 @@
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
-<herd>no-herd</herd>
-<maintainer>
- <email>hollow@gentoo.org</email>
- <name>Benedikt Böhm</name>
-</maintainer>
+ <maintainer>
+ <email>hollow@gentoo.org</email>
+ <name>Benedikt Böhm</name>
+ </maintainer>
</pkgmetadata>